removed extra/mesa-demos

This commit is contained in:
Kevin Mihelich 2014-07-06 14:19:50 +00:00
parent 28bd8859a1
commit 50f1828b8a
3 changed files with 0 additions and 217 deletions

View file

@ -1,82 +0,0 @@
Disclaimer
Mesa is a 3-D graphics library with an API which is very similar to
that of OpenGL*
To the extent that Mesa utilizes the OpenGL command syntax or state
machine, it is being used with authorization from Silicon Graphics,
Inc.(SGI). However, the author does not possess an OpenGL license
from SGI, and makes no claim that Mesa is in any way a compatible
replacement for OpenGL or associated with SGI. Those who want a
licensed implementation of OpenGL should contact a licensed
vendor.
Please do not refer to the library as MesaGL (for legal
reasons). It's just Mesa or The Mesa 3-D graphics
library
* OpenGL is a trademark of Silicon Graphics Incorporated.
License / Copyright Information
The Mesa distribution consists of several components. Different copyrights
and licenses apply to different components. For example, GLUT is copyrighted
by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
device drivers are copyrighted by their authors. See below for a list of
Mesa's main components and the license for each.
The core Mesa library is licensed according to the terms of the MIT license.
This allows integration with the XFree86, Xorg and DRI projects.
The default Mesa license is as follows:
Copyright (C) 1999-2007 Brian Paul All Rights Reserved.
Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software"),
to deal in the Software without restriction, including without limitation
the rights to use, copy, modify, merge, publish, distribute, sublicense,
and/or sell copies of the Software, and to permit persons to whom the
Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Attention, Contributors
When contributing to the Mesa project you must agree to the licensing terms
of the component to which you're contributing.
The following section lists the primary components of the Mesa distribution
and their respective licenses.
Mesa Component Licenses
Component Location Primary Author License
----------------------------------------------------------------------------
Main Mesa code src/mesa/ Brian Paul Mesa (MIT)
Device drivers src/mesa/drivers/* See drivers See drivers
Ext headers include/GL/glext.h SGI SGI Free B
include/GL/glxext.h
GLUT src/glut/ Mark Kilgard Mark's copyright
Mesa GLU library src/glu/mesa/ Brian Paul GNU-LGPL
SGI GLU library src/glu/sgi/ SGI SGI Free B
demo programs progs/demos/ various see source files
X demos progs/xdemos/ Brian Paul see source files
SGI demos progs/samples/ SGI SGI copyright
RedBook demos progs/redbook/ SGI SGI copyright

View file

@ -1,41 +0,0 @@
# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - add mesa makedepend
pkgname='mesa-demos'
pkgver=8.1.0
pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="Mesa demos and tools"
url="http://mesa3d.sourceforge.net"
license=('custom')
depends=('libgl' 'glew')
makedepends=('mesa')
source=("ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2"
'LICENSE'
drawtex-resolve-glDrawTexfOES-extension-function.patch)
sha256sums=('9703fa0646b32a1e68d2abf5628f936f77bf97c69ffcaac90de380820a87a828'
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
'963b3e45b2eccafea50fdab4f2fac17bd308f4c15522c00d4787b50ebb25423a')
prepare() {
cd "${srcdir}/mesa-demos-${pkgver}"
# merged upstream
patch -Np1 -i ../drawtex-resolve-glDrawTexfOES-extension-function.patch
}
build() {
cd "${srcdir}/mesa-demos-${pkgver}"
./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/mesa-demos-${pkgver}"
make DESTDIR="${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
}

View file

@ -1,94 +0,0 @@
From 9c326a34e088971a3c11b2e5289cd1a8e4d439df Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tapani=20P=C3=A4lli?= <tapani.palli@intel.com>
Date: Wed, 30 Apr 2014 14:05:11 +0300
Subject: [PATCH] drawtex: resolve glDrawTexfOES extension function
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=78101
Signed-off-by: Tapani Pälli <tapani.palli@intel.com>
Reviewed-by: Brian Paul <brianp@vmware.com>
Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
---
src/egl/opengles1/drawtex.c | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/egl/opengles1/drawtex.c b/src/egl/opengles1/drawtex.c
index 524f931..1ba8ac7 100644
--- a/src/egl/opengles1/drawtex.c
+++ b/src/egl/opengles1/drawtex.c
@@ -25,13 +25,14 @@ static GLfloat width = 200, height = 200;
static GLboolean animate = GL_FALSE;
static int win;
+static PFNGLDRAWTEXFOESPROC glDrawTexfOES_func = NULL;
static void
draw(void)
{
glClear(GL_COLOR_BUFFER_BIT);
- glDrawTexfOES(view_posx, view_posy, 0.0, width, height);
+ glDrawTexfOES_func(view_posx, view_posy, 0.0, width, height);
}
@@ -128,6 +129,13 @@ init(void)
exit(1);
}
+ glDrawTexfOES_func = eglGetProcAddress("glDrawTexfOES");
+
+ if (!glDrawTexfOES_func) {
+ fprintf(stderr, "Sorry, failed to resolve glDrawTexfOES function\n");
+ exit(1);
+ }
+
glClearColor(0.4, 0.4, 0.4, 0.0);
make_smile_texture();
--
1.9.2
From 6ad8820c457845300806a2f9469599460ca96af9 Mon Sep 17 00:00:00 2001
From: Stefan Dirsch <sndirsch@suse.de>
Date: Thu, 8 May 2014 11:48:44 +0200
Subject: [PATCH] drawtex: fixed compiler warnings related to use of
eglGetProcAddress
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Add proper <EGL/egl.h> include and cast in order to fix compiler
warnings related to the use of eglGetProcAddress.
Reviewed-By: Tapani Pälli <tapani.palli@intel.com>
---
src/egl/opengles1/drawtex.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/egl/opengles1/drawtex.c b/src/egl/opengles1/drawtex.c
index 1ba8ac7..dc1de13 100644
--- a/src/egl/opengles1/drawtex.c
+++ b/src/egl/opengles1/drawtex.c
@@ -16,6 +16,7 @@
#include <string.h>
#include <GLES/gl.h>
#include <GLES/glext.h>
+#include <EGL/egl.h>
#include "eglut.h"
@@ -129,7 +130,7 @@ init(void)
exit(1);
}
- glDrawTexfOES_func = eglGetProcAddress("glDrawTexfOES");
+ glDrawTexfOES_func = (PFNGLDRAWTEXFOESPROC) eglGetProcAddress("glDrawTexfOES");
if (!glDrawTexfOES_func) {
fprintf(stderr, "Sorry, failed to resolve glDrawTexfOES function\n");
--
1.9.2