mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-base to 5.15.2+kde+r214-1
This commit is contained in:
parent
ddc9dde3fb
commit
50f3e5b1b9
2 changed files with 4 additions and 30 deletions
|
@ -8,9 +8,9 @@
|
|||
|
||||
pkgbase=qt5-base
|
||||
pkgname=(qt5-base qt5-xcb-private-headers)
|
||||
pkgver=5.15.2+kde+r211
|
||||
pkgver=5.15.2+kde+r214
|
||||
pkgrel=1
|
||||
_commit=f0f4d885ed2fb088cadc8e25c0161d37f9e8770b
|
||||
_commit=59b9316cd54ac956d000557c2bf8c4da07efbc0a
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
|
@ -35,12 +35,10 @@ groups=('qt' 'qt5')
|
|||
_pkgfqn=qtbase
|
||||
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
|
||||
qt5-base-cflags.patch
|
||||
qt5-base-nostrip.patch
|
||||
qt5-base-mariadb-10.6.patch)
|
||||
qt5-base-nostrip.patch)
|
||||
sha256sums=('SKIP'
|
||||
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
|
||||
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
|
||||
'dde1c2c7300a6e05b12145f0c0b180991aa5929a4bf13c026eef6511593f357b')
|
||||
'4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
|
||||
|
||||
pkgver() {
|
||||
cd $_pkgfqn
|
||||
|
@ -51,7 +49,6 @@ prepare() {
|
|||
cd ${_pkgfqn}
|
||||
|
||||
git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
|
||||
patch -p1 < ../qt5-base-mariadb-10.6.patch # Fix broken mysql version detection with mariadb 10.6
|
||||
|
||||
patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
|
||||
patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
diff --git a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||
index a641935dc5..19e6a8286d 100644
|
||||
--- a/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||
+++ b/src/plugins/sqldrivers/mysql/qsql_mysql.cpp
|
||||
@@ -1355,7 +1355,7 @@ bool QMYSQLDriver::open(const QString& db,
|
||||
}
|
||||
|
||||
#if MYSQL_VERSION_ID >= 50007
|
||||
- if (mysql_get_client_version() >= 50503 && mysql_get_server_version(d->mysql) >= 50503) {
|
||||
+ if (true) {
|
||||
// force the communication to be utf8mb4 (only utf8mb4 supports 4-byte characters)
|
||||
mysql_set_character_set(d->mysql, "utf8mb4");
|
||||
#if QT_CONFIG(textcodec)
|
||||
@@ -1371,8 +1371,7 @@ bool QMYSQLDriver::open(const QString& db,
|
||||
}
|
||||
#endif // MYSQL_VERSION_ID >= 50007
|
||||
|
||||
- d->preparedQuerysEnabled = mysql_get_client_version() >= 40108
|
||||
- && mysql_get_server_version(d->mysql) >= 40100;
|
||||
+ d->preparedQuerysEnabled = true;
|
||||
|
||||
#if QT_CONFIG(thread)
|
||||
mysql_thread_init();
|
Loading…
Reference in a new issue