extra/polymake to 4.12-2

This commit is contained in:
Kevin Mihelich 2024-06-21 22:57:13 +00:00
parent 8e81077dc5
commit 5100a3fd13
3 changed files with 33 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = polymake
pkgdesc = Open source software for research in polyhedral geometry
pkgver = 4.12
pkgrel = 1
pkgrel = 2
url = https://polymake.org/
arch = x86_64
license = GPL
@ -37,6 +37,8 @@ pkgbase = polymake
depends = zlib
optdepends = java-runtime: java module
source = https://polymake.org/lib/exe/fetch.php/download/polymake-4.12-minimal.tar.bz2
source = lrs-073.patch
sha256sums = bd5a667ffca4bf7eb8d51134030ce3df3b16dd9d0e800fafdb1ce835867640d9
sha256sums = 4795e9fc2dd23546ca7f6a112695f09f6b745517cff387a0f9f54aecf3272ef7
pkgname = polymake

View file

@ -8,7 +8,7 @@ highmem=1
pkgname=polymake
pkgver=4.12
pkgrel=1
pkgrel=2
_perlver=`perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]).".".($v->[2]);'`
pkgdesc='Open source software for research in polyhedral geometry'
arch=(x86_64)
@ -45,11 +45,14 @@ makedepends=(ant
permlib
soplex)
optdepends=('java-runtime: java module')
source=(https://polymake.org/lib/exe/fetch.php/download/polymake-${pkgver/.r/r}-minimal.tar.bz2)
sha256sums=('bd5a667ffca4bf7eb8d51134030ce3df3b16dd9d0e800fafdb1ce835867640d9')
source=(https://polymake.org/lib/exe/fetch.php/download/polymake-${pkgver/.r/r}-minimal.tar.bz2
lrs-073.patch)
sha256sums=('bd5a667ffca4bf7eb8d51134030ce3df3b16dd9d0e800fafdb1ce835867640d9'
'4795e9fc2dd23546ca7f6a112695f09f6b745517cff387a0f9f54aecf3272ef7')
prepare() {
sed -e 's|-lgmp|-lgmp -lmpfr|g' -i polymake-$pkgver/bundled/soplex/support/configure.pl # Fix soplex linking
patch -d polymake-$pkgver -p1 < lrs-073.patch # Fix build with lrs 073
}
build() {

View file

@ -0,0 +1,24 @@
diff -ru polymake-4.12.orig/bundled/lrs/apps/polytope/src/lrs_interface.cc polymake-4.12/bundled/lrs/apps/polytope/src/lrs_interface.cc
--- polymake-4.12.orig/bundled/lrs/apps/polytope/src/lrs_interface.cc 2024-06-21 19:35:09.144851916 +0200
+++ polymake-4.12/bundled/lrs/apps/polytope/src/lrs_interface.cc 2024-06-21 19:35:25.521671387 +0200
@@ -554,7 +554,7 @@
Bitset V(Points.rows());
for (Int index = D.Q->lastdv+1, end = D.P->m_A+D.P->d; index <= end; ++index)
- if ( !checkindex(D.P,D.Q,index) )
+ if ( !checkindex(D.P,D.Q,index,0) )
V += D.Q->inequality[index - D.Q->lastdv]-1;
return std::pair< Bitset, Matrix<Rational> >(V,AH);
diff -ru polymake-4.12.orig/bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp polymake-4.12/bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp
--- polymake-4.12.orig/bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp 2024-06-21 19:35:09.154852010 +0200
+++ polymake-4.12/bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp 2024-06-21 19:35:41.175150886 +0200
@@ -245,7 +245,7 @@
for (ulong index = lastdv + 1; index <= m + d; index++) {
ineq = Q->inequality[index - lastdv]; /* the input inequality number corr. to this index */
- redineq[ineq] = checkindex (P, Q, index);
+ redineq[ineq] = checkindex (P, Q, index, 0);
} /* end for index ..... */
std::list<ulong> redundancies;