mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added extra/pkcs11-helper
This commit is contained in:
parent
dadffc7f05
commit
512c629e73
2 changed files with 98 additions and 0 deletions
58
extra/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch
Normal file
58
extra/pkcs11-helper/0001-nss-use-nss-pkcs11-h.patch
Normal file
|
@ -0,0 +1,58 @@
|
||||||
|
From 083a3a62f2e631deec2fb2799d10660a41c50294 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alon Bar-Lev <alon.barlev@gmail.com>
|
||||||
|
Date: Fri, 30 Jul 2021 20:06:36 +0300
|
||||||
|
Subject: [PATCH] nss: use nss pkcs11.h
|
||||||
|
|
||||||
|
make nss happy with its own extensions and non-standard behavior.
|
||||||
|
---
|
||||||
|
lib/_pkcs11h-crypto-nss.c | 14 ++++++++++----
|
||||||
|
lib/common.h | 7 +++++++
|
||||||
|
2 files changed, 17 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/_pkcs11h-crypto-nss.c b/lib/_pkcs11h-crypto-nss.c
|
||||||
|
index 4b70e826..f57f9e6b 100644
|
||||||
|
--- a/lib/_pkcs11h-crypto-nss.c
|
||||||
|
+++ b/lib/_pkcs11h-crypto-nss.c
|
||||||
|
@@ -48,15 +48,21 @@
|
||||||
|
* POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
*/
|
||||||
|
|
||||||
|
-#include "common.h"
|
||||||
|
-
|
||||||
|
-#include "_pkcs11h-crypto.h"
|
||||||
|
+#ifdef HAVE_CONFIG_H
|
||||||
|
+#include <config.h>
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#if defined(ENABLE_PKCS11H_ENGINE_NSS)
|
||||||
|
-#define _PKCS11T_H_ /* required so no conflict with ours */
|
||||||
|
#include <nss.h>
|
||||||
|
#include <cert.h>
|
||||||
|
|
||||||
|
+/* Use PKCS#11 of nss to avoid conflicts and make nss happy with its own extensions */
|
||||||
|
+#define PKCS11_H 1
|
||||||
|
+
|
||||||
|
+#include "common.h"
|
||||||
|
+
|
||||||
|
+#include "_pkcs11h-crypto.h"
|
||||||
|
+
|
||||||
|
static
|
||||||
|
int
|
||||||
|
__pkcs11h_crypto_nss_initialize (
|
||||||
|
diff --git a/lib/common.h b/lib/common.h
|
||||||
|
index 61a958af..2499e9c5 100644
|
||||||
|
--- a/lib/common.h
|
||||||
|
+++ b/lib/common.h
|
||||||
|
@@ -72,5 +72,12 @@
|
||||||
|
|
||||||
|
#define _PKCS11H_ASSERT assert
|
||||||
|
|
||||||
|
+#ifndef FALSE
|
||||||
|
+#define FALSE 0
|
||||||
|
+#endif
|
||||||
|
+#ifndef TRUE
|
||||||
|
+#define TRUE 1
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#endif
|
||||||
|
|
40
extra/pkcs11-helper/PKGBUILD
Normal file
40
extra/pkcs11-helper/PKGBUILD
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
# Maintainer:
|
||||||
|
# Contributor: Stanislaw Datskevich <me a nek0 net>
|
||||||
|
# Contributor: Gregor Robinson <gregor@fiatflux.co.uk>
|
||||||
|
# Contributor: Martin Perner <martin dot perner at gmail dot com>
|
||||||
|
|
||||||
|
# remove when bumped upstream
|
||||||
|
|
||||||
|
pkgname=pkcs11-helper
|
||||||
|
pkgver=1.29.0
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc='A library that simplifies the interaction with PKCS11 providers for end-user applications using a simple API and optional OpenSSL engine'
|
||||||
|
arch=('x86_64')
|
||||||
|
url='https://github.com/OpenSC/pkcs11-helper'
|
||||||
|
license=('GPL' 'BSD')
|
||||||
|
depends=('gnutls' 'nss' 'openssl')
|
||||||
|
provides=('libpkcs11-helper.so')
|
||||||
|
options=('debug')
|
||||||
|
source=("https://github.com/OpenSC/${pkgname}/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2")
|
||||||
|
sha256sums=('996846a3c8395e03d8c0515111dc84d82e6e3648d44ba28cb2dbbbca2d4db7d6')
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd pkcs11-helper-$pkgver
|
||||||
|
|
||||||
|
libtoolize
|
||||||
|
aclocal
|
||||||
|
autoheader
|
||||||
|
automake --add-missing
|
||||||
|
autoreconf -v
|
||||||
|
./configure --prefix=/usr
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd pkcs11-helper-$pkgver
|
||||||
|
|
||||||
|
make DESTDIR="$pkgdir" install
|
||||||
|
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
|
||||||
|
install -D -m0644 COPYING* "$pkgdir"/usr/share/licenses/$pkgname/
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in a new issue