Merge branch 'master' of github.com:plugapps/plugapps

This commit is contained in:
Mike Staszel 2010-10-07 11:18:55 -05:00
commit 51421b450d
28 changed files with 1434 additions and 244 deletions

View file

@ -0,0 +1,39 @@
pkgname=openjdk6-debian
pkgver=6.b18_1.8.1
pkgrel=1
pkgdesc="Debian's package of OpenJDK6, including the Zero and Shark VMs"
depends=('glibc' 'gcc-libs')
makedepends=()
conflicts=('java-environment' 'java-runtime')
provides=('java-environment=6' 'java-runtime=6')
url="http://packages.debian.org/sid/openjdk-6-jre-zero"
source=("http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jre-headless_6b18-1.8.1-2_armel.deb"
"http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jre-zero_6b18-1.8.1-2_armel.deb"
"http://ftp.us.debian.org/debian/pool/main/o/openjdk-6/openjdk-6-jdk_6b18-1.8.1-2_armel.deb")
arch=('arm')
license="GPLv2"
build() {
ar x `basename ${source[0]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[0]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[1]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[1]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[2]}`
tar xf data.tar.gz -C ${pkgdir}
ar x `basename ${source[2]}`
tar xf data.tar.gz -C ${pkgdir}
rm -rf ${pkgdir}/usr/share/lintian
mkdir -p ${pkgdir}/usr/bin
ln -s ${pkgdir}/usr/lib/jvm/java-6-openjdk/bin/* ${pkgdir}/usr/bin
}
md5sums=('f6675141307f8c8032c3f37b5378fb89'
'dadcce59369b02d1ee075b2c254b2fa0'
'8dd55f57d788dcee520eb40c889ff5a0')

View file

@ -0,0 +1,20 @@
# Maintainer: Mike Staszel <mikestaszel@gmail.com>
pkgname=openjre7
pkgver=7b86
pkgrel=2
pkgdesc="OpenJRE from WithLinux"
arch=('arm')
license=('GPL2')
url="unknown"
depends=('libffi')
makedepends=('xz')
provides=('java-runtime')
install=openjre7.install
source=(http://sheeva.with-linux.com/sheeva/java/$pkgname-$pkgver-armv5tel.txz)
md5sums=('d1820d7f0b4bfed65c0d0e541f670e7f')
build() {
cd ${srcdir}/
cp -R ${srcdir}/opt ${pkgdir}/
}

View file

@ -0,0 +1,17 @@
post_install() {
echo -e "\033[1mNotice\033[0m"
echo "Add /opt/openjre7/bin to your PATH."
echo ""
}
post_upgrade() {
post_install
}
post_remove() {
KERNEL_VERSION=.*
}
op=$1
shift
$op $*

View file

@ -0,0 +1,60 @@
# Maintainer: wide-eye <eyeswide@gmail.com>
# Contributor: BlackEagle < ike DOT devolder AT herecura DOT be >
# No Plugbox changes, but sabnzbd depends on this package.
pkgname=par2cmdline
pkgver=0.4
pkgrel=14
pkgdesc="Providing a tool to apply the data-recovery capability concepts of RAID-like systems to the posting & recovery of multi-part archives on Usenet."
url="http://sourceforge.net/projects/parchive/"
license="GPL"
depends=('gcc-libs')
makedepends=()
arch=('i686' 'x86_64')
source=(
"http://downloads.sourceforge.net/sourceforge/parchive/${pkgname}-${pkgver}.tar.gz"
'par2cmdline-0.4-autoconf.patch'
'par2cmdline-0.4-wildcard-fix.patch'
'par2cmdline-0.4-offset.patch'
'par2cmdline-0.4-letype.patch'
'par2cmdline-0.4-gcc4.patch'
'par2cmdline-0.4-cosmetic.patch'
'par2cmdline-0.4-hardlinks.patch'
)
md5sums=(
'1551b63e57e3c232254dc62073b723a9'
'8a0fad41e3c3165e3c788d2693797557'
'c823d25f8862531e6e435ce0c76f8384'
'cd54801b5107f03982c2b01ead21f02a'
'1f7adb9308d4e972a5630eb56a42f8d5'
'd52515669d3bc43f19c545fd6405dacc'
'986d44b0cdba449459f9cfd93322144f'
'8683d237bc11e9d5581d14b4697d1f8b'
)
build() {
cd ${pkgname}-${pkgver}
msg "patch autoconf failure"
patch -N -i ../par2cmdline-0.4-autoconf.patch || return 1
msg "patch wildcard-fix"
patch -N -i ../par2cmdline-0.4-wildcard-fix.patch || return 1
msg "patch offset"
patch -N -i ../par2cmdline-0.4-offset.patch || return 1
msg "patch letype"
patch -N -i ../par2cmdline-0.4-letype.patch || return 1
msg "patch gcc4"
patch -N -i ../par2cmdline-0.4-gcc4.patch || return 1
msg "patch cosmetic"
patch -N -i ../par2cmdline-0.4-cosmetic.patch || return 1
msg "patch hardlinks"
patch -N -i ../par2cmdline-0.4-hardlinks.patch || return 1
msg "Configure"
./configure --prefix=/usr
make || return 1
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=$startdir/pkg install
}

View file

@ -0,0 +1,22 @@
--- ../orig/par2cmdline-0.4/par2cmdline.h 2004-04-15 15:30:02.000000000 +0200
+++ ./par2cmdline.h 2007-03-24 13:25:43.000000000 +0100
@@ -132,6 +132,10 @@
typedef unsigned long long u64;
#endif
+// FIXME: this is not done right w/ autoconf
+#include <sys/ioctl.h>
+#include <sys/mount.h>
+
#if HAVE_SYS_STAT_H
# include <sys/stat.h>
#endif
@@ -179,6 +183,8 @@
#include <ctype.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <sys/ioctl.h>
+#include <sys/mount.h>
#include <dirent.h>
#include <assert.h>

View file

@ -0,0 +1,106 @@
--- verificationhashtable.h 2003-06-03 13:48:52.000000000 +0200
+++ verificationhashtable.h.new 2010-02-10 20:48:50.425580166 +0100
@@ -66,11 +66,11 @@ public:
// Comparison operators for searching
bool operator <(const VerificationHashEntry &r) const
{
- return crc < r.crc || crc == r.crc && hash < r.hash;
+ return crc < r.crc || ( crc == r.crc && hash < r.hash );
}
bool operator >(const VerificationHashEntry &r) const
{
- return crc > r.crc || crc == r.crc && hash > r.hash;
+ return crc > r.crc || ( crc == r.crc && hash > r.hash );
}
bool operator ==(const VerificationHashEntry &r) const
{
@@ -183,11 +183,11 @@ inline const VerificationHashEntry* Veri
while (entry)
{
- if (entry->crc < crc || entry->crc == crc && entry->hash < hash)
+ if (entry->crc < crc || ( entry->crc == crc && entry->hash < hash ) )
{
entry = entry->right;
}
- else if (entry->crc > crc || entry->crc == crc && entry->hash > hash)
+ else if (entry->crc > crc || ( entry->crc == crc && entry->hash > hash ) )
{
entry = entry->left;
}
@@ -402,14 +402,14 @@ inline const VerificationHashEntry* Veri
// have already been matched, or ones that are the wrong length
while (currententry && (currententry->SourceFile() != sourcefile ||
currententry->IsSet() ||
- checksummer.ShortBlock() && checksummer.BlockLength() != currententry->GetDataBlock()->GetLength()
+ ( checksummer.ShortBlock() && checksummer.BlockLength() != currententry->GetDataBlock()->GetLength() )
)
)
{
// If we found an unused entry (which was presumably for the wrong
// source file) remember it (providing it is the correct length).
- if (0 == nextentry && !(currententry->IsSet() ||
- checksummer.ShortBlock() && checksummer.BlockLength() != currententry->GetDataBlock()->GetLength()
+ if ( ( ( 0 == nextentry && !(currententry->IsSet() ) ) ||
+ ( checksummer.ShortBlock() && checksummer.BlockLength() != currententry->GetDataBlock()->GetLength() )
)
)
{
@@ -425,8 +425,8 @@ inline const VerificationHashEntry* Veri
}
// Check for an unused entry which is the correct length
- while (nextentry && (nextentry->IsSet() ||
- checksummer.ShortBlock() && checksummer.BlockLength() != nextentry->GetDataBlock()->GetLength()
+ while ( ( ( nextentry && (nextentry->IsSet() ) ) ||
+ ( checksummer.ShortBlock() && checksummer.BlockLength() != nextentry->GetDataBlock()->GetLength() )
)
)
{
--- par1repairer.cpp 2004-04-15 15:40:48.000000000 +0200
+++ par1repairer.cpp.new 2010-02-10 21:04:43.288702325 +0100
@@ -324,7 +324,7 @@ bool Par1Repairer::LoadRecoveryFile(stri
||
(fileheader.datasize && (fileheader.dataoffset < sizeof(fileheader) || fileheader.dataoffset + fileheader.datasize > filesize))
||
- (fileheader.datasize && (fileheader.filelistoffset <= fileheader.dataoffset && fileheader.dataoffset < fileheader.filelistoffset+fileheader.filelistsize || fileheader.dataoffset <= fileheader.filelistoffset && fileheader.filelistoffset < fileheader.dataoffset + fileheader.datasize)))
+ (fileheader.datasize && ( ( fileheader.filelistoffset <= fileheader.dataoffset && fileheader.dataoffset < fileheader.filelistoffset+fileheader.filelistsize ) || ( fileheader.dataoffset <= fileheader.filelistoffset && fileheader.filelistoffset < fileheader.dataoffset + fileheader.datasize ) )))
break;
// Check the size of the file list
@@ -518,9 +518,9 @@ bool Par1Repairer::LoadOtherRecoveryFile
// Check the the file extension is the correct form
if ((tail[0] == 'P' || tail[0] == 'p') &&
(
- (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r')
+ ( (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r') )
||
- isdigit(tail[1]) && isdigit(tail[2])
+ ( isdigit(tail[1]) && isdigit(tail[2]) )
))
{
LoadRecoveryFile(filename);
@@ -549,9 +549,9 @@ bool Par1Repairer::LoadExtraRecoveryFile
// Check the the file extension is the correct form
if ((tail[0] == 'P' || tail[0] == 'p') &&
(
- (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r')
+ ( (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r') )
||
- isdigit(tail[1]) && isdigit(tail[2])
+ ( isdigit(tail[1]) && isdigit(tail[2]) )
))
{
LoadRecoveryFile(filename);
@@ -652,9 +652,9 @@ bool Par1Repairer::VerifyExtraFiles(cons
// Check the the file extension is the correct form
if ((tail[0] == 'P' || tail[0] == 'p') &&
(
- (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r')
+ ( (tail[1] == 'A' || tail[1] == 'a') && (tail[2] == 'R' || tail[2] == 'r') )
||
- isdigit(tail[1]) && isdigit(tail[2])
+ ( isdigit(tail[1]) && isdigit(tail[2]) )
))
{
skip = true;

View file

@ -0,0 +1,62 @@
Fix compilation with gcc-4.
Patch by Dirk-Jan Heijs.
http://bugs.gentoo.org/102391
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=287904
--- par2cmdline-0.4/reedsolomon.cpp
+++ par2cmdline-0.4/reedsolomon.cpp
@@ -51,7 +51,7 @@
}
}
-bool ReedSolomon<Galois8>::SetInput(const vector<bool> &present)
+template <> bool ReedSolomon<Galois8>::SetInput(const vector<bool> &present)
{
inputcount = (u32)present.size();
@@ -80,7 +80,7 @@
return true;
}
-bool ReedSolomon<Galois8>::SetInput(u32 count)
+template <> bool ReedSolomon<Galois8>::SetInput(u32 count)
{
inputcount = count;
@@ -101,7 +101,7 @@
return true;
}
-bool ReedSolomon<Galois8>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer)
+template <> bool ReedSolomon<Galois8>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer)
{
// Look up the appropriate element in the RS matrix
Galois8 factor = leftmatrix[outputindex * (datapresent + datamissing) + inputindex];
@@ -189,7 +189,7 @@
// Set which of the source files are present and which are missing
// and compute the base values to use for the vandermonde matrix.
-bool ReedSolomon<Galois16>::SetInput(const vector<bool> &present)
+template <> bool ReedSolomon<Galois16>::SetInput(const vector<bool> &present)
{
inputcount = (u32)present.size();
@@ -233,7 +233,7 @@
// Record that the specified number of source files are all present
// and compute the base values to use for the vandermonde matrix.
-bool ReedSolomon<Galois16>::SetInput(u32 count)
+template <> bool ReedSolomon<Galois16>::SetInput(u32 count)
{
inputcount = count;
@@ -267,7 +267,7 @@
return true;
}
-bool ReedSolomon<Galois16>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer)
+template <> bool ReedSolomon<Galois16>::Process(size_t size, u32 inputindex, const void *inputbuffer, u32 outputindex, void *outputbuffer)
{
// Look up the appropriate element in the RS matrix

View file

@ -0,0 +1,15 @@
--- Makefile.in 2004-04-12 18:44:18.000000000 +0200
+++ Makefile.in.new 2010-02-10 21:08:17.799145528 +0100
@@ -716,9 +716,9 @@ uninstall-am: uninstall-binPROGRAMS unin
install-exec-hook :
- ln -f $(DESTDIR)$(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2create$(EXEEXT)
- ln -f $(DESTDIR)$(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2verify$(EXEEXT)
- ln -f $(DESTDIR)$(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2repair$(EXEEXT)
+ ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2create$(EXEEXT)
+ ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2verify$(EXEEXT)
+ ln -sf $(bindir)/par2$(EXEEXT) $(DESTDIR)$(bindir)/par2repair$(EXEEXT)
uninstall-hook :
rm -f $(DESTDIR)$(bindir)/par2create$(EXEEXT)

View file

@ -0,0 +1,219 @@
diff -ur par2cmdline-0.4-orig/letype.h par2cmdline-0.4/letype.h
--- par2cmdline-0.4-orig/letype.h 2003-05-26 20:01:17.000000000 +0200
+++ par2cmdline-0.4/letype.h 2006-05-09 10:47:29.000000000 +0200
@@ -28,44 +28,15 @@
#else
-class leu16
+struct leu16
{
-public:
- leu16(void);
-
- leu16(const leu16 &other);
- leu16& operator=(const leu16 &other);
-
- leu16(const u16 &other);
leu16& operator=(const u16 &other);
operator u16(void) const;
-protected:
u16 value;
};
-inline leu16::leu16(void)
-{
-}
-
-inline leu16::leu16(const leu16 &other)
-: value(other.value)
-{
-}
-
-inline leu16& leu16::operator =(const leu16 &other)
-{
- value = other.value;
- return *this;
-}
-
-inline leu16::leu16(const u16 &other)
-{
- ((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
- ((unsigned char*)&value)[1] = (unsigned char)((other >> 8) & 0xff);
-}
-
inline leu16& leu16::operator=(const u16 &other)
{
((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
@@ -81,46 +52,15 @@
}
-class leu32
+struct leu32
{
-public:
- leu32(void);
-
- leu32(const leu32 &other);
- leu32& operator=(const leu32 &other);
-
- leu32(const u32 &other);
leu32& operator=(const u32 &other);
operator u32(void) const;
-protected:
u32 value;
};
-inline leu32::leu32(void)
-{
-}
-
-inline leu32::leu32(const leu32 &other)
-: value(other.value)
-{
-}
-
-inline leu32& leu32::operator =(const leu32 &other)
-{
- value = other.value;
- return *this;
-}
-
-inline leu32::leu32(const u32 &other)
-{
- ((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
- ((unsigned char*)&value)[1] = (unsigned char)((other >> 8) & 0xff);
- ((unsigned char*)&value)[2] = (unsigned char)((other >> 16) & 0xff);
- ((unsigned char*)&value)[3] = (unsigned char)((other >> 24) & 0xff);
-}
-
inline leu32& leu32::operator=(const u32 &other)
{
((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
@@ -140,50 +80,15 @@
}
-class leu64
+struct leu64
{
-public:
- leu64(void);
-
- leu64(const leu64 &other);
- leu64& operator=(const leu64 &other);
-
- leu64(const u64 &other);
leu64& operator=(const u64 &other);
operator u64(void) const;
-protected:
u64 value;
};
-inline leu64::leu64(void)
-{
-}
-
-inline leu64::leu64(const leu64 &other)
-: value(other.value)
-{
-}
-
-inline leu64& leu64::operator =(const leu64 &other)
-{
- value = other.value;
- return *this;
-}
-
-inline leu64::leu64(const u64 &other)
-{
- ((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
- ((unsigned char*)&value)[1] = (unsigned char)((other >> 8) & 0xff);
- ((unsigned char*)&value)[2] = (unsigned char)((other >> 16) & 0xff);
- ((unsigned char*)&value)[3] = (unsigned char)((other >> 24) & 0xff);
- ((unsigned char*)&value)[4] = (unsigned char)((other >> 32) & 0xff);
- ((unsigned char*)&value)[5] = (unsigned char)((other >> 40) & 0xff);
- ((unsigned char*)&value)[6] = (unsigned char)((other >> 48) & 0xff);
- ((unsigned char*)&value)[7] = (unsigned char)((other >> 56) & 0xff);
-}
-
inline leu64& leu64::operator=(const u64 &other)
{
((unsigned char*)&value)[0] = (unsigned char)((other >> 0) & 0xff);
diff -ur par2cmdline-0.4-orig/md5.h par2cmdline-0.4/md5.h
--- par2cmdline-0.4-orig/md5.h 2003-08-02 01:41:04.000000000 +0200
+++ par2cmdline-0.4/md5.h 2006-05-09 10:47:29.000000000 +0200
@@ -20,6 +20,13 @@
#ifndef __MD5_H__
#define __MD5_H__
+#ifdef WIN32
+#pragma pack(push, 1)
+#define PACKED
+#else
+#define PACKED __attribute__ ((packed))
+#endif
+
// This file defines the MD5Hash and MD5Context objects which are used
// to compute and manipulate the MD5 Hash values for a block of data.
@@ -35,12 +42,11 @@
// MD5 Hash value
-class MD5Hash
-{
-public:
- // Constructor does not initialise the value
- MD5Hash(void) {};
+struct MD5Hash;
+ostream& operator<<(ostream &s, const MD5Hash &hash);
+struct MD5Hash
+{
// Comparison operators
bool operator==(const MD5Hash &other) const;
bool operator!=(const MD5Hash &other) const;
@@ -54,13 +60,8 @@
friend ostream& operator<<(ostream &s, const MD5Hash &hash);
string print(void) const;
- // Copy and assignment
- MD5Hash(const MD5Hash &other);
- MD5Hash& operator=(const MD5Hash &other);
-
-public:
u8 hash[16]; // 16 byte MD5 Hash value
-};
+} PACKED;
// Intermediate computation state
@@ -144,16 +145,9 @@
return !other.operator<(*this);
}
-inline MD5Hash::MD5Hash(const MD5Hash &other)
-{
- memcpy(&hash, &other.hash, sizeof(hash));
-}
-
-inline MD5Hash& MD5Hash::operator=(const MD5Hash &other)
-{
- memcpy(&hash, &other.hash, sizeof(hash));
-
- return *this;
-}
+#ifdef WIN32
+#pragma pack(pop)
+#endif
+#undef PACKED
#endif // __MD5_H__

View file

@ -0,0 +1,16 @@
--- par2cmdline-0.4.orig/par2creatorsourcefile.cpp 2004-04-15 14:45:23.000000000 +0100
+++ par2cmdline-0.4/par2creatorsourcefile.cpp 2005-09-29 02:27:43.000000000 +0100
@@ -213,11 +213,12 @@
}
}
+ offset += want;
+
if (noiselevel > CommandLine::nlQuiet)
{
// Display progress
u32 oldfraction = (u32)(1000 * offset / filesize);
- offset += want;
u32 newfraction = (u32)(1000 * offset / filesize);
if (oldfraction != newfraction)
{

View file

@ -0,0 +1,23 @@
--- commandline.cpp.orig 2006-04-06 21:41:27.000000000 -0700
+++ commandline.cpp 2006-04-07 00:12:29.000000000 -0700
@@ -550,6 +550,20 @@
}
else
{
+ //start of shell expanded * patch. -- Michael Evans
+ //The shell might expaned * so, if we have our name and we're creating, then filter for files...
+ if ((parfilename.length() != 0) && (operation == opCreate))
+ {
+ struct stat st;
+ if (!(stat(argv[0], &st) == 0 && S_ISREG(st.st_mode)))
+ {
+ cerr << "Skipping non-regular file: " << argv[0] << endl;
+ argc--;
+ argv++;
+ options = false;
+ continue;
+ }
+ }//end of shell expanded * patch. -- Michael Evans
filenames = new list<string>;
filenames->push_back(argv[0]);
}

View file

@ -0,0 +1,20 @@
# Contributor: Jonathan Curran <jonc@icicled.net>
# No Plugbox changes, sabnzbd depends on this package.
pkgname=python-yenc
pkgver=0.3
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
pkgdesc="yenc decoder for python"
url="http://sabnzbd.sourceforge.net/"
depends=('python')
source=(http://sabnzbd.sourceforge.net/yenc-$pkgver.tar.gz)
md5sums=('7b3edd32db6c1ce566ad550e3de64c83')
build() {
cd $startdir/src/yenc-$pkgver
python setup.py install --root=$startdir/pkg
}

View file

@ -0,0 +1,39 @@
# No Plugbox changes, this is just from AUR but has been requested
# very, very often.
pkgname=sabnzbd
pkgver=0.5.4
pkgrel=3
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
arch=(i686 x86_64)
url="http://www.sabnzbd.org/"
license=('GPL')
depends=('par2cmdline' 'python' 'python-cheetah' 'python-feedparser' 'python-yenc' 'pyopenssl' 'unrar' 'unzip' 'sqlite3' 'curl')
install=sabnzbd.install
backup=('etc/conf.d/sabnzbd' 'opt/sabnzbd/sabnzbd.ini')
source=("http://downloads.sourceforge.net/sabnzbdplus/SABnzbd-$pkgver-src.tar.gz"
sabnzbd sabnzbd.init sabnzbd.confd sabnzbd.desktop x-nzb.xml addnzb.sh)
md5sums=('b64e5d47ea4c115b98dd96744946c89d'
'f45907d98a19052eaeb7ad98ff13b16d'
'0300f4804c7abcfc7013b3a90b83c38c'
'dc5fdcc132033b38e2f34d2355d573be'
'a83d735a8a21b68622ed0d6ac1139a9e'
'11fb2cd1451e3725b08bfc2bd045be54'
'3287c7a1becdf0a4f7276cfbccb301dd')
build() {
mkdir -p $startdir/pkg/opt/sabnzbd
touch $startdir/pkg/opt/sabnzbd/sabnzbd.ini
mv -v $startdir/src/SABnzbd-$pkgver/* $startdir/pkg/opt/sabnzbd/
find $startdir/pkg/opt/sabnzbd -type d -exec chmod 755 {} \;
find $startdir/pkg/opt/sabnzbd -type f -exec chmod 644 {} \;
chmod 755 $startdir/pkg/opt/sabnzbd/SABnzbd.py
chmod 755 $startdir/pkg/opt/sabnzbd/Sample-PostProc.sh
install -D -m755 $startdir/sabnzbd $startdir/pkg/usr/bin/sabnzbd
install -D -m755 $startdir/sabnzbd.init $startdir/pkg/etc/rc.d/sabnzbd
install -D -m644 $startdir/sabnzbd.confd $startdir/pkg/etc/conf.d/sabnzbd
install -D -m755 $startdir/sabnzbd.desktop $startdir/pkg/usr/share/applications/sabnzbd.desktop
install -D -m755 $startdir/addnzb.sh $startdir/pkg/opt/sabnzbd/addnzb.ssh
install -D -m770 $startdir/x-nzb.xml $startdir/pkg/opt/sabnzbd/x-nzb.xml
}

View file

@ -0,0 +1,13 @@
#!/bin/bash
. /etc/conf.d/sabnzbd
# SABnzbd must be able to read the file, so we copy it to a directory where it
# certainly has rights.
nzbname=`basename $1`
TEMP_NZB="/var/tmp/"$nzbname
cp $1 $TEMP_NZB
curl -f "$SABNZBD_PROTOCOL://$SABNZBD_USPW$SABNZBD_IP:$SABNZBD_PORT/sabnzbd/api?mode=addlocalfile&name=$TEMP_NZB&pp=1&priority=-1&apikey=$SABNZBD_KEY"
rm $TEMP_NZB
exit 0

View file

@ -0,0 +1,3 @@
#!/bin/sh
python /opt/sabnzbd/SABnzbd.py -f $HOME/.sabnzbd.ini "$@"

View file

@ -0,0 +1,16 @@
SABNZBD_USER="sabnzbd"
SABNZBD_CONF="/opt/sabnzbd/sabnzbd.ini"
# Put the session key from Config > General here
SABNZBD_KEY=""
# Set to the protocol, IP and port
SABNZBD_PROTOCOL="http"
SABNZBD_IP="127.0.0.1"
SABNZBD_PORT="8080"
# If you use a username and password, change the following variable to
# "user:pass@"
SABNZBD_USPW=""

View file

@ -0,0 +1,9 @@
[Desktop Entry]
Type=Application
Version=1.0
Name=SABnzbd+
GenericName=Binary Newsreader
Exec=sh /opt/sabnzbd/addnzb.sh %u
Terminal=false
Categories=Network
MimeType=application/x-nzb

View file

@ -0,0 +1,43 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/sabnzbd
case "$1" in
start)
stat_busy "Starting SABnzbd"
if [ -f /var/run/daemons/sabnzbd ]; then
echo -n "Sabnzbd is already running as a daemon! If you are certain it is not running, remove /var/run/daemons/sabnzbd."
stat_fail
else
su - $SABNZBD_USER -c "python /opt/sabnzbd/SABnzbd.py -f $SABNZBD_CONF -s $SABNZBD_IP:$SABNZBD_PORT -d" -s /bin/sh
if [ $? -gt 0 ]; then
stat_fail
else
add_daemon sabnzbd
stat_done
fi
fi
;;
stop)
stat_busy "Stopping SABnzbd"
curl -f "$SABNZBD_PROTOCOL://$SABNZBD_USPW$SABNZBD_IP:$SABNZBD_PORT/sabnzbd/api?mode=shutdown&apikey=$SABNZBD_KEY" &> /dev/null
if [ $? -gt 0 ]; then
stat_fail
else
rm_daemon sabnzbd
stat_done
fi
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac
exit 0

View file

@ -0,0 +1,24 @@
## arg 1: the new package version
post_install() {
# add x-nzb mimetype
xdg-mime install --mode system /opt/sabnzbd/x-nzb.xml
groupadd sabnzbd &> /dev/null
useradd -g sabnzbd -d /opt/sabnzbd -s /bin/false sabnzbd &> /dev/null
chown -R sabnzbd:sabnzbd /opt/sabnzbd
echo " >> Don't forget to edit /etc/conf.d/sabnzbd!"
echo " >> Add your Session key and if necessary your username and password to ensure a proper shutdown."
echo " >> "
echo " >> If you want to associate .nzb-files with SABnzbd, run 'xdg-mime default sabnzbd.desktop applications/x-nzb'"
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
chown -R sabnzbd:sabnzbd /opt/sabnzbd
}
## arg 1: the old package version
pre_remove() {
userdel sabnzbd &> /dev/null
}

View file

@ -0,0 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
<mime-type type="application/x-nzb">
<comment xml:lang='en'>An XML-based file format for retrieving posts from NNTP (Usenet) servers</comment>
<sub-class-of type="application/xml"/>
<glob pattern="*.nzb"/>
</mime-type>
</mime-info>

View file

@ -1,8 +1,8 @@
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
pkgname=filesystem
pkgver=2010.07
pkgrel=2
pkgver=2010.09
pkgrel=1
pkgdesc="Base filesystem"
arch=('arm')
license=('GPL')
@ -16,7 +16,7 @@ backup=(etc/fstab etc/crypttab etc/group etc/hosts etc/ld.so.conf etc/passwd
source=(group issue nsswitch.conf securetty host.conf ld.so.conf
passwd shadow fstab crypttab hosts motd resolv.conf shells
gshadow services protocols profile modprobe.d.usb-load-ehci-first)
md5sums=('75c7e1770305e1f3b75c52785c137611'
md5sums=('78a40317b8ea1d6810835fb12501fec7'
'336bdaeeff0ccc84a6b84f1d8c4e2127'
'13753e4e0964f3652b0cc60a28528bdf'
'2f890aefb8eee68b5b9d91f4777d0cd9'

View file

@ -14,7 +14,6 @@ mail:x:12:
uucp:x:14:
log:x:19:root
locate:x:21:
rfkill:x:24:
smmsp:x:25:
http:x:33:
games:x:50:

View file

@ -3,7 +3,7 @@
# This PKGBUILD makes a kernel for the DockStar with aholler's LED patches.
pkgname=kernel26-dockstar
pkgver=2.6.35.2
pkgver=2.6.35.6
pkgrel=1
pkgdesc="The Linux Kernel and modules with DockStar LEDs"
arch=('arm')
@ -15,12 +15,12 @@ conflicts=('kernel26')
provides=('kernel26')
install=kernel26-dockstar.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
config-2.6.35.2-dockstar
dockstar-2.6.35.4.config
0001-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
0002-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
0003-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch)
md5sums=('0da1c090199663c180d8a60bf49de36e'
'2ff476d7bad26179d56154be9acb9c29'
md5sums=('26ff1af2a0a398d3b6ef60bb8ce311d4'
'c088afd52aab4878ddc04a005c5db033'
'0ed85186b0b5446c4afbbc45639a7466'
'e81eae381cc2c282d169c879cc4da54b'
'75287077b9a0105156977acb85d57546')
@ -28,7 +28,7 @@ LDFLAGS=""
build() {
cd $srcdir/
cp 000* config-2.6.35.2-dockstar linux-$pkgver/
cp 000* dockstar-2.6.35.4.config linux-$pkgver/
cd linux-$pkgver
# Apply Aholler's DockStar hardware patches
@ -37,7 +37,7 @@ build() {
patch -p1 -i 0003-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch
# Prepare for make
mv config-2.6.35.2-dockstar .config
mv dockstar-2.6.35.4.config .config
echo "Press ENTER 4972 times..."
make oldconfig

View file

@ -3,7 +3,7 @@
# This PKGBUILD builds a kernel using cbxbiker's With-Linux configuration.
pkgname=kernel26-withlinux
pkgver=2.6.35.2
pkgver=2.6.35.6
pkgrel=1
pkgdesc="The Linux Kernel and modules from WithLinux, natively compiled"
arch=('arm')
@ -16,8 +16,8 @@ provides=('kernel26')
install=kernel26-withlinux.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
http://sheeva.with-linux.com/sheeva/$pkgver/sheeva-$pkgver.config)
md5sums=('0da1c090199663c180d8a60bf49de36e'
'4a2d9a701cf6ae86ee83c0ef4b3e0605')
md5sums=('26ff1af2a0a398d3b6ef60bb8ce311d4'
'ae6ec897eeae3f92d6363e571a2068fa')
LDFLAGS=""
build() {

View file

@ -0,0 +1,81 @@
--- vnc_unixsrc/Xvnc/config/cf/linux.cf.orig 2010-09-21 20:00:26.000000000 +0000
+++ vnc_unixsrc/Xvnc/config/cf/linux.cf 2010-09-21 20:02:08.000000000 +0000
@@ -249,42 +249,36 @@
#ifdef i386Architecture
#define OptimizedCDebugFlags DefaultGcc2i386Opt
-#define LinuxMachineDefines -D__i386__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* i386Architecture */
#ifdef x86_64Architecture
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__x86_64__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines -D_XSERVER64
#endif /* x86_64Architecture */
#ifdef AlphaArchitecture
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__alpha__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines -D_XSERVER64
#endif /* AlphaArchitecture */
#ifdef Mc68020Architecture
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__mc68000__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* Mc68020Architecture */
#ifdef s390Architecture
#define OptimzedCDebugFlags -O2
-#define LinuxMachineDefines -D__s390__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* s390Architecture */
#ifdef s390xArchitecture
#define OptimzedCDebugFlags -O2
-#define LinuxMachineDefines -D__s390x__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* s390xArchitecture */
@@ -292,7 +286,6 @@
#ifdef PowerPCArchitecture
#define DefaultCCOptions -fsigned-char
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__powerpc__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* PowerPCArchitecture */
@@ -300,14 +293,12 @@
#ifdef ArmArchitecture
#define DefaultCCOptions -fsigned-char
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__arm__
#define ServerOSDefines XFree86ServerOSDefines -DDDXTIME -DPART_NET
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#endif /* Arm */
#ifdef SparcArchitecture
#define OptimizedCDebugFlags -O2
-#define LinuxMachineDefines -D__sparc__
#define ServerOSDefines -DDDXOSINIT
#define ServerExtraDefines -DGCCUSESGAS XFree86ServerDefines
#define AsVISOption -Av9a
@@ -327,10 +318,10 @@
Always define _REENTRANT since we may use threaded libraries */
/* REMOVE
-#define StandardDefines -Dlinux LinuxMachineDefines LinuxSourceDefines
+#define StandardDefines -Dlinux LinuxSourceDefines
*/
-#define StandardDefines -Dlinux LinuxMachineDefines \
+#define StandardDefines -Dlinux \
LinuxSourceDefines -D_REENTRANT
/* END ORL VNC modification

47
extra/tightvnc/PKGBUILD Normal file
View file

@ -0,0 +1,47 @@
# Maintainer: Paul Mattal <paul@archlinux.org>
# This PKGBUILD was submitted by a user
pkgname=tightvnc
pkgver=1.3.10
pkgrel=5
pkgdesc="VNC Unix server && viewer"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.tightvnc.com"
depends=('libjpeg>=7' 'zlib' 'libxaw' 'libxp' 'xorg-xauth')
makedepends=('imake')
conflicts=('vnc')
options=(!makeflags)
source=(http://downloads.sf.net/sourceforge/vnc-tight/$pkgname-${pkgver}_unixsrc.tar.bz2
tightvnc-fontpath-xcolors.patch
LinuxMachineDefines-arm.patch)
build() {
cd $srcdir/vnc_unixsrc || return 1
patch -Np1 -i ../tightvnc-fontpath-xcolors.patch || return 1
sed -i 's|/usr/local/|/usr/share/|' vncserver || return 1
# The following patch allows the package to compile on ARM. It may not
# be the best way to do it, but it works. A more elegant solution
# is welcomed.
patch -Np1 -i ../LinuxMachineDefines-arm.patch || return 1
xmkmf || return 1
make World || return 1
cd Xvnc || return 1
./configure || return 1
sed 's|PROTO_DEFINES =|PROTO_DEFINES = -D_XOPEN_SOURCE=500L|' \
-i programs/Xserver/os/Makefile lib/font/fc/Makefile || return 1
make || return 1
cd .. || return 1
mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/man/man1 || return 1
./vncinstall $pkgdir/usr/bin $pkgdir/usr/share/man || return 1
# install java classes
mkdir -p $pkgdir/usr/share/vnc/classes || return 1
install -Dm644 $srcdir/vnc_unixsrc/classes/* \
$pkgdir/usr/share/vnc/classes || return 1
}
md5sums=('397b35faad32d5246b6d44b142f8304f'
'21aa7f3376ec3c608ff22d199a19c601'
'48a419227940ef3dcd92fab7f8809845')

View file

@ -0,0 +1,13 @@
diff -urN vnc_unixsrc/vncserver vnc_unixsrc.fixed/vncserver
--- vnc_unixsrc/vncserver 2009-02-11 23:27:18.000000000 -0500
+++ vnc_unixsrc.fixed/vncserver 2009-04-23 21:46:46.000000000 -0400
@@ -34,7 +34,8 @@
$desktopName = "X";
$vncClasses = "/usr/local/vnc/classes";
$vncUserDir = "$ENV{HOME}/.vnc";
-$fontPath = "unix/:7100";
+$fontPath = "/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/";
+$colorPath = "/usr/share/X11/rgb";
$authType = "-rfbauth $vncUserDir/passwd";
# Read configuration from the system-wide and user files if present.