community/luminancehdr: fix

This commit is contained in:
Kevin Mihelich 2017-06-04 15:40:18 +00:00
parent b0bf611e1c
commit 5147d66332
3 changed files with 6 additions and 21 deletions

View file

@ -3,8 +3,7 @@
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
# Contributor: Dmitry N. Shilov <stormblast@land.ru>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove sse and sse2 flags
# remove when bumped upstream
pkgname=luminancehdr
pkgver=2.5.1
@ -19,16 +18,8 @@ makedepends=('cmake' 'boost' 'gtest' 'qt5-tools' 'patch')
optdepends=('hugin: align image stack functionality')
changelog=$pkgname.changelog
options=('!emptydirs')
source=(http://sourceforge.net/projects/qtpfsgui/files/luminance/$pkgver/luminance-hdr-$pkgver.tar.bz2
strip-sse.patch)
sha256sums=('a8986e0afba434a2e9da7e8aed19cdb763fedc8de2655bdb496c4ee9d3f41696'
'f74a1d27684a7a8fa3223e1bf8e04bd2158925b8f1d0b32ef167910920511974')
prepare() {
cd "${srcdir}"/luminance-hdr-$pkgver
patch -p0 -i ../strip-sse.patch
}
source=(http://sourceforge.net/projects/qtpfsgui/files/luminance/$pkgver/luminance-hdr-$pkgver.tar.bz2)
sha256sums=('a8986e0afba434a2e9da7e8aed19cdb763fedc8de2655bdb496c4ee9d3f41696')
build() {
cd "${srcdir}"/luminance-hdr-$pkgver

View file

@ -1,3 +1,6 @@
2017-06-04 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* luminancehdr 2.5.1-1
2017-05-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
* luminancehdr 2.5.0-3 boost 1.64.0 rebuild

View file

@ -1,9 +0,0 @@
--- cmake/CompilerSettings.cmake.orig 2017-04-18 18:18:08.775977375 -0400
+++ cmake/CompilerSettings.cmake 2017-04-18 18:18:22.582643430 -0400
@@ -1,6 +1,5 @@
IF(UNIX)
ADD_DEFINITIONS(-Wall -Wno-unknown-pragmas)
-ADD_DEFINITIONS(-ffast-math)
IF(APPLE)
# optimize for 64-bit core 2 architecture on Apple