removed community/consul

This commit is contained in:
Kevin Mihelich 2020-03-04 14:23:00 +00:00
parent d17c210c5f
commit 51d0cd0025
11 changed files with 0 additions and 322 deletions

View file

@ -1,25 +0,0 @@
From ec190de75ad612a93561d65a11168a544d334bac Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 26 Jun 2018 06:43:01 -0600
Subject: [PATCH] fix ARM build
---
GNUmakefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/GNUmakefile b/GNUmakefile
index bee271760..7786ac50f 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -137,7 +137,7 @@ changelogfmt:
# linux builds a linux package independent of the source platform
linux:
- @$(SHELL) $(CURDIR)/build-support/scripts/build-local.sh -o linux -a amd64
+ @$(SHELL) $(CURDIR)/build-support/scripts/build-local.sh -o linux -a $(GOARCH)
# dist builds binaries for all platforms and packages them for distribution
dist:
--
2.21.0

View file

@ -1,92 +0,0 @@
# Maintainer: Thore Bödecker <foxxx0@archlinux.org>
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix ARM build
# - remove export GOARCH='amd64'
pkgname=consul
pkgver=1.5.3
pkgrel=2
pkgdesc="A tool for service discovery, monitoring and configuration."
arch=('x86_64')
_gocli_commit='3d22a244be8aa6fb16ac24af0e195c08b7d973aa' # HEAD
url="https://www.consul.io"
license=('MPL2')
depends=('glibc')
makedepends=('git' 'go-pie' 'procps-ng' 'zip')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/consul/archive/v${pkgver}.tar.gz"
"gocli::git+https://github.com/mitchellh/cli#commit=${_gocli_commit}"
'consul.service'
'consul.default'
'consul.sysusers'
'example.json'
'fix-build-version-info.patch'
'consul-ldflags.patch'
'unparallelize-or-disable-flaky-tests.patch'
'0001-fix-ARM-build.patch'
)
install=consul.install
backup=('etc/default/consul')
sha512sums=('9a1ec590132069deb0d74809bcc7da7df4d40b17e6e2ff95cf90a2dbd5487bd2309164f09ca9c4802f77a56b453479605841531083bf272dbcb9a53b91e9bc8c'
'SKIP'
'c70b9d1556f6c7ecb2e915ab685f289cef0e31198bd2e50c74a0483bbfb387beec67334f539a90adbf68b61b07946e98b300ab8a8e26e53b35f4ab4894adeb04'
'ec5a800529a297c709fa383c094ecf106351cf0f8ac7b613b972d415d77fe001088902d7ab805e63e78a8e6360323fec1b795db5a4446df1e21b9b4ed31e7079'
'ef872aedb2bc022a29292b7972a792b22e684c1ccb904a2b2cfec6d8966c28fb19be1452ce060821c419f1b646b236ba2e783175595e4bb6926d164c27a15c87'
'c4292b8f56ee955ed7385a49843fd90d6434029891b3e1e724cb2fc841514c06e2554a26d3937c114371b18c2168c4e64319eb2cbd726ee8b35870df19089348'
'8442826050639bf4a8799d5bdeb9778b5dbf45c7c557292209691a08d207ece6106e7f6711ccb1e252b7d1dbbff14f0deb72b4f07e664a304b91092d0afa447b'
'0d779e78bb5f5edafddcc3de1a754a6c39e3ce6dd7aa1387f491803f977b4a7d5e9a1eaa17d212be89109b191c91c2cdf4dd9728cffb3b724b28d20248ce8e12'
'b59b2733d598ae6648c198f26f23961d4c1ea8c693a1a5b1c16a0951400c3bb9a9d2d5efe4f0a5cca9ae3b1f225a8eb4133c9011c4125589e936c7dcdc4b2495'
'3f6c2d7e13bb13ee1614463f81a33eedbce8237b2e5189c78e3e12b00c38497a1f17eae8298d3276c4df8bf5e1f950ac62718f6a4ec5c07a94de2210efbc26bc')
prepare() {
export GOPATH="${srcdir}"
export PATH="$PATH:$GOPATH/bin"
mkdir -p "src/github.com/mitchellh"
mkdir -p "src/github.com/hashicorp"
mv "${pkgname}-${pkgver}" "${srcdir}/src/github.com/hashicorp/${pkgname}"
mv "gocli" "${srcdir}/src/github.com/mitchellh/cli"
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
local filename
for filename in "${source[@]}"; do
if [[ "$filename" =~ \.patch$ ]]; then
msg2 "Applying patch ${filename##*/}"
patch -p1 -N -l -i "$srcdir/${filename##*/}"
fi
done
}
build() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
export GOOS='linux'
make linux
}
check() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
# weird race conditions when being run overparallelized
export GOMAXPROCS="2"
export GOOS='linux'
export GOTEST_FLAGS="-p 2 -parallel 2"
export TRAVIS='true'
make -j1 test
}
package() {
cd "${srcdir}/src/github.com/hashicorp/${pkgname}"
install -D -d -m750 -o 208 -g 208 "${pkgdir}/var/lib/consul"
install -D -d -m750 -o 0 -g 208 "${pkgdir}/etc/consul.d"
install -D -m644 "${srcdir}/consul.default" "${pkgdir}/etc/default/consul"
install -D -m644 -o 0 -g 0 "${srcdir}/example.json" "${pkgdir}/usr/share/doc/consul/config.example.json"
install -Dm755 "bin/consul" "${pkgdir}/usr/bin/consul"
install -Dm644 "${srcdir}/consul.service" "${pkgdir}/usr/lib/systemd/system/consul.service"
install -Dm644 "${srcdir}/consul.sysusers" "${pkgdir}/usr/lib/sysusers.d/consul.conf"
}
# vim:set ts=2 sw=2 et:

View file

@ -1,31 +0,0 @@
diff -upr b/build-support/functions/20-build.sh c/build-support/functions/20-build.sh
--- b/build-support/functions/20-build.sh 2019-05-08 20:34:08.000000000 +0200
+++ c/build-support/functions/20-build.sh 2019-05-09 10:39:50.420779679 +0200
@@ -453,7 +453,7 @@ function build_consul_local {
if [ $os == "windows" ];then
binname="consul.exe"
fi
- CGO_ENABLED=0 GOOS=${os} GOARCH=${arch} go install -ldflags "${GOLDFLAGS}" -tags "${GOTAGS}" && cp "${MAIN_GOPATH}/bin/${GOBIN_EXTRA}${binname}" "${outdir}/${binname}"
+ CGO_ENABLED=0 GOOS=${os} GOARCH=${arch} go install -ldflags "-linkmode external -extldflags ${EXTLDFLAGS} -s -w ${GOLDFLAGS}" -tags "${GOTAGS}" && cp "${MAIN_GOPATH}/bin/${GOBIN_EXTRA}${binname}" "${outdir}/${binname}"
if test $? -ne 0
then
err "ERROR: Failed to build Consul for ${osarch}"
diff -upr b/GNUmakefile c/GNUmakefile
--- b/GNUmakefile 2019-05-09 10:38:41.960775825 +0200
+++ c/GNUmakefile 2019-05-09 10:39:15.477444378 +0200
@@ -22,6 +22,7 @@ GOPATH=$(shell go env GOPATH)
ASSETFS_PATH?=agent/bindata_assetfs.go
GOLDFLAGS=
+EXTLDFLAGS := ${LDFLAGS}
ifeq ($(FORCE_REBUILD),1)
NOCACHE=--no-cache
@@ -90,6 +91,7 @@ export GIT_DIRTY
export GIT_DESCRIBE
export GOTAGS
export GOLDFLAGS
+export EXTLDFLAGS
# Allow skipping docker build during integration tests in CI since we already
# have a built binary

View file

@ -1 +0,0 @@
CONSUL_FLAGS=""

View file

@ -1,9 +0,0 @@
post_upgrade() {
# improved permissions since 0.9.3-1
if [ "$(vercmp "$2" "0.9.3")" -lt 0 ]; then
chown 0:208 /etc/consul.d
chmod 0750 /etc/consul.d
echo -en "----\nThe directory permissions for /etc/consul.d/ have been fixed.\n----\n"
fi
true
}

View file

@ -1,16 +0,0 @@
[Unit]
Description=Consul Agent
Requires=network-online.target
After=network-online.target
[Service]
User=consul
Group=consul
EnvironmentFile=-/etc/default/consul
Restart=on-failure
ExecStart=/usr/bin/consul agent $CONSUL_FLAGS -config-dir=/etc/consul.d
ExecReload=/usr/bin/kill -HUP $MAINPID
KillSignal=SIGINT
[Install]
WantedBy=multi-user.target

View file

@ -1 +0,0 @@
u consul 208 - /var/lib/consul

View file

@ -1,12 +0,0 @@
--- a/./logger/syslog_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/./logger/syslog_test.go 2019-01-04 14:16:21.575451546 +0100
@@ -16,6 +16,9 @@ func TestSyslogFilter(t *testing.T) {
if os.Getenv("TRAVIS") == "true" {
t.Skip("Syslog not supported on travis-ci")
}
+ if os.Getenv("CONSUL_TEST_SKIP_SYSLOG") == "true" {
+ t.Skip("Skipping test due to env var CONSUL_TEST_SKIP_SYSLOG being set")
+ }
l, err := gsyslog.NewLogger(gsyslog.LOG_NOTICE, "LOCAL0", "consul")
if err != nil {

View file

@ -1,7 +0,0 @@
{
"data_dir": "/var/lib/consul",
"disable_update_check": true,
"log_level": "INFO",
"node_name": "example.localdomain",
"server": true
}

View file

@ -1,74 +0,0 @@
--- a/version/version.go 2018-06-26 09:57:33.703932696 +0200
+++ b/version/version.go 2018-06-26 09:59:05.986536238 +0200
@@ -1,7 +1,6 @@
package version
import (
- "fmt"
"strings"
)
@@ -27,24 +26,6 @@ var (
// for displaying to humans.
func GetHumanVersion() string {
version := Version
- if GitDescribe != "" {
- version = GitDescribe
- }
-
- release := VersionPrerelease
- if GitDescribe == "" && release == "" {
- release = "dev"
- }
-
- if release != "" {
- if !strings.HasSuffix(version, "-"+release) {
- // if we tagged a prerelease version then the release is in the version already
- version += fmt.Sprintf("-%s", release)
- }
- if GitCommit != "" {
- version += fmt.Sprintf(" (%s)", GitCommit)
- }
- }
// Strip off any single quotes added by the git information.
return strings.Replace(version, "'", "", -1)
--- a/GNUmakefile 2019-05-08 20:34:08.000000000 +0200
+++ b/GNUmakefile 2019-05-09 09:55:40.400630733 +0200
@@ -21,12 +21,7 @@ GOARCH?=$(shell go env GOARCH)
GOPATH=$(shell go env GOPATH)
ASSETFS_PATH?=agent/bindata_assetfs.go
-# Get the git commit
-GIT_COMMIT?=$(shell git rev-parse --short HEAD)
-GIT_DIRTY?=$(shell test -n "`git status --porcelain`" && echo "+CHANGES" || true)
-GIT_DESCRIBE?=$(shell git describe --tags --always --match "v*")
-GIT_IMPORT=github.com/hashicorp/consul/version
-GOLDFLAGS=-X $(GIT_IMPORT).GitCommit=$(GIT_COMMIT)$(GIT_DIRTY) -X $(GIT_IMPORT).GitDescribe=$(GIT_DESCRIBE)
+GOLDFLAGS=
ifeq ($(FORCE_REBUILD),1)
NOCACHE=--no-cache
@@ -248,16 +243,6 @@ ui: ui-docker static-assets-docker
tools:
go get -u -v $(GOTOOLS)
-version:
- @echo -n "Version: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh
- @echo -n "Version + release: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -r
- @echo -n "Version + git: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -g
- @echo -n "Version + release + git: "
- @$(SHELL) $(CURDIR)/build-support/scripts/version.sh -r -g
-
docker-images: go-build-image ui-build-image
@@ -286,4 +271,4 @@ proto:
.PHONY: all ci bin dev dist cov test test-ci test-internal test-install-deps cover format vet ui static-assets tools
.PHONY: docker-images go-build-image ui-build-image static-assets-docker consul-docker ui-docker
-.PHONY: version proto test-envoy-integ
+.PHONY: proto test-envoy-integ

View file

@ -1,54 +0,0 @@
diff -upr a/agent/cache/cache_test.go b/agent/cache/cache_test.go
--- a/agent/cache/cache_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/agent/cache/cache_test.go 2019-01-08 15:23:12.540631267 +0100
@@ -213,7 +213,6 @@ func TestCacheGet_blockingInitSameKey(t
// Test that Get with different cache keys both block on initial value
// but that the fetches were both properly called.
func TestCacheGet_blockingInitDiffKeys(t *testing.T) {
- t.Parallel()
require := require.New(t)
@@ -299,7 +298,6 @@ func TestCacheGet_blockingIndex(t *testi
// Test a get with an index set will timeout if the fetch doesn't return
// anything.
func TestCacheGet_blockingIndexTimeout(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -438,7 +436,6 @@ func TestCacheGet_emptyFetchResult(t *te
// Test that a type registered with a periodic refresh will perform
// that refresh after the timer is up.
func TestCacheGet_periodicRefresh(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -525,7 +522,6 @@ func TestCacheGet_periodicRefreshMultipl
// Test that a refresh performs a backoff.
func TestCacheGet_periodicRefreshErrorBackoff(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
@@ -566,7 +562,6 @@ func TestCacheGet_periodicRefreshErrorBa
// Test that a badly behaved RPC that returns 0 index will perform a backoff.
func TestCacheGet_periodicRefreshBadRPCZeroIndexErrorBackoff(t *testing.T) {
- t.Parallel()
typ := TestType(t)
defer typ.AssertExpectations(t)
diff -upr a/agent/cache-types/connect_ca_leaf_test.go b/agent/cache-types/connect_ca_leaf_test.go
--- a/agent/cache-types/connect_ca_leaf_test.go 2018-11-14 23:37:47.000000000 +0100
+++ b/agent/cache-types/connect_ca_leaf_test.go 2019-01-08 15:23:55.670339830 +0100
@@ -870,7 +870,6 @@ func TestConnectCALeaf_changingRoots(t *
// Test that after an initial signing, an expiringLeaf will trigger a
// blocking query to resign.
func TestConnectCALeaf_expiringLeaf(t *testing.T) {
- t.Parallel()
require := require.New(t)
rpc := TestRPC(t)