extra/qt6-webengine to 6.7.2-2

This commit is contained in:
Kevin Mihelich 2024-07-26 10:28:52 +00:00
parent aa731b9fbb
commit 51f873dd18
4 changed files with 37 additions and 27 deletions

View file

@ -1,7 +1,7 @@
pkgbase = qt6-webengine
pkgdesc = Provides support for web applications using the Chromium browser project
pkgver = 6.7.2
pkgrel = 1
pkgrel = 2
url = https://www.qt.io
arch = x86_64
groups = qt6
@ -69,11 +69,9 @@ pkgbase = qt6-webengine
source = git+https://code.qt.io/qt/qtwebengine-chromium
source = qtwebengine-6.7.0-ninja1.12.patch
source = qtwebengine-ffmpeg-7.patch
source = no-h264.patch
sha256sums = e4ea371bbe91763e0499b7d12166b43162f29e57ba81705870a0f8c4ba784408
sha256sums = SKIP
sha256sums = c037cccc1d43bcd9d67045354ca48b405acec217149cb4b2bd3cfb7b5561cc33
sha256sums = d31143fcb04acdb4d0a183eb0e1f37be66aad19454ebbbd326a8fa68ce6f0d35
sha256sums = 5e41df98141a5a3c6ab1ef1f1a45ea4a27631cfa3fe8b0cdd524624424d74541
sha256sums = f108c916ab87a247571255c56f9d04fc9bccdc3fe8972bf5a60d29636c6f5c3e
pkgname = qt6-webengine

View file

@ -10,7 +10,7 @@ highmem=1
pkgname=qt6-webengine
pkgver=6.7.2
pkgrel=1
pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@ -79,14 +79,12 @@ source=(git+https://code.qt.io/qt/$_pkgfn#tag=v$pkgver
git+https://code.qt.io/qt/qtwebengine-chromium
qtwebengine-6.7.0-ninja1.12.patch
qtwebengine-ffmpeg-7.patch
no-h264.patch
0001-ARM-toolchain-fixes.patch
0002-Run-blink-bindings-generation-single-threaded.patch)
sha256sums=('e4ea371bbe91763e0499b7d12166b43162f29e57ba81705870a0f8c4ba784408'
'SKIP'
'c037cccc1d43bcd9d67045354ca48b405acec217149cb4b2bd3cfb7b5561cc33'
'd31143fcb04acdb4d0a183eb0e1f37be66aad19454ebbbd326a8fa68ce6f0d35'
'5e41df98141a5a3c6ab1ef1f1a45ea4a27631cfa3fe8b0cdd524624424d74541'
'f108c916ab87a247571255c56f9d04fc9bccdc3fe8972bf5a60d29636c6f5c3e'
'772aeba76d16387e28ef629285965109a4bfaa02ca2dd466e9526fe2030773ec'
'eff4ebf2e714185ef6e36e30c8d2158da6b41a46e3168d06472d35f6c9977aaf')
@ -98,9 +96,8 @@ prepare() {
# Fix build with ninja 1.12 - Gentoo patch
patch -p1 -i ../qtwebengine-6.7.0-ninja1.12.patch
# Fix build with ffmpeg 7 - OpenSUSE and Chromium patches
# Fix build with ffmpeg 7 - Chromium patches
patch -d src/3rdparty/chromium -p1 -i "$srcdir"/qtwebengine-ffmpeg-7.patch
patch -p1 -i ../no-h264.patch
if [[ $CARCH == "armv7h" ]]; then
export MAKEFLAGS="-j1"

View file

@ -1,17 +0,0 @@
From: Fabian Vogt <fabian@ritter-vogt.de>
Subject: Don't require open264 when proprietary_codecs are supported
diff --git a/src/3rdparty/chromium/third_party/webrtc/webrtc.gni b/src/3rdparty/chromium/third_party/webrtc/webrtc.gni
index 5a1c43c8888..d867f7e5330 100644
--- a/src/3rdparty/chromium/third_party/webrtc/webrtc.gni
+++ b/src/3rdparty/chromium/third_party/webrtc/webrtc.gni
@@ -186,8 +186,7 @@ declare_args() {
#
# Enabling H264 when building with MSVC is currently not supported, see
# bugs.webrtc.org/9213#c13 for more info.
- rtc_use_h264 =
- proprietary_codecs && !is_android && !is_ios && !(is_win && !is_clang)
+ rtc_use_h264 = false
# Enable to use H265
rtc_use_h265 = proprietary_codecs

View file

@ -551,3 +551,35 @@ index e1be5aa9a5b13..951c003956fb5 100644
const base::TimeDelta frame_duration =
base::Seconds(frames_read / static_cast<double>(sample_rate_));
diff --git a/chromium/third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc b/chromium/third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc
index c6446c2..805b95b 100644
--- a/third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc
+++ b/third_party/webrtc/modules/video_coding/codecs/h264/h264_decoder_impl.cc
@@ -233,7 +233,6 @@
int total_size = y_size + 2 * uv_size;
av_frame->format = context->pix_fmt;
- av_frame->reordered_opaque = context->reordered_opaque;
// Create a VideoFrame object, to keep a reference to the buffer.
// TODO(nisse): The VideoFrame's timestamp and rotation info is not used.
@@ -381,8 +380,6 @@
return WEBRTC_VIDEO_CODEC_ERROR;
}
packet->size = static_cast<int>(input_image.size());
- int64_t frame_timestamp_us = input_image.ntp_time_ms_ * 1000; // ms -> μs
- av_context_->reordered_opaque = frame_timestamp_us;
int result = avcodec_send_packet(av_context_.get(), packet.get());
@@ -399,10 +396,6 @@
return WEBRTC_VIDEO_CODEC_ERROR;
}
- // We don't expect reordering. Decoded frame timestamp should match
- // the input one.
- RTC_DCHECK_EQ(av_frame_->reordered_opaque, frame_timestamp_us);
-
// TODO(sakal): Maybe it is possible to get QP directly from FFmpeg.
h264_bitstream_parser_.ParseBitstream(input_image);
absl::optional<int> qp = h264_bitstream_parser_.GetLastSliceQp();