mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/chromium to to 27.0.1453.93-2
This commit is contained in:
parent
1d0f1b25df
commit
5230dcdecc
2 changed files with 45 additions and 0 deletions
|
@ -40,6 +40,7 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
|
|||
chromium.default
|
||||
chromium.sh
|
||||
chromium-pnacl-r0.patch
|
||||
chromium-27.0.1453.93-fix-crash-when-quickly-dragging-a-new-tab.patch
|
||||
chromium-26.0.1410.43-speechd-0.8.patch
|
||||
die-sysroot-die.patch)
|
||||
sha256sums=('7af8f70745992afdee0196039b5beab1b86b6de7fa70ca4f4a04dc335f034b3f'
|
||||
|
@ -48,6 +49,7 @@ sha256sums=('7af8f70745992afdee0196039b5beab1b86b6de7fa70ca4f4a04dc335f034b3f'
|
|||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
'9875ffcc0e9ae9420876ac66b130b1b017d445a031d43cbe0119793e1fb3781c'
|
||||
'23b04468881642ffdc8457016c8f91df395dfccb4af2ad6b758168180ae070f3'
|
||||
'd530f52cb485ff8da035b38ffebe171309a1d8e515040f5e6398ecb286336797'
|
||||
'66705264d9e679a58ed522b4475a06c8a5a4fe52a709c537b1a7d5aa43fb6c84')
|
||||
|
||||
prepare() {
|
||||
|
@ -59,6 +61,10 @@ prepare() {
|
|||
# Fix build without pnacl (patch from Gentoo)
|
||||
patch -Np0 -i "$srcdir/chromium-pnacl-r0.patch"
|
||||
|
||||
# Fix crash when quickly dragging a new tab
|
||||
# https://code.google.com/p/chromium/issues/detail?id=228918
|
||||
patch -Np1 -i "$srcdir/chromium-27.0.1453.93-fix-crash-when-quickly-dragging-a-new-tab.patch"
|
||||
|
||||
# Fix header location for speech-dispatcher 0.8 (patch from PLD Linux)
|
||||
patch -Np2 -i "$srcdir/chromium-26.0.1410.43-speechd-0.8.patch"
|
||||
|
||||
|
|
|
@ -0,0 +1,39 @@
|
|||
From afcf3acc715aef47855ced19434dba2f52b92400 Mon Sep 17 00:00:00 2001
|
||||
From: "dcheng@chromium.org"
|
||||
<dcheng@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>
|
||||
Date: Fri, 24 May 2013 21:49:42 +0000
|
||||
Subject: [PATCH] Fix crash when quickly dragging a new tab.
|
||||
|
||||
The root cause is r185551, which changed the semantics of
|
||||
scoped_ptr::reset(). This code depended on the fact that a get() during
|
||||
a reset() would return the original value of the stored pointer, but
|
||||
after r185551, it returns the value that it is being reset to. This
|
||||
caused the code to stop an animation and the code to end a drag to
|
||||
conflict, since the animation code would sometimes delete a TabGtk that
|
||||
was still being dragged.
|
||||
|
||||
BUG=228918
|
||||
|
||||
Review URL: https://chromiumcodereview.appspot.com/16035005
|
||||
|
||||
git-svn-id: svn://svn.chromium.org/chrome/trunk/src@202184 0039d316-1c4b-4281-b951-d872f2087c98
|
||||
---
|
||||
chrome/browser/ui/gtk/tabs/tab_strip_gtk.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chrome/browser/ui/gtk/tabs/tab_strip_gtk.cc b/chrome/browser/ui/gtk/tabs/tab_strip_gtk.cc
|
||||
index d86364d..4e6c352 100644
|
||||
--- a/chrome/browser/ui/gtk/tabs/tab_strip_gtk.cc
|
||||
+++ b/chrome/browser/ui/gtk/tabs/tab_strip_gtk.cc
|
||||
@@ -1406,7 +1406,7 @@ void TabStripGtk::RemoveTabAt(int index) {
|
||||
// Remove the Tab from the TabStrip's list.
|
||||
tab_data_.erase(tab_data_.begin() + index);
|
||||
|
||||
- if (!IsDragSessionActive() || !drag_controller_->IsDraggingTab(removed)) {
|
||||
+ if (!removed->dragging()) {
|
||||
gtk_container_remove(GTK_CONTAINER(tabstrip_.get()), removed->widget());
|
||||
delete removed;
|
||||
}
|
||||
--
|
||||
1.8.2.3
|
||||
|
Loading…
Reference in a new issue