mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/freeimage to 3.18.0-15
This commit is contained in:
parent
4eb5e2329d
commit
52ad0e7069
2 changed files with 16 additions and 18 deletions
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgname=freeimage
|
||||
pkgver=3.18.0
|
||||
pkgrel=14
|
||||
pkgrel=15
|
||||
pkgdesc="Library project for developers who would like to support popular graphics image formats"
|
||||
arch=('x86_64')
|
||||
license=('GPL' 'custom:FIPL')
|
||||
|
@ -20,7 +20,7 @@ source=("https://downloads.sourceforge.net/project/freeimage/Source%20Distributi
|
|||
freeimage-unbundle.patch
|
||||
freeimage-libraw-0.20.patch)
|
||||
sha512sums=('9d9cc7e2d57552c3115e277aeb036e0455204d389026b17a3f513da5be1fd595421655488bb1ec2f76faebed66049119ca55e26e2a6d37024b3fb7ef36ad4818'
|
||||
'8bd50232864058c407ef931b1d3981c18dc9fe5a696a4788afaaf579d0918a6e007ef699b4815a803792cd37b959aceb290ac9d47515982021b373c4df85ceae'
|
||||
'bd96331900e3f13c8830ef59377c840fa36b3c3ef97d1effd6f644acfefb7d618812b268f00f8f051e9d4c978b8dac0c0ab0e6ec7db5aaebf0fa0328913cfaac'
|
||||
'5709e4c5baac3505bf2f2498082fbf6b8614e631fec69fc629036c8d033fbe21434a198e9ae24d577dd65928fd31a0d95c584ea4349d74134f7859d4e57b8397')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -613,8 +613,8 @@ diff -rupN FreeImage/Source/Metadata/TagConversion.cpp FreeImage-new/Source/Meta
|
|||
*/
|
||||
diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTIFF.cpp
|
||||
--- FreeImage/Source/Metadata/XTIFF.cpp 2015-03-03 23:07:10.000000000 +0100
|
||||
+++ FreeImage-new/Source/Metadata/XTIFF.cpp 2018-07-31 23:37:58.564953201 +0200
|
||||
@@ -29,13 +29,18 @@
|
||||
+++ FreeImage-new/Source/Metadata/XTIFF.cpp 2022-06-06 21:13:28.672755346 +0200
|
||||
@@ -29,7 +29,7 @@
|
||||
#pragma warning (disable : 4786) // identifier was truncated to 'number' characters
|
||||
#endif
|
||||
|
||||
|
@ -623,18 +623,7 @@ diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTI
|
|||
|
||||
#include "FreeImage.h"
|
||||
#include "Utilities.h"
|
||||
#include "FreeImageTag.h"
|
||||
#include "FIRational.h"
|
||||
|
||||
+extern "C"
|
||||
+{
|
||||
+ int _TIFFDataSize(TIFFDataType type);
|
||||
+}
|
||||
+
|
||||
// ----------------------------------------------------------
|
||||
// Extended TIFF Directory GEO Tag Support
|
||||
// ----------------------------------------------------------
|
||||
@@ -224,6 +229,33 @@ tiff_write_geotiff_profile(TIFF *tif, FI
|
||||
@@ -224,6 +224,33 @@ tiff_write_geotiff_profile(TIFF *tif, FI
|
||||
// TIFF EXIF tag reading & writing
|
||||
// ----------------------------------------------------------
|
||||
|
||||
|
@ -668,7 +657,7 @@ diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTI
|
|||
/**
|
||||
Read a single Exif tag
|
||||
|
||||
@@ -575,45 +607,11 @@ tiff_read_exif_tags(TIFF *tif, TagLib::M
|
||||
@@ -575,45 +602,11 @@ tiff_read_exif_tags(TIFF *tif, TagLib::M
|
||||
|
||||
// loop over all Core Directory Tags
|
||||
// ### uses private data, but there is no other way
|
||||
|
@ -717,7 +706,7 @@ diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTI
|
|||
}
|
||||
|
||||
return TRUE;
|
||||
@@ -723,10 +721,9 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
|
||||
@@ -723,10 +716,9 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
|
||||
|
||||
TagLib& tag_lib = TagLib::instance();
|
||||
|
||||
|
@ -731,6 +720,15 @@ diff -rupN FreeImage/Source/Metadata/XTIFF.cpp FreeImage-new/Source/Metadata/XTI
|
|||
|
||||
if(skip_write_field(tif, tag_id)) {
|
||||
// skip tags that are already handled by the LibTIFF writing process
|
||||
@@ -749,7 +741,7 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
|
||||
continue;
|
||||
}
|
||||
// type of storage may differ (e.g. rationnal array vs float array type)
|
||||
- if((unsigned)_TIFFDataSize(tif_tag_type) != FreeImage_TagDataWidth(tag_type)) {
|
||||
+ if((unsigned)TIFFFieldSetGetSize(fld) != FreeImage_TagDataWidth(tag_type)) {
|
||||
// skip tag or _TIFFmemcpy will fail
|
||||
continue;
|
||||
}
|
||||
diff -rupN FreeImage/Source/Utilities.h FreeImage-new/Source/Utilities.h
|
||||
--- FreeImage/Source/Utilities.h 2016-04-11 15:15:32.000000000 +0200
|
||||
+++ FreeImage-new/Source/Utilities.h 2018-08-01 00:16:29.826825358 +0200
|
||||
|
|
Loading…
Reference in a new issue