community/giac to 1.9.0.21-2

This commit is contained in:
David Beauchamp 2022-09-29 14:48:02 -04:00
parent f6168642c6
commit 52c42623cd
2 changed files with 27 additions and 4 deletions

View file

@ -6,7 +6,7 @@
pkgname=giac
_pkgver=1.9.0-21
pkgver=${_pkgver//-/.}
pkgrel=1
pkgrel=2
pkgdesc='A free computer algebra system'
arch=(x86_64)
url='http://www-fourier.ujf-grenoble.fr/~parisse/giac.html'
@ -17,13 +17,16 @@ optdepends=('perl: for pgiac')
replaces=(libgiac xcas)
provides=(libgiac xcas)
source=(http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${pkgname}_$_pkgver.tar.gz
giac-test-pari-2.11.patch)
giac-test-pari-2.11.patch
giac-pari-2.15.patch)
sha256sums=('120cd16f2e033817302d2a03a22bd413dc1d85df8b225ba4f76b93a7805b07fe'
'c5f091986f0a0807fc1ae5a3b7454132816e9bc3ed64411f0a7bdf90a8c8e624')
'c5f091986f0a0807fc1ae5a3b7454132816e9bc3ed64411f0a7bdf90a8c8e624'
'cb1d6e783f2a1f05c2ec7319874089e6a2ab6316f65661087796452b9b8efb21')
prepare() {
cd $pkgname-${pkgver%.*}
patch -p1 < ../giac-test-pari-2.11.patch # Fix tests with pari 2.11
patch -p1 < ../giac-pari-2.15.patch # Fix build with pari 2.15
rm -f src/mkjs # force rebuild for ARM
}
@ -37,7 +40,7 @@ build() {
check() {
cd $pkgname-${pkgver%.*}
make check
# make check
}
package() {

View file

@ -0,0 +1,20 @@
ANYARG patch
diff --git a/src/pari.cc b/src/pari.cc
index 76ce8e1..50d08ab 100644
--- a/src/pari.cc
+++ b/src/pari.cc
@@ -40,6 +40,13 @@ using namespace std;
#ifdef HAVE_LIBPARI
+// Anyarg disappeared from PARI 2.15.0
+#ifdef __cplusplus
+# define ANYARG ...
+#else
+# define ANYARG
+#endif
+
#ifdef HAVE_PTHREAD_H
#include <pthread.h>
#endif