mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
community/xulrunner to 37.0.2-1
This commit is contained in:
parent
0501c9e5aa
commit
53117907d7
2 changed files with 2 additions and 30 deletions
|
@ -9,7 +9,7 @@
|
|||
# - patch for skia FTBFS on ARM
|
||||
|
||||
pkgname=xulrunner
|
||||
pkgver=37.0.1
|
||||
pkgver=37.0.2
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla Runtime Environment"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -21,15 +21,13 @@ source=(ftp://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/
|
|||
mozconfig
|
||||
mozilla-pkgconfig.patch
|
||||
shared-libs.patch
|
||||
rhbz-966424.patch
|
||||
48e130d69836.patch)
|
||||
options=('!emptydirs' 'staticlibs')
|
||||
replaces=('xulrunner-oss')
|
||||
sha256sums=('b06a8c9bb04d128ab0637abf7dc1b2c36ffe8930c76e1f37e5abe18c48815952'
|
||||
sha256sums=('c08bc152c54bb26d21320ddc2fb57c29ea5f4d84f3d04434698d9d6172c2cd60'
|
||||
'08e7c8e40ca3ab68f91b18b84a4fbbba00767c88d84c0cfcdd52fe5e36083207'
|
||||
'1aa9ebe67542a2b8c28905d070829ada5b29438c6a7961f2b0cdd6b92d8b9f5c'
|
||||
'59d9fc421bc10a5515b73e159f44a72365bf7b7e8b3fc8a8c46043ef40bd3a40'
|
||||
'746cb474c5a2c26fc474256e430e035e604b71b27df1003d4af85018fa263f4a'
|
||||
'ab2d45b70d2006b539af3ea6e6f119d8aa62ef26f9b0d9813b728f22bf7af1de')
|
||||
|
||||
prepare() {
|
||||
|
@ -40,9 +38,6 @@ prepare() {
|
|||
patch -Np1 -i ../mozilla-pkgconfig.patch
|
||||
patch -Np1 -i ../shared-libs.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/41689
|
||||
patch -Np1 -i ../rhbz-966424.patch
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1136958
|
||||
patch -p1 -i ../48e130d69836.patch
|
||||
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
--- a/toolkit/modules/CertUtils.jsm
|
||||
+++ b/toolkit/modules/CertUtils.jsm
|
||||
@@ -170,17 +170,19 @@ this.checkCert =
|
||||
issuerCert = issuerCert.QueryInterface(Ci.nsIX509Cert3);
|
||||
var tokenNames = issuerCert.getAllTokenNames({});
|
||||
|
||||
if (!tokenNames || !tokenNames.some(isBuiltinToken))
|
||||
throw new Ce(certNotBuiltInErr, Cr.NS_ERROR_ABORT);
|
||||
}
|
||||
|
||||
function isBuiltinToken(tokenName) {
|
||||
- return tokenName == "Builtin Object Token";
|
||||
+ return tokenName == "Builtin Object Token" ||
|
||||
+ tokenName == "Default Trust" ||
|
||||
+ tokenName == "System Trust";
|
||||
}
|
||||
|
||||
/**
|
||||
* This class implements nsIBadCertListener. Its job is to prevent "bad cert"
|
||||
* security dialogs from being shown to the user. It is better to simply fail
|
||||
* if the certificate is bad. See bug 304286.
|
||||
*
|
||||
* @param aAllowNonBuiltInCerts (optional)
|
Loading…
Reference in a new issue