mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/texlive-bin to 2011.3-1
This commit is contained in:
parent
56b4fe7008
commit
5314eb8f01
3 changed files with 94 additions and 82 deletions
|
@ -1,16 +1,16 @@
|
|||
# Maintainer: Rémy Oudompheng <remy@archlinux.org>
|
||||
# Contributor: francois <francois.archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Removed clisp makedepend, removed xindy from build and packaging (only thing that used clisp)
|
||||
# - Use -fPIC with armv7
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=texlive-bin
|
||||
pkgver=2011.1
|
||||
pkgver=2011.3
|
||||
_luatex_ver=0.70.1
|
||||
pkgrel=5
|
||||
pkgrel=1
|
||||
pkgdesc="TeX Live binaries"
|
||||
license=('GPL')
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -19,17 +19,16 @@ makedepends=('perl' 'ffcall')
|
|||
optdepends=('ed: for texconfig')
|
||||
provides=('lcdf-typetools' 'kpathsea' 'pdfjam')
|
||||
conflicts=('pdfjam')
|
||||
options=('!libtool')
|
||||
options=('!libtool' '!strip')
|
||||
url='http://tug.org/texlive/'
|
||||
install="texlive.install"
|
||||
source=('texmf.cnf'
|
||||
'fix-fontforge-encoding.patch'
|
||||
'09-texlive-fonts.conf'
|
||||
'archlinux-build.patch'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20110724.tar.xz'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20110724.tar.xz'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20111210.tar.xz'
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20111210.tar.xz'
|
||||
# "http://foundry.supelec.fr/gf/download/frsrelease/392/1730/luatex-beta-${_luatex_ver}.tar.bz2"
|
||||
'http://mirrors.kernel.org/archlinux/other/texlive/luatex-svn4356.tar.xz'
|
||||
'http://ftp.archlinux.org/other/texlive/luatex-svn4356.tar.xz'
|
||||
)
|
||||
backup=(etc/texmf/web2c/texmf.cnf \
|
||||
etc/texmf/chktex/chktexrc \
|
||||
|
@ -45,12 +44,11 @@ backup=(etc/texmf/web2c/texmf.cnf \
|
|||
etc/texmf/dvipdfm/config/config \
|
||||
etc/texmf/xdvi/XDvi)
|
||||
|
||||
md5sums=('ff30d6813babd2e41c414365eea9c147'
|
||||
md5sums=('220a4f4cc0d915bf8fcbcb553dcee1ae'
|
||||
'bfb9716aa00c86c08cd31e5b32edeb98'
|
||||
'393a4bf67adc7ca5df2b386759d1a637'
|
||||
'94ef5571a54262790ab64d6d044dd10c'
|
||||
'58e8ab64188eaf15897b7acf472dca9f'
|
||||
'9f7ae1aa24afd9e34289ac10a8f9e87b'
|
||||
'c7bb38c0ab30c2b64cf4cf83a736b35c'
|
||||
'5d8f06a3683ce88a3c33e15f5ba6a858'
|
||||
'e7f0197559ef865d8c01683dab3b8526')
|
||||
|
||||
build() {
|
||||
|
@ -107,11 +105,6 @@ build() {
|
|||
#############################################################
|
||||
### configure
|
||||
cd source
|
||||
patch -Np1 -i ${srcdir}/archlinux-build.patch
|
||||
for _dir in texk/tetex texk/texlive texk/tex4htk \
|
||||
utils/ps2eps utils/chktex utils/psutils; do
|
||||
(cd ${_dir} && automake) || true
|
||||
done
|
||||
## prevent compiling Xdvi with libXp
|
||||
sed -i~ 's|-lXp ||' texk/xdvik/configure
|
||||
test ! -d Work && mkdir Work
|
||||
|
@ -119,6 +112,7 @@ build() {
|
|||
echo "--> Initial configuration..."
|
||||
# we use temporary prefix to avoid messing the existing $pkgdir/usr/share/texmf tree
|
||||
../configure --prefix=/usr -C \
|
||||
--sysconfdir=/etc \
|
||||
--datarootdir=/usr/share \
|
||||
--datadir=/usr/share \
|
||||
--mandir=/usr/share/man \
|
||||
|
@ -173,16 +167,6 @@ package() {
|
|||
install -d -m755 $pkgdir/etc/texmf/xdvi
|
||||
install -d -m755 $pkgdir/etc/fonts/conf.avail
|
||||
install -m644 $srcdir/09-texlive-fonts.conf $pkgdir/etc/fonts/conf.avail/
|
||||
# replace upstream texmf.cnf with ours
|
||||
rm -f $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
install -m644 $srcdir/texmf.cnf $pkgdir/etc/texmf/web2c/texmf.cnf
|
||||
# since the location of texmf.cnf is hard-wired to be under /usr/share/texmf/web2c
|
||||
# we make a symlink from /etc/texmf/web2c/texmf.cnf to the latter
|
||||
ln -s /etc/texmf/web2c/texmf.cnf $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
# fix location of TEXMFCACHE for luatools
|
||||
sed -i 's#texlive2010#texlive#' $pkgdir/usr/share/texmf/web2c/texmfcnf.lua
|
||||
## remove aleph from fmtutil.cnf
|
||||
sed -i -e '/aleph/d' $pkgdir/usr/share/texmf/web2c/fmtutil.cnf
|
||||
# move man files to /usr/share/man
|
||||
for i in 1 5; do
|
||||
install -d -m755 $pkgdir/usr/share/man/man$i
|
||||
|
@ -232,7 +216,18 @@ package() {
|
|||
echo "-------------------------------------------------------"
|
||||
cd Work
|
||||
make DESTDIR=${pkgdir} texmf=$pkgdir/usr/share/texmf install
|
||||
rm -rf ${pkgdir}/usr/{texmf,texmf-dist}
|
||||
rm -rf ${pkgdir}/usr/{texmf,share/texmf-dist}
|
||||
|
||||
# replace upstream texmf.cnf with ours
|
||||
rm -f $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
install -m644 $srcdir/texmf.cnf $pkgdir/etc/texmf/web2c/texmf.cnf
|
||||
# since the location of texmf.cnf is hard-wired to be under /usr/share/texmf/web2c
|
||||
# we make a symlink from /etc/texmf/web2c/texmf.cnf to the latter
|
||||
ln -sf /etc/texmf/web2c/texmf.cnf $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
# fix location of TEXMFCACHE for luatools
|
||||
sed -i 's#texlive2010#texlive#' $pkgdir/usr/share/texmf/web2c/texmfcnf.lua
|
||||
## remove aleph from fmtutil.cnf
|
||||
sed -i -e '/aleph/d' $pkgdir/usr/share/texmf/web2c/fmtutil.cnf
|
||||
|
||||
## install luatex binary
|
||||
#install -m755 $srcdir/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex $pkgdir/usr/bin/
|
||||
|
@ -250,14 +245,20 @@ package() {
|
|||
PATH="$PATH:${pkgdir}/usr/bin" texlinks -f $pkgdir/usr/share/texmf/web2c/fmtutil.cnf $pkgdir/usr/bin/
|
||||
#############################################################
|
||||
# remove dangling symlinks
|
||||
_bibtexextra_scripts="bibexport"
|
||||
_bibtexextra_scripts="
|
||||
bibexport
|
||||
urlbst
|
||||
"
|
||||
_core_scripts="
|
||||
afm2afm
|
||||
arlatex
|
||||
autoinst
|
||||
bundledoc
|
||||
cmap2enc
|
||||
ctanify
|
||||
ctanupload
|
||||
de-macro
|
||||
dosepsbin
|
||||
dviasm
|
||||
epstopdf
|
||||
findhyph
|
||||
|
@ -270,6 +271,8 @@ latexdiff-vc
|
|||
latexmk
|
||||
latexrevise
|
||||
listings-ext.sh
|
||||
match_parens
|
||||
mf2pt1
|
||||
mkjobtexmf
|
||||
mkluatexfontdb
|
||||
mkt1font
|
||||
|
@ -301,6 +304,7 @@ texcount
|
|||
texdef
|
||||
texdiff
|
||||
texdirflatten
|
||||
texliveonfly
|
||||
texloganalyser
|
||||
thumbpdf
|
||||
vpl2ovp
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
diff -ur source.old/texk/am/script_links.am source/texk/am/script_links.am
|
||||
--- source.old/texk/am/script_links.am 2011-05-02 13:54:33.000000000 +0200
|
||||
+++ source/texk/am/script_links.am 2011-06-05 11:22:53.118216353 +0200
|
||||
@@ -51,8 +51,8 @@
|
||||
# We support both multiplatform and non-multiplatform builds.
|
||||
install-links:
|
||||
case "$(bindir)" in \
|
||||
- */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. TYPE=$(TYPE) EXT=$(EXT) make-links;; \
|
||||
- */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. TYPE=$(TYPE) EXT=$(EXT) make-links;; \
|
||||
+ */bin) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) TYPE=$(TYPE) EXT=$(EXT) make-links;; \
|
||||
+ */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) TYPE=$(TYPE) EXT=$(EXT) make-links;; \
|
||||
*) echo "strange directory '$(bindir)' for linked $(TYPE) scripts" >&2; \
|
||||
exit 1;; \
|
||||
esac
|
||||
diff -ur source.old/texk/tetex/Makefile.am source/texk/tetex/Makefile.am
|
||||
--- source.old/texk/tetex/Makefile.am 2011-05-31 11:47:04.000000000 +0200
|
||||
+++ source/texk/tetex/Makefile.am 2011-06-05 10:28:40.287025375 +0200
|
||||
@@ -35,7 +35,7 @@
|
||||
|
||||
include $(srcdir)/../am/script_links.am
|
||||
|
||||
-texmfdir = ${prefix}/$(scriptsdir)
|
||||
+texmfdir = $(datadir)/$(scriptsdir)
|
||||
dist_texmf_SCRIPTS = $(perl_scripts:=.pl) $(shell_scripts:=.sh)
|
||||
|
||||
if !WIN32
|
||||
diff -ur source.old/texk/texlive/linked_scripts/Makefile.am source/texk/texlive/linked_scripts/Makefile.am
|
||||
--- source.old/texk/texlive/linked_scripts/Makefile.am 2011-05-31 11:47:04.000000000 +0200
|
||||
+++ source/texk/texlive/linked_scripts/Makefile.am 2011-06-05 09:41:50.997250443 +0200
|
||||
@@ -165,8 +165,8 @@
|
||||
done
|
||||
else !WIN32
|
||||
case "$(bindir)" in \
|
||||
- */bin) $(MAKE) $(AM_MAKEFLAGS) REL=.. install-links;; \
|
||||
- */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=../.. install-links;; \
|
||||
+ */bin) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) install-links;; \
|
||||
+ */bin/*) $(MAKE) $(AM_MAKEFLAGS) REL=$(datadir) install-links;; \
|
||||
*) echo "strange directory '$(bindir)' for linked scripts" >&2; \
|
||||
exit 1;; \
|
||||
esac
|
|
@ -200,6 +200,24 @@ TEXINPUTS.xelatex = .;$TEXMF/tex/{xelatex,latex,xetex,generic,}//
|
|||
TEXINPUTS.xeplain = .;$TEXMF/tex/{xeplain,eplain,plain,xetex,generic,}//
|
||||
TEXINPUTS.xetex = .;$TEXMF/tex/{xetex,plain,generic,}//
|
||||
|
||||
% Omega / Aleph.
|
||||
TEXINPUTS.aleph = .;$TEXMF/tex/{plain,generic,}//
|
||||
TEXINPUTS.elambda = .;$TEXMF/tex/{lambda,latex,generic,}//
|
||||
TEXINPUTS.eomega = .;$TEXMF/tex/{plain,generic,}//
|
||||
TEXINPUTS.lambda = .;$TEXMF/tex/{lambda,latex,generic,}//
|
||||
TEXINPUTS.lamed = .;$TEXMF/tex/{lamed,lambda,latex,generic,}//
|
||||
TEXINPUTS.omega = .;$TEXMF/tex/{plain,generic,}//
|
||||
|
||||
% p(La)TeX.
|
||||
TEXINPUTS.ptex = .;$TEXMF/tex/{ptex,ptexgeneric,plain,generic,}//
|
||||
TEXINPUTS.platex = .;$TEXMF/tex/{platex,ptexgeneric,latex,generic,}//
|
||||
|
||||
% epTeX.
|
||||
TEXINPUTS.eptex = .;$TEXMF/tex/{ptex,ptexgeneric,plain,generic,}//
|
||||
|
||||
% pBibTeX bibliographies and style files.
|
||||
BIBINPUTS.pbibtex = .;$TEXMF/{pbibtex,bibtex}/bib//
|
||||
BSTINPUTS.pbibtex = .;$TEXMF/{pbibtex,bibtex}/bst//
|
||||
|
||||
% ConTeXt.
|
||||
TEXINPUTS.context = .;$TEXMF/tex/{context,plain,generic,}//
|
||||
|
@ -285,6 +303,10 @@ BSTINPUTS = .;$TEXMF/bibtex/{bst,csf}//
|
|||
MLBIBINPUTS = .;$TEXMF/bibtex/bib/{mlbib,}//
|
||||
MLBSTINPUTS = .;$TEXMF/bibtex/{mlbst,bst}//
|
||||
|
||||
% .ris and .bltxml bibliography formats.
|
||||
RISINPUTS = .;$TEXMF/bibtex/ris//
|
||||
BLTXMLINPUTS = .;$TEXMF/bibtex/bltxml//
|
||||
|
||||
% MFT style files.
|
||||
MFTINPUTS = .;$TEXMF/mft//
|
||||
|
||||
|
@ -307,7 +329,7 @@ AFMFONTS = .;$TEXMF/fonts/afm//;$OSFONTDIR//
|
|||
% TrueType outline fonts.
|
||||
TTFONTS = .;$TEXMF/fonts/{truetype,opentype}//;$OSFONTDIR//
|
||||
|
||||
% Opentype outline fonts.
|
||||
% OpenType outline fonts.
|
||||
OPENTYPEFONTS = .;$TEXMF/fonts/{opentype,truetype}//;$OSFONTDIR//
|
||||
|
||||
% Type 42 outline fonts.
|
||||
|
@ -331,9 +353,6 @@ CMAPFONTS = .;$TEXMF/fonts/cmap//
|
|||
% Subfont definition files.
|
||||
SFDFONTS = .;$TEXMF/fonts/sfd//
|
||||
|
||||
% OpenType outline fonts.
|
||||
OPENTYPEFONTS = .;$TEXMF/fonts/opentype//
|
||||
|
||||
% OpenType feature files (.fea).
|
||||
FONTFEATURES=.;$TEXMF/fonts/fea//
|
||||
|
||||
|
@ -353,11 +372,13 @@ MPSUPPORT = .;$TEXMF/metapost/support
|
|||
MIMELIBDIR = /etc
|
||||
MAILCAPLIBDIR = /etc
|
||||
|
||||
% Default settings for fontconfig library, used by Windows versions of
|
||||
% xetex/xdvipdfmx. On Unixish systems, fontconfig ignores this.
|
||||
FONTCONFIG_FILE=fonts.conf
|
||||
FONTCONFIG_PATH=$TEXMFSYSVAR/fonts/conf
|
||||
FC_CACHEDIR=$TEXMFSYSVAR/fonts/cache
|
||||
% Default settings for the fontconfig library as used by the Windows
|
||||
% versions of xetex/xdvipdfmx. On Unixish systems, fontconfig ignores
|
||||
% this. ConTeXT MkIV (all platforms) also use these values.
|
||||
%
|
||||
FONTCONFIG_FILE = fonts.conf
|
||||
FONTCONFIG_PATH = $TEXMFSYSVAR/fonts/conf
|
||||
FC_CACHEDIR = $TEXMFSYSVAR/fonts/cache
|
||||
|
||||
% TeX documentation and source files, for use with texdoc and kpsewhich.
|
||||
TEXDOCS = $TEXMF/doc//
|
||||
|
@ -392,10 +413,19 @@ TW_INIPATH = $TW_LIBPATH
|
|||
% would allow command execution.
|
||||
DVIPDFMXINPUTS = $TEXMF/dvipdfmx
|
||||
|
||||
% Find scripts that are distributed/installed in the texmf tree.
|
||||
|
||||
% Lua needs to look in TEXINPUTS for lua scripts distributed with packages.
|
||||
LUAINPUTS = .;$TEXMF/scripts/{$progname,$engine,}/{lua,}//;$TEXINPUTS
|
||||
%
|
||||
% But we can't simply use $TEXINPUTS, since then if TEXINPUTS is set in
|
||||
% the environment with a colon, say, TEXINPUTS=/some/dir:, the intended
|
||||
% default expansion of TEXINPUTS will not happen and .lua files under
|
||||
% the /tex/ will not be found.
|
||||
%
|
||||
% So, duplicate the TEXINPUTS.*lualatex values as LUAINPUTS.*lualatex.
|
||||
% The default LUAINPUTS sufficess for luatex and dviluatex.
|
||||
%
|
||||
LUAINPUTS.lualatex = .;$TEXMF/scripts/{$progname,$engine,}/{lua,}//;$TEXMF/tex/{lualatex,latex,luatex,generic,}//
|
||||
LUAINPUTS.dvilualatex = .;$TEXMF/scripts/{$progname,$engine,}/{lua,}//;$TEXMF/tex/{lualatex,latex,luatex,generic,}//
|
||||
LUAINPUTS = .;$TEXMF/scripts/{$progname,$engine,}/{lua,}//;$TEXMF/tex/{luatex,plain,generic,}//
|
||||
|
||||
% Lua needs to look for binary lua libraries distributed with packages.
|
||||
CLUAINPUTS = .;$SELFAUTOLOC/lib/{$progname,$engine,}/lua//
|
||||
|
@ -563,7 +593,8 @@ TEX = etex
|
|||
% interactive `e' option. %d is replaced by the line number and %s by
|
||||
% the current filename. The default is specified at compile-time, and
|
||||
% we let that stay in place since different platforms like different values.
|
||||
%TEXEDIT = vi +%d "%s"
|
||||
%TEXEDIT = vi +%d '%s' % default for Unix
|
||||
%TEXEDIT = texworks --position=+%d "%s" % default for Windows
|
||||
%MFEDIT = ${TEXEDIT}
|
||||
%MPEDIT = ${TEXEDIT}
|
||||
|
||||
|
@ -571,6 +602,18 @@ TEX = etex
|
|||
% given as command line option or environment variable.
|
||||
BIBTEX_CSFILE = 88591lat.csf
|
||||
|
||||
% This variable is specific to Windows. It must be set to 0 or 1. The
|
||||
% default is 0. Setting it to 1 tells the Windows script wrappers to
|
||||
% use an already installed Perl interpreter if one is found on the
|
||||
% search path, in preference to the Perl shipped with TeX Live. Thus,
|
||||
% it may be useful if you both (a) installed a full Perl distribution
|
||||
% for general use, and (b) need to run Perl programs from TL that use
|
||||
% additional modules we don't provide. The TL Perl does provide all the
|
||||
% standard Perl modules.
|
||||
%
|
||||
%TEXLIVE_WINDOWS_TRY_EXTERNAL_PERL = 0
|
||||
|
||||
|
||||
% Part 3: Array and other sizes for TeX (and Metafont).
|
||||
%
|
||||
% If you want to change some of these sizes only for a certain TeX
|
||||
|
@ -644,6 +687,11 @@ param_size = 10000 % simultaneous macro parameters, also applies to MP
|
|||
save_size = 50000 % for saving values outside current group
|
||||
stack_size = 5000 % simultaneous input sources
|
||||
|
||||
% These are Omega-specific.
|
||||
ocp_buf_size = 500000 % character buffers for ocp filters.
|
||||
ocp_stack_size = 10000 % stacks for ocp computations.
|
||||
ocp_list_size = 1000 % control for multiple ocps.
|
||||
|
||||
% These work best if they are the same as the I/O buffer size, but it
|
||||
% doesn't matter much. Must be a multiple of 8.
|
||||
dvi_buf_size = 16384 % TeX
|
||||
|
|
Loading…
Reference in a new issue