mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/mgba to 0.6.3-2
This commit is contained in:
parent
bfcebb7f62
commit
531de6829c
2 changed files with 44 additions and 4 deletions
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Jonathan Steel <jsteel at archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Duck Hunt <vaporeon@tfwno.gf>
|
||||
|
@ -9,17 +8,23 @@
|
|||
pkgbase=mgba
|
||||
pkgname=('libmgba' 'mgba-sdl' 'mgba-qt')
|
||||
pkgver=0.6.3
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('x86_64')
|
||||
url='http://mgba.io'
|
||||
license=('custom:MPL2')
|
||||
makedepends=('cmake' 'qt5-multimedia' 'sdl2' 'zlib' 'libpng' 'libzip' 'libedit'
|
||||
'ffmpeg' 'libmagick' 'desktop-file-utils' 'qt5-tools')
|
||||
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz)
|
||||
md5sums=('5e46c98c6321941499c44f88b2001d9b')
|
||||
source=($pkgbase-$pkgver.tar.gz::https://github.com/mgba-emu/mgba/archive/$pkgver.tar.gz
|
||||
mgba-qt5.11.patch)
|
||||
md5sums=('5e46c98c6321941499c44f88b2001d9b'
|
||||
'36e0ba610e1ba0806324d1d6b8f315b7')
|
||||
|
||||
prepare() {
|
||||
[[ ! -d build ]] && mkdir build || rm -rf build
|
||||
|
||||
cd mgba-$pkgver
|
||||
|
||||
patch -Np1 -i ../mgba-qt5.11.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
35
community/mgba/mgba-qt5.11.patch
Normal file
35
community/mgba/mgba-qt5.11.patch
Normal file
|
@ -0,0 +1,35 @@
|
|||
From 7f41dd354176b720c8e3310553c6b772278b9dca Mon Sep 17 00:00:00 2001
|
||||
From: Vicki Pfau <vi@endrift.com>
|
||||
Date: Fri, 25 May 2018 18:04:16 -0700
|
||||
Subject: [PATCH] Qt: Fix build with Qt 5.11
|
||||
|
||||
---
|
||||
src/platform/qt/LoadSaveState.cpp | 1 +
|
||||
src/platform/qt/Window.h | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/platform/qt/LoadSaveState.cpp b/src/platform/qt/LoadSaveState.cpp
|
||||
index 538254ff6..d9db6a7d3 100644
|
||||
--- a/src/platform/qt/LoadSaveState.cpp
|
||||
+++ b/src/platform/qt/LoadSaveState.cpp
|
||||
@@ -10,6 +10,7 @@
|
||||
#include "GamepadButtonEvent.h"
|
||||
#include "VFileDevice.h"
|
||||
|
||||
+#include <QAction>
|
||||
#include <QDateTime>
|
||||
#include <QKeyEvent>
|
||||
#include <QPainter>
|
||||
diff --git a/src/platform/qt/Window.h b/src/platform/qt/Window.h
|
||||
index baca971ea..2d9d139cc 100644
|
||||
--- a/src/platform/qt/Window.h
|
||||
+++ b/src/platform/qt/Window.h
|
||||
@@ -5,6 +5,7 @@
|
||||
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
||||
#pragma once
|
||||
|
||||
+#include <QAction>
|
||||
#include <QDateTime>
|
||||
#include <QList>
|
||||
#include <QMainWindow>
|
||||
|
Loading…
Reference in a new issue