mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/gdc to 6.1.1-1
This commit is contained in:
parent
c49314e69a
commit
53996e49d9
2 changed files with 76 additions and 97 deletions
|
@ -2,82 +2,98 @@
|
|||
# Contributor: Moritz Maxeiner <moritz@ucworks.org>
|
||||
# Contributor: Jerome Berger <jeberger@free.fr>
|
||||
# Contributor: Jesus Alvarez <jeezusjr@gmail.com>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
|
||||
# ALARM: Johannes Pfau <johannespfau@gmail.com>
|
||||
# - specifid build host
|
||||
# - replaced bugurl with our GitHub issue page
|
||||
|
||||
pkgname=('gdc' 'libgphobos-devel')
|
||||
pkgver=5.3.0
|
||||
pkgrel=2
|
||||
pkgver=6.1.1
|
||||
pkgrel=1
|
||||
_pkgver=6
|
||||
_islver=0.16.1
|
||||
_commit=80f78834
|
||||
arch=('i686' 'x86_64')
|
||||
url="https://github.com/D-Programming-GDC/GDC"
|
||||
license=('GPL')
|
||||
makedepends=('binutils>=2.23' 'git' 'gcc' 'make' 'perl' 'automake')
|
||||
url="https://github.com/D-Programming-GDC/GDC"
|
||||
makedepends=('binutils>=2.26' 'git' 'gcc' 'make' 'perl' 'automake')
|
||||
options=('!emptydirs' '!buildflags')
|
||||
source=(
|
||||
"ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2"
|
||||
"gdc::git://github.com/D-Programming-GDC/GDC.git#commit=e95a735b978da70467bbb553fab40efa3ea17569"
|
||||
"git+https://github.com/D-Programming-GDC/GDMD.git"
|
||||
"folders.diff"
|
||||
"system_zlib.diff"
|
||||
)
|
||||
sha256sums=('b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
|
||||
'4c679ac426a841182215654f5555c0294449e4fde107da0e0f6c2dbb6476f0b2')
|
||||
|
||||
groups=('dlang' 'dlang-gdc')
|
||||
conflicts=('gdc1-bin' 'gdc1-hg' 'gdc-git')
|
||||
source=(
|
||||
git://gcc.gnu.org/git/gcc.git#commit=${_commit}
|
||||
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
|
||||
gdc::git://github.com/D-Programming-GDC/GDC.git#commit=73a7fb5d4e75c0e1a4ee7cdb67d080cceb8ff955
|
||||
git+https://github.com/D-Programming-GDC/GDMD.git
|
||||
folders.diff
|
||||
system_zlib.diff
|
||||
)
|
||||
sha256sums=(
|
||||
'SKIP'
|
||||
'412538bb65c799ac98e17e8cfcdacbb257a57362acfaaff254b0fcae970126d2'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'ea5c80a28026393bd4627485602660a4a01d9fbc65299e95e768013e197bad20'
|
||||
'3c818788b5435794c37e5d3d131fe74c813368a3b7260f85fb2cd725308e4889'
|
||||
)
|
||||
|
||||
prepare()
|
||||
{
|
||||
cd $srcdir/gcc-$pkgver
|
||||
# gcc-6.0 forces a changed triplet - need to address in pacman/devtools
|
||||
[[ $CARCH == "x86_64" ]] && CHOST=x86_64-pc-linux-gnu
|
||||
|
||||
echo ${pkgver} > gcc/BASE-VER
|
||||
prepare() {
|
||||
cd ${srcdir}/gcc
|
||||
|
||||
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
|
||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
||||
# link isl for in-tree build
|
||||
ln -sf ../isl-${_islver} isl
|
||||
|
||||
cd $srcdir/gdc
|
||||
git apply $srcdir/folders.diff # fix gdc_include_path
|
||||
git apply $srcdir/system_zlib.diff # use correct system zlib
|
||||
./setup-gcc.sh ../gcc-$pkgver
|
||||
# Do not run fixincludes
|
||||
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
|
||||
|
||||
mkdir $srcdir/gcc-build
|
||||
# Arch Linux installs x86_64 libraries /lib
|
||||
[[ $CARCH == "x86_64" ]] && sed -i '/m64=/s/lib64/lib/' gcc/config/i386/t-linux64
|
||||
|
||||
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
|
||||
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
|
||||
|
||||
cd $srcdir/gdc
|
||||
git apply $srcdir/folders.diff # fix gdc_include_path
|
||||
git apply $srcdir/system_zlib.diff # use correct system zlib
|
||||
./setup-gcc.sh ../gcc
|
||||
|
||||
mkdir ${srcdir}/gcc-build
|
||||
}
|
||||
|
||||
|
||||
build() {
|
||||
# ALARM: Specify build host types
|
||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi"
|
||||
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
|
||||
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a"
|
||||
cd ${srcdir}/gcc-build
|
||||
|
||||
cd ${srcdir}/gcc-build
|
||||
# ALARM: Specify build host types
|
||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=armv5tel-unknown-linux-gnueabi --build=armv5tel-unknown-linux-gnueabi"
|
||||
[[ $CARCH == "armv6h" ]] && CONFIGFLAG="--host=armv6l-unknown-linux-gnueabihf --build=armv6l-unknown-linux-gnueabihf --with-arch=armv6 --with-float=hard --with-fpu=vfp"
|
||||
[[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16"
|
||||
[[ $CARCH == "aarch64" ]] && CONFIGFLAG="--host=aarch64-unknown-linux-gnu --build=aarch64-unknown-linux-gnu --with-arch=armv8-a"
|
||||
|
||||
${srcdir}/gcc-$pkgver/configure --prefix=/usr \
|
||||
--libdir=/usr/lib --libexecdir=/usr/lib \
|
||||
--mandir=/usr/share/man --infodir=/usr/share/info \
|
||||
--with-bugurl=https://github.com/archlinuxarm/PKGBUILDs/issues \
|
||||
--enable-languages=d \
|
||||
--enable-shared --enable-threads=posix \
|
||||
--with-system-zlib --enable-__cxa_atexit \
|
||||
--disable-libunwind-exceptions --enable-clocale=gnu \
|
||||
--disable-libstdcxx-pch --disable-libssp \
|
||||
--enable-gnu-unique-object --enable-linker-build-id \
|
||||
--enable-cloog-backend=isl --disable-cloog-version-check \
|
||||
--enable-gold --enable-plugin --enable-ld=default \
|
||||
--enable-install-libiberty --with-plugin-ld=ld.gold \
|
||||
--with-linker-hash-style=gnu \
|
||||
--disable-multilib --disable-werror \
|
||||
--disable-nls --disable-bootstrap \
|
||||
--disable-libgomp --disable-libmudflap --disable-libquadmath \
|
||||
--enable-checking=release $CONFIGFLAG
|
||||
# using -pipe causes spurious test-suite failures
|
||||
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
|
||||
CFLAGS=${CFLAGS/-pipe/}
|
||||
CXXFLAGS=${CXXFLAGS/-pipe/}
|
||||
|
||||
make -j 4
|
||||
${srcdir}/gcc/configure --prefix=/usr \
|
||||
--libdir=/usr/lib --libexecdir=/usr/lib \
|
||||
--mandir=/usr/share/man --infodir=/usr/share/info \
|
||||
--with-bugurl=https://archlinuxarm.org/forum \
|
||||
--enable-languages=d \
|
||||
--enable-shared --enable-threads=posix --enable-libmpx \
|
||||
--with-system-zlib --with-isl --enable-__cxa_atexit \
|
||||
--disable-libunwind-exceptions --enable-clocale=gnu \
|
||||
--disable-libstdcxx-pch --disable-libssp \
|
||||
--enable-gnu-unique-object --enable-linker-build-id \
|
||||
--enable-lto --enable-plugin --enable-install-libiberty \
|
||||
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
|
||||
--disable-multilib --disable-werror \
|
||||
--enable-checking=release $CONFIGFLAG
|
||||
|
||||
make -j 4
|
||||
}
|
||||
|
||||
package_gdc()
|
||||
|
@ -101,7 +117,7 @@ package_libgphobos-devel()
|
|||
options=("staticlibs")
|
||||
|
||||
# druntime
|
||||
install -D $srcdir/gdc/libphobos/libdruntime/object.di $pkgdir/usr/include/dlang/gdc/object.di
|
||||
install -D $srcdir/gdc/libphobos/libdruntime/object.d $pkgdir/usr/include/dlang/gdc/object.d
|
||||
install -D $srcdir/gdc/libphobos/libdruntime/__entrypoint.di ${pkgdir}/usr/include/dlang/gdc/__entrypoint.di
|
||||
cp -r $srcdir/gdc/libphobos/libdruntime/core $pkgdir/usr/include/dlang/gdc/core
|
||||
cp -r $srcdir/gdc/libphobos/libdruntime/gcc $pkgdir/usr/include/dlang/gdc/gcc
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
diff --git a/gcc/d/d-spec.c b/gcc/d/d-spec.c
|
||||
index a43cb34..e4bb527 100644
|
||||
index d45c648..9010edb 100644
|
||||
--- a/gcc/d/d-spec.c
|
||||
+++ b/gcc/d/d-spec.c
|
||||
@@ -96,7 +96,7 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
|
||||
|
@ -11,7 +11,7 @@ index a43cb34..e4bb527 100644
|
|||
|
||||
/* The new argument list will be contained in this. */
|
||||
cl_decoded_option *new_decoded_options;
|
||||
@@ -462,6 +462,14 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
|
||||
@@ -468,6 +468,14 @@ lang_specific_driver (cl_decoded_option **in_decoded_options,
|
||||
j++;
|
||||
}
|
||||
|
||||
|
@ -26,33 +26,11 @@ index a43cb34..e4bb527 100644
|
|||
/* Add `-lgphobos' if we haven't already done so. */
|
||||
if (library > 0 && phobos)
|
||||
{
|
||||
diff --git a/libphobos/src/Makefile.am b/libphobos/src/Makefile.am
|
||||
index de99b58..d174646 100644
|
||||
--- a/libphobos/src/Makefile.am
|
||||
+++ b/libphobos/src/Makefile.am
|
||||
@@ -92,8 +92,6 @@ Z_OBJS=zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o \
|
||||
zlib/infback.o zlib/inffast.o zlib/inflate.o zlib/inftrees.o \
|
||||
zlib/trees.o zlib/uncompr.o zlib/zutil.o
|
||||
|
||||
-ZLIB_OBJS=@ZLIB_OBJS@
|
||||
-
|
||||
|
||||
# modules which require some kind of operating system
|
||||
OS_OBJS=std/file.o std/mmfile.o std/path.o std/process.o \
|
||||
@@ -113,7 +111,7 @@ WINDOWS_OBJS=std/c/windows/com.o std/c/windows/stat.o std/c/wcharh.o \
|
||||
|
||||
D_EXTRA_OBJS=@D_EXTRA_OBJS@
|
||||
|
||||
-ALL_PHOBOS_OBJS = $(D_EXTRA_OBJS) $(MAIN_OBJS) $(ZLIB_OBJS)
|
||||
+ALL_PHOBOS_OBJS = $(D_EXTRA_OBJS) $(MAIN_OBJS)
|
||||
|
||||
|
||||
libgphobos2.a : $(ALL_PHOBOS_OBJS) ../libdruntime/libgdruntime.a
|
||||
diff --git a/libphobos/src/Makefile.in b/libphobos/src/Makefile.in
|
||||
index 6d3a91f..803e4aa 100644
|
||||
index 6597116..f0f42e3 100644
|
||||
--- a/libphobos/src/Makefile.in
|
||||
+++ b/libphobos/src/Makefile.in
|
||||
@@ -150,7 +150,6 @@ SHELL = @SHELL@
|
||||
@@ -151,7 +151,6 @@ SHELL = @SHELL@
|
||||
STRIP = @STRIP@
|
||||
VERSION = @VERSION@
|
||||
WERROR = @WERROR@
|
||||
|
@ -60,7 +38,7 @@ index 6d3a91f..803e4aa 100644
|
|||
abs_builddir = @abs_builddir@
|
||||
abs_srcdir = @abs_srcdir@
|
||||
abs_top_builddir = @abs_top_builddir@
|
||||
@@ -272,7 +271,7 @@ WINDOWS_OBJS = std/c/windows/com.o std/c/windows/stat.o std/c/wcharh.o \
|
||||
@@ -283,7 +282,7 @@ WINDOWS_OBJS = std/c/windows/com.o std/c/windows/stat.o std/c/wcharh.o \
|
||||
std/windows/charset.o std/windows/iunknown.o std/windows/registry.o \
|
||||
std/windows/syserror.o std/internal/windows/advapi32.o
|
||||
|
||||
|
@ -69,18 +47,3 @@ index 6d3a91f..803e4aa 100644
|
|||
|
||||
# Work around what appears to be a GNU make bug handling MAKEFLAGS
|
||||
# values defined in terms of make variables, as is the case for CC and
|
||||
diff --git a/libphobos/src/etc/c/zlib.d b/libphobos/src/etc/c/zlib.d
|
||||
index 65b1d92..b41b63a 100644
|
||||
--- a/libphobos/src/etc/c/zlib.d
|
||||
+++ b/libphobos/src/etc/c/zlib.d
|
||||
@@ -37,8 +37,8 @@ import core.stdc.config;
|
||||
|
||||
extern (C):
|
||||
|
||||
-const char[] ZLIB_VERSION = "1.2.3";
|
||||
-const ZLIB_VERNUM = 0x1230;
|
||||
+const char[] ZLIB_VERSION = "1.2.8";
|
||||
+const ZLIB_VERNUM = 0x1280;
|
||||
|
||||
/*
|
||||
The 'zlib' compression library provides in-memory compression and
|
||||
|
|
Loading…
Reference in a new issue