mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/qt to 4.7.4-2
This commit is contained in:
parent
4bb00dd46a
commit
53a474f334
2 changed files with 96 additions and 3 deletions
|
@ -14,7 +14,7 @@ plugrel=1
|
|||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.7.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt.nokia.com/'
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -26,12 +26,14 @@ options=('!libtool' '!distcc' '!ccache')
|
|||
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
||||
source=("ftp://ftp.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop')
|
||||
'qtconfig.desktop'
|
||||
'blacklist-diginotar-certs.diff')
|
||||
md5sums=('ddf7d83f912cf1283aa066368464fa22'
|
||||
'fc211414130ab2764132e7370f8e5caa'
|
||||
'85179f5e0437514f8639957e1d8baf62'
|
||||
'f11852b97583610f3dbb669ebc3e21bc'
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd')
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
||||
'd875a2a7639de3bd63dc519c13b4d069')
|
||||
|
||||
build() {
|
||||
unset QMAKESPEC
|
||||
|
@ -44,6 +46,8 @@ build() {
|
|||
|
||||
cd $srcdir/$_pkgfqn
|
||||
|
||||
patch -p1 -i "${srcdir}"/blacklist-diginotar-certs.diff
|
||||
|
||||
sed -i "s|-O2|$CXXFLAGS|" mkspecs/common/g++.conf
|
||||
sed -i "/^QMAKE_RPATH/s| -Wl,-rpath,||g" mkspecs/common/g++.conf
|
||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= $LDFLAGS|g" mkspecs/common/g++.conf
|
||||
|
|
89
extra/qt/blacklist-diginotar-certs.diff
Normal file
89
extra/qt/blacklist-diginotar-certs.diff
Normal file
|
@ -0,0 +1,89 @@
|
|||
diff --git a/src/network/ssl/qsslcertificate.cpp b/src/network/ssl/qsslcertificate.cpp
|
||||
index 328c5c2..1ae98f4 100644
|
||||
--- a/src/network/ssl/qsslcertificate.cpp
|
||||
+++ b/src/network/ssl/qsslcertificate.cpp
|
||||
@@ -803,22 +803,47 @@ QList<QSslCertificate> QSslCertificatePrivate::certificatesFromDer(const QByteAr
|
||||
// These certificates are known to be fraudulent and were created during the comodo
|
||||
// compromise. See http://www.comodo.com/Comodo-Fraud-Incident-2011-03-23.html
|
||||
static const char *certificate_blacklist[] = {
|
||||
- "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e",
|
||||
- "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06",
|
||||
- "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3",
|
||||
- "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29",
|
||||
- "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71",
|
||||
- "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47",
|
||||
- "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43",
|
||||
- "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0",
|
||||
- "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0",
|
||||
+ "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e", "mail.google.com", // Comodo
|
||||
+ "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06", "www.google.com", // Comodo
|
||||
+ "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3", "login.yahoo.com", // Comodo
|
||||
+ "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29", "login.yahoo.com", // Comodo
|
||||
+ "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71", "login.yahoo.com", // Comodo
|
||||
+ "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47", "login.skype.com", // Comodo
|
||||
+ "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43", "addons.mozilla.org", // Comodo
|
||||
+ "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0", "login.live.com", // Comodo
|
||||
+ "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0", "global trustee", // Comodo
|
||||
+
|
||||
+ "05:e2:e6:a4:cd:09:ea:54:d6:65:b0:75:fe:22:a2:56", "*.google.com", // leaf certificate issued by DigiNotar
|
||||
+ "0c:76:da:9c:91:0c:4e:2c:9e:fe:15:d0:58:93:3c:4c", "DigiNotar Root CA", // DigiNotar root
|
||||
+ "f1:4a:13:f4:87:2b:56:dc:39:df:84:ca:7a:a1:06:49", "DigiNotar Services CA", // DigiNotar intermediate signed by DigiNotar Root
|
||||
+ "36:16:71:55:43:42:1b:9d:e6:cb:a3:64:41:df:24:38", "DigiNotar Services 1024 CA", // DigiNotar intermediate signed by DigiNotar Root
|
||||
+ "0a:82:bd:1e:14:4e:88:14:d7:5b:1a:55:27:be:bf:3e", "DigiNotar Root CA G2", // other DigiNotar Root CA
|
||||
+ "a4:b6:ce:e3:2e:d3:35:46:26:3c:b3:55:3a:a8:92:21", "CertiID Enterprise Certificate Authority", // DigiNotar intermediate signed by "DigiNotar Root CA G2"
|
||||
+ "5b:d5:60:9c:64:17:68:cf:21:0e:35:fd:fb:05:ad:41", "DigiNotar Qualified CA", // DigiNotar intermediate signed by DigiNotar Root
|
||||
+
|
||||
+ "1184640176", "DigiNotar Services 1024 CA", // DigiNotar intermediate cross-signed by Entrust
|
||||
+ "120000525", "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
|
||||
+ "120000505", "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
|
||||
+ "120000515", "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
|
||||
+ "20015536", "DigiNotar PKIoverheid CA Overheid en Bedrijven", // DigiNotar intermediate cross-signed by the Dutch government
|
||||
+ "20001983", "DigiNotar PKIoverheid CA Organisatie - G2", // DigiNotar intermediate cross-signed by the Dutch government
|
||||
+ "d6:d0:29:77:f1:49:fd:1a:83:f2:b9:ea:94:8c:5c:b4", "DigiNotar Extended Validation CA", // DigiNotar intermediate signed by DigiNotar EV Root
|
||||
+ "1e:7d:7a:53:3d:45:30:41:96:40:0f:71:48:1f:45:04", "DigiNotar Public CA 2025", // DigiNotar intermediate
|
||||
+// "(has not been seen in the wild so far)", "DigiNotar Public CA - G2", // DigiNotar intermediate
|
||||
+// "(has not been seen in the wild so far)", "Koninklijke Notariele Beroepsorganisatie CA", // compromised during DigiNotar breach
|
||||
+// "(has not been seen in the wild so far)", "Stichting TTP Infos CA," // compromised during DigiNotar breach
|
||||
+ "1184640175", "DigiNotar Root CA", // DigiNotar intermediate cross-signed by Entrust
|
||||
+ "1184644297", "DigiNotar Root CA", // DigiNotar intermediate cross-signed by Entrust
|
||||
0
|
||||
};
|
||||
|
||||
bool QSslCertificatePrivate::isBlacklisted(const QSslCertificate &certificate)
|
||||
{
|
||||
for (int a = 0; certificate_blacklist[a] != 0; a++) {
|
||||
- if (certificate.serialNumber() == certificate_blacklist[a])
|
||||
+ QString blacklistedCommonName = QString::fromUtf8(certificate_blacklist[(a+1)]);
|
||||
+ if (certificate.serialNumber() == certificate_blacklist[a++] &&
|
||||
+ (certificate.subjectInfo(QSslCertificate::CommonName) == blacklistedCommonName ||
|
||||
+ certificate.issuerInfo(QSslCertificate::CommonName) == blacklistedCommonName))
|
||||
return true;
|
||||
}
|
||||
return false;
|
||||
diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
|
||||
index 141d80a..b8e6c4c 100644
|
||||
--- a/src/network/ssl/qsslsocket_openssl.cpp
|
||||
+++ b/src/network/ssl/qsslsocket_openssl.cpp
|
||||
@@ -1193,12 +1193,16 @@ bool QSslSocketBackendPrivate::startHandshake()
|
||||
X509 *x509 = q_SSL_get_peer_certificate(ssl);
|
||||
configuration.peerCertificate = QSslCertificatePrivate::QSslCertificate_from_X509(x509);
|
||||
q_X509_free(x509);
|
||||
- if (QSslCertificatePrivate::isBlacklisted(configuration.peerCertificate)) {
|
||||
- q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
|
||||
- q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
|
||||
- emit q->error(QAbstractSocket::SslHandshakeFailedError);
|
||||
- plainSocket->disconnectFromHost();
|
||||
- return false;
|
||||
+
|
||||
+ // check the whole chain for blacklisting (including root, as we check for subjectInfo and issuer)
|
||||
+ foreach (const QSslCertificate &cert, configuration.peerCertificateChain) {
|
||||
+ if (QSslCertificatePrivate::isBlacklisted(cert)) {
|
||||
+ q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
|
||||
+ q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
|
||||
+ emit q->error(QAbstractSocket::SslHandshakeFailedError);
|
||||
+ plainSocket->disconnectFromHost();
|
||||
+ return false;
|
||||
+ }
|
||||
}
|
||||
|
||||
// Start translating errors.
|
Loading…
Reference in a new issue