mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/gdal to 1.11.0-2 (adding patch)
This commit is contained in:
parent
223eec2ab4
commit
53a6d4951e
2 changed files with 90 additions and 1 deletions
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgname=gdal
|
||||
pkgver=1.11.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="A translator library for raster geospatial data formats"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gdal.org/"
|
||||
|
@ -22,14 +22,19 @@ optdepends=('postgresql: postgresql database support'
|
|||
'swig: perl binding support')
|
||||
changelog=$pkgname.changelog
|
||||
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
|
||||
fix_json_012.patch
|
||||
gdal-1.5.1-python-install.patch)
|
||||
sha256sums=('989db33ff411e2c888348e71edec5ad06c74ed68781ebfbc4e85179b9d65aafe'
|
||||
'0ef2a20e9a0e86f85eab9a4a1e5caf7364f1d547deed6f2249fe542d4d2881f4'
|
||||
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/$pkgname-$pkgver"
|
||||
patch -Np0 -i "${srcdir}/gdal-1.5.1-python-install.patch"
|
||||
|
||||
# Fix compilation failure related to recent json-c changes. FS#40584
|
||||
patch -Np0 -i "${srcdir}/fix_json_012.patch"
|
||||
|
||||
# python2 fixes
|
||||
sed -i 's_python python1.5_python2 python python1.5_' configure
|
||||
for file in swig/python/{,osgeo/,samples/,scripts/}*.py; do
|
||||
|
|
84
community/gdal/fix_json_012.patch
Normal file
84
community/gdal/fix_json_012.patch
Normal file
|
@ -0,0 +1,84 @@
|
|||
Index: ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp (revision 27044)
|
||||
+++ ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp (revision 27267)
|
||||
@@ -1079,5 +1079,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"JSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
|
||||
json_tokener_free(jstok);
|
||||
Index: ogr/ogrsf_frmts/gme/ogrgmejson.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/gme/ogrgmejson.cpp (revision 27208)
|
||||
+++ ogr/ogrsf_frmts/gme/ogrgmejson.cpp (revision 27267)
|
||||
@@ -515,5 +515,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"JSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
|
||||
json_tokener_free(jstok);
|
||||
Index: ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp (revision 27044)
|
||||
+++ ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp (revision 27267)
|
||||
@@ -78,5 +78,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"GeoJSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
|
||||
json_tokener_free(jstok);
|
||||
@@ -1517,5 +1517,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"GeoJSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
json_tokener_free(jstok);
|
||||
return NULL;
|
||||
Index: ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp (revision 27044)
|
||||
+++ ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp (revision 27267)
|
||||
@@ -75,5 +75,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"TopoJSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
|
||||
json_tokener_free(jstok);
|
||||
Index: ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp (revision 27050)
|
||||
+++ ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp (revision 27267)
|
||||
@@ -79,5 +79,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"ESRIJSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
|
||||
json_tokener_free(jstok);
|
||||
Index: ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp
|
||||
===================================================================
|
||||
--- ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp (revision 27044)
|
||||
+++ ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp (revision 27267)
|
||||
@@ -505,5 +505,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"JSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err], jstok->char_offset);
|
||||
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
|
||||
json_tokener_free(jstok);
|
||||
CPLHTTPDestroyResult(psResult);
|
||||
Index: frmts/mbtiles/mbtilesdataset.cpp
|
||||
===================================================================
|
||||
--- frmts/mbtiles/mbtilesdataset.cpp (revision 27215)
|
||||
+++ frmts/mbtiles/mbtilesdataset.cpp (revision 27267)
|
||||
@@ -619,5 +619,5 @@
|
||||
CPLError( CE_Failure, CPLE_AppDefined,
|
||||
"JSON parsing error: %s (at offset %d)",
|
||||
- json_tokener_errors[jstok->err],
|
||||
+ json_tokener_error_desc(jstok->err),
|
||||
jstok->char_offset);
|
||||
json_tokener_free(jstok);
|
Loading…
Reference in a new issue