community/python-matplotlib to 3.5.2-1

This commit is contained in:
Kevin Mihelich 2022-05-07 18:22:46 +00:00
parent fe7afeecbd
commit 53b169f4f6
2 changed files with 40 additions and 29 deletions

View file

@ -10,8 +10,8 @@
# - disable lto via setup.cfg
pkgname=python-matplotlib
pkgver=3.5.1
pkgrel=2
pkgver=3.5.2
pkgrel=1
pkgdesc="A python plotting library, making publication quality plots"
arch=(x86_64)
url="https://matplotlib.org"
@ -38,14 +38,14 @@ checkdepends=(python-pytest python-pytest-xdist python-pytest-runner python-pyte
texlive-bin texlive-core texlive-latexextra texlive-pictures ghostscript inkscape ffmpeg imagemagick
gtk4 python-cairo python-gobject python-pyqt5 pyside2 python-pyqt6 pyside6 python-tornado python-wxpython tk
jupyter-nbconvert jupyter-nbformat python-ipykernel python-pandas python-pikepdf python-pytz)
_tag=312c1fb08c5d46aaccaf8b62c8673e4202523e8a # git rev-parse v${pkgver}
_ftver=2.11.0
_tag=af8c92817e9c1b5cb51bd060ceb99ed956e714c1 # git rev-parse v${pkgver}
_ftver=2.12.1
source=(git+https://github.com/matplotlib/matplotlib.git#tag=${_tag}?signed
https://github.com/QuLogic/mpl-images/archive/v${pkgver}-with-freetype-${_ftver}/mpl-images-${pkgver}-ft${_ftver}.tar.gz
freetype.patch)
b2sums=('SKIP'
'85e4298a7b36c6eedc6a4f7b81f803ab45536697937dccd1a039471e257a4f23f547f16e244bebb77a1d3260397a3da0a7f4ee70869a47c8f68b603f0e287d89'
'514324b3e17e832d5199eaa6592c05ca662b1164ddc95f16ea076d6a1063b06e6a8fa4eac7740e5f73afbcc9d17244c5cc41373d5787f62cd58eab10249302c9')
'b3dc00bd2e2ffb36e8d61ae570dee19a7bf54155fd91d4dc03b3f0ac439466efddc9564a27c44bb3eb9b46b7505cb4920f35c1a2c74a3ab7396a4b7bbbc6a9be'
'0f41283060ecd070e04efa51b32321f378fbcd50d2fc3105df517f55ea5b0268f2d4494dd742e463c4790fa18ecdac26e6c6ab6adcaa134cda152a523911ece1')
validpgpkeys=(23CAB59E3332F94D26BEF0378D86E7FAE5EB0C10) # Elliott Sales de Andrade <quantum.analyst@gmail.com>
prepare() {
@ -74,9 +74,10 @@ check() {
cd matplotlib
python -m venv --system-site-packages test-env
test-env/bin/python setup.py install --skip-build
# test_ipynb: https://github.com/matplotlib/matplotlib/issues/21654 fixed but jupyter does not see matplotlib?
# test_ipynb: https://github.com/matplotlib/matplotlib/issues/21654 fixed but `ModuleNotFoundError: No module named 'matplotlib'`
# test_cross_Qt_imports https://github.com/matplotlib/matplotlib/issues/23004
xvfb-run -a -s "-screen 0 640x480x24" \
test-env/bin/python -m pytest -ra -n auto -v --color=yes --pyargs matplotlib mpl_toolkits.tests -k 'not test_ipynb'
test-env/bin/python -m pytest -ra -n auto -v --color=yes --pyargs matplotlib mpl_toolkits.tests -k 'not test_ipynb and not test_cross_Qt_imports'
}
package() {

View file

@ -1,4 +1,4 @@
From 0779db3fa70c58e88e048bec9b738ae02fccaead Mon Sep 17 00:00:00 2001
From 200afb4b8503031e1aad437482b2bc61b1cede32 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Fri, 14 Feb 2020 06:05:42 -0500
@ -9,27 +9,27 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
lib/matplotlib/tests/test_constrainedlayout.py | 2 +-
lib/matplotlib/tests/test_polar.py | 2 +-
lib/matplotlib/tests/test_tightlayout.py | 10 +++++-----
setupext.py | 9 ++++++++-
7 files changed, 23 insertions(+), 13 deletions(-)
setupext.py | 9 +++++++++++++--
6 files changed, 23 insertions(+), 12 deletions(-)
diff --git a/lib/matplotlib/__init__.py b/lib/matplotlib/__init__.py
index bc800e1322..10ff904c8e 100644
--- a/lib/matplotlib/__init__.py
+++ b/lib/matplotlib/__init__.py
@@ -1198,7 +1198,7 @@ default_test_modules = [
@@ -1201,7 +1201,7 @@ default_test_modules = [
def _init_tests():
# The version of FreeType to install locally for running the
# tests. This must match the value in `setupext.py`
- LOCAL_FREETYPE_VERSION = '2.6.1'
+ LOCAL_FREETYPE_VERSION = '2.11.0'
+ LOCAL_FREETYPE_VERSION = '2.12.1'
from matplotlib import ft2font
if (ft2font.__freetype_version__ != LOCAL_FREETYPE_VERSION or
diff --git a/lib/matplotlib/tests/test_axes.py b/lib/matplotlib/tests/test_axes.py
index 2d6c1deed4..472e0e6902 100644
index eb4c34382b..03b92d34fa 100644
--- a/lib/matplotlib/tests/test_axes.py
+++ b/lib/matplotlib/tests/test_axes.py
@@ -6572,7 +6572,7 @@ def test_normal_axes():
@@ -6710,7 +6710,7 @@ def test_normal_axes():
]
for nn, b in enumerate(bbaxis):
targetbb = mtransforms.Bbox.from_bounds(*target[nn])
@ -38,7 +38,7 @@ index 2d6c1deed4..472e0e6902 100644
target = [
[150.0, 119.999, 930.0, 11.111],
@@ -6590,7 +6590,7 @@ def test_normal_axes():
@@ -6728,7 +6728,7 @@ def test_normal_axes():
target = [85.5138, 75.88888, 1021.11, 1017.11]
targetbb = mtransforms.Bbox.from_bounds(*target)
@ -48,10 +48,10 @@ index 2d6c1deed4..472e0e6902 100644
# test that get_position roundtrips to get_window_extent
axbb = ax.get_position().transformed(fig.transFigure).bounds
diff --git a/lib/matplotlib/tests/test_constrainedlayout.py b/lib/matplotlib/tests/test_constrainedlayout.py
index a8222a73d5..ea007a233f 100644
index 8fd3cc5a35..b1e0fa57cd 100644
--- a/lib/matplotlib/tests/test_constrainedlayout.py
+++ b/lib/matplotlib/tests/test_constrainedlayout.py
@@ -411,7 +411,7 @@ def test_hidden_axes():
@@ -431,7 +431,7 @@ def test_hidden_axes():
extents1 = np.copy(axs[0, 0].get_position().extents)
np.testing.assert_allclose(
@ -61,7 +61,7 @@ index a8222a73d5..ea007a233f 100644
def test_colorbar_align():
diff --git a/lib/matplotlib/tests/test_polar.py b/lib/matplotlib/tests/test_polar.py
index ea3cdfa129..d6cc018d5d 100644
index 85aece5fce..9fea856af4 100644
--- a/lib/matplotlib/tests/test_polar.py
+++ b/lib/matplotlib/tests/test_polar.py
@@ -314,7 +314,7 @@ def test_get_tightbbox_polar():
@ -74,7 +74,7 @@ index ea3cdfa129..d6cc018d5d 100644
@check_figures_equal(extensions=["png"])
diff --git a/lib/matplotlib/tests/test_tightlayout.py b/lib/matplotlib/tests/test_tightlayout.py
index 23d363b508..e94c863477 100644
index e9b01b160d..beab853489 100644
--- a/lib/matplotlib/tests/test_tightlayout.py
+++ b/lib/matplotlib/tests/test_tightlayout.py
@@ -172,12 +172,12 @@ def test_outward_ticks():
@ -96,10 +96,10 @@ index 23d363b508..e94c863477 100644
diff --git a/setupext.py b/setupext.py
index 0d85f479d1..42d6fbe2ca 100644
index 90bc304531..7ae976b8fa 100644
--- a/setupext.py
+++ b/setupext.py
@@ -167,12 +167,18 @@ _freetype_hashes = {
@@ -167,6 +167,16 @@ _freetype_hashes = {
'955e17244e9b38adb0c98df66abb50467312e6bb70eac07e49ce6bd1a20e809a',
'2.10.1':
'3a60d391fd579440561bf0e7f31af2222bc610ad6ce4d9d7bd2165bca8669110',
@ -109,17 +109,24 @@ index 0d85f479d1..42d6fbe2ca 100644
+ '5eab795ebb23ac77001cfb68b7d4d50b5d6c7469247b0b01b2c953269f658dac',
+ '2.11.0':
+ 'a45c6b403413abd5706f3582f04c8339d26397c4304b78fa552f2215df64101f',
'2.11.1':
- 'f8db94d307e9c54961b39a1cc799a67d46681480696ed72ecf78d4473770f09b'
+ 'f8db94d307e9c54961b39a1cc799a67d46681480696ed72ecf78d4473770f09b',
+ '2.12.0':
+ '7940a46eeb0255baaa87c553d72778c4f8daa2b8888c8e2a05766a2a8686740c',
+ '2.12.1':
+ 'efe71fd4b8246f1b0b1b9bfca13cfff1c9ad85930340c27df469733bbb620938'
}
# This is the version of FreeType to use when building a local version. It
@@ -174,7 +184,7 @@ _freetype_hashes = {
# must match the value in lib/matplotlib.__init__.py and also needs to be
# changed below in the embedded windows build script (grep for "REMINDER" in
# this file). Also update the cache path in `.circleci/config.yml`.
-LOCAL_FREETYPE_VERSION = '2.6.1'
+LOCAL_FREETYPE_VERSION = '2.11.0'
LOCAL_FREETYPE_HASH = _freetype_hashes.get(LOCAL_FREETYPE_VERSION, 'unknown')
# Also update the cache path in `.circleci/config.yml`.
@@ -580,6 +586,7 @@ class FreeType(SetupPackage):
-TESTING_VERSION_OF_FREETYPE = '2.6.1'
+TESTING_VERSION_OF_FREETYPE = '2.12.1'
if sys.platform.startswith('win') and platform.machine() == 'ARM64':
# older versions of freetype are not supported for win/arm64
# Matplotlib tests will not pass
@@ -590,6 +600,7 @@ class FreeType(SetupPackage):
ext.extra_objects.insert(
0, str(src_path / 'objs' / '.libs' / libfreetype))
ext.define_macros.append(('FREETYPE_BUILD_TYPE', 'local'))
@ -127,3 +134,6 @@ index 0d85f479d1..42d6fbe2ca 100644
def do_custom_build(self, env):
# We're using a system freetype
--
2.35.1