mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Merge pull request #726 from farcaller/master
Fixes to make docker 0.8 work with btrfs driver on arm
This commit is contained in:
commit
53bad644b3
2 changed files with 35 additions and 4 deletions
|
@ -6,7 +6,7 @@
|
|||
pkgname=docker
|
||||
_truever=0.8.0
|
||||
pkgver=${_truever%.*}
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
epoch=1
|
||||
pkgdesc='Pack, ship and run any application as a lightweight container'
|
||||
arch=('x86_64')
|
||||
|
@ -19,9 +19,12 @@ optdepends=('btrfs-progs: btrfs backend support')
|
|||
options=('!strip')
|
||||
install=$pkgname.install
|
||||
source=("git+https://github.com/dotcloud/docker.git#tag=v$_truever"
|
||||
'docker-arm.patch')
|
||||
'docker-arm.patch'
|
||||
'btrfs-arm.patch')
|
||||
md5sums=('SKIP'
|
||||
'47cc1cdf900af66660bfa3402012ea71')
|
||||
'47cc1cdf900af66660bfa3402012ea71'
|
||||
'1ec4b4b42eb80f2692cee757324370b0')
|
||||
|
||||
# magic harcoded path
|
||||
_magic=src/github.com/dotcloud
|
||||
|
||||
|
@ -30,6 +33,10 @@ prepare() {
|
|||
ln -sfn "../../../docker" "$_magic/docker"
|
||||
cd "${srcdir}/docker"
|
||||
patch -p1 <"${srcdir}/docker-arm.patch"
|
||||
patch -p1 <"${srcdir}/btrfs-arm.patch"
|
||||
find . -name '*.go' | xargs sed --in-place= -e 's/\/\/ +build amd64/\/\/ +build amd64,arm/'
|
||||
find . -name '*.go' | xargs sed --in-place= -e 's/\/\/ +build !linux !amd64/\/\/ +build !linux !amd64 !arm/'
|
||||
find . -name '*.go' | xargs sed --in-place= -e 's/\/\/ +build linux,amd64/\/\/ +build linux,amd64 linux,arm/'
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
24
community/docker/btrfs-arm.patch
Normal file
24
community/docker/btrfs-arm.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 23c1b0f9a91dcf3c7dc83dc0af44826cb8e96562 Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Pouzanov <farcaller@gmail.com>
|
||||
Date: Sat, 22 Feb 2014 22:25:10 +0000
|
||||
Subject: [PATCH] Golang sucks so much sometimes
|
||||
|
||||
---
|
||||
graphdriver/btrfs/btrfs.go | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/graphdriver/btrfs/btrfs.go b/graphdriver/btrfs/btrfs.go
|
||||
index 592e058..03faf85 100644
|
||||
--- a/graphdriver/btrfs/btrfs.go
|
||||
+++ b/graphdriver/btrfs/btrfs.go
|
||||
@@ -30,7 +30,7 @@ func Init(home string) (graphdriver.Driver, error) {
|
||||
return nil, err
|
||||
}
|
||||
|
||||
- if buf.Type != 0x9123683E {
|
||||
+ if buf.Type != -1859950530 {
|
||||
return nil, fmt.Errorf("%s is not a btrfs filesystem", rootdir)
|
||||
}
|
||||
|
||||
--
|
||||
1.9.0
|
Loading…
Reference in a new issue