diff --git a/community/gitea/PKGBUILD b/community/gitea/PKGBUILD
index 82faa7f3a..39b2c2896 100644
--- a/community/gitea/PKGBUILD
+++ b/community/gitea/PKGBUILD
@@ -7,7 +7,7 @@
 #  - don't check repo signature until author puts his keys on keyservers
 
 pkgname=gitea
-pkgver=1.9.5
+pkgver=1.10.0
 pkgrel=1
 pkgdesc="Painless self-hosted Git service. Community managed fork of Gogs."
 arch=(x86_64)
@@ -25,7 +25,7 @@ optdepends=(
   'sqlite: SQLite support'
 )
 backup=('etc/gitea/app.ini')
-_tag=4bc18582031a1376f29416a735cfb94fbb4688f5 # git rev-parse v${pkgver}
+_tag=7be07352eae738e152d8d1988520b3529b9919bf # git rev-parse v${pkgver}
 source=("git+https://github.com/go-gitea/gitea.git#tag=${_tag}"
         gitea.tmpfiles
         gitea.service
@@ -35,7 +35,7 @@ sha256sums=('SKIP'
             '1521fd7edc3830c695698ffe9835709f1408040b5ec989f07410972c894fa8ba'
             '7789b3f6699b9e111fa080226047cdc765e55ff49a3f72aac989c11c06c3e7e0'
             '2abc51ccd0086bb996194bb7fb241a3f26d84f518417c872b66a3db8970da7e4'
-            '5eb47d104acd2e4f8c83bfc27c77b98fcfabcab492ffb2c91675062ecd1706ad')
+            'dc1ea5c72a4f3c216c021f3fea8ac46263d820c6e4e5e088b7d50d56c0fde61f')
 validpgpkeys=(8C4033A23895237CB27D52D9D9B5613BEB813F99  # Matti Ranta <matti@mdranta.net> old RSA2048, retrieved from https://github.com/techknowlogick.gpg
               B56E3C7437A49E136862F5DE9D8A57ADAA232E95  # Matti Ranta <matti@mdranta.net> new RSA4096, retrieved from https://github.com/techknowlogick.gpg
               ED810FD31FBE67F406ED71BDD4F1E9B6493ED946  # Jonas Franz <info@jonasfranz.software>
@@ -53,9 +53,8 @@ build() {
   cd ${pkgname}
   export GOGC=50
   make generate
-  EXTRA_GOFLAGS="-trimpath" \
   LDFLAGS="-linkmode external -extldflags \"${LDFLAGS}\" -X \"code.gitea.io/gitea/modules/setting.AppWorkPath=/var/lib/gitea/\""
-  make GOFLAGS="-v" TAGS="bindata sqlite pam" build
+  make EXTRA_GOFLAGS="-trimpath" TAGS="bindata sqlite pam" build
 }
 
 package() {
diff --git a/community/gitea/gitea-arch-defaults.patch b/community/gitea/gitea-arch-defaults.patch
index 430f0da86..acbf61e3d 100644
--- a/community/gitea/gitea-arch-defaults.patch
+++ b/community/gitea/gitea-arch-defaults.patch
@@ -16,7 +16,7 @@
  SCRIPT_TYPE = bash
  ; Default ANSI charset
  ANSI_CHARSET =
-@@ -270,7 +270,7 @@ SQLITE_TIMEOUT = 500
+@@ -272,7 +272,7 @@ SQLITE_TIMEOUT = 500
  ; For iterate buffer, default is 50
  ITERATE_BUFFER_SIZE = 50
  ; Show the database generated SQL
@@ -25,8 +25,8 @@
  ; Maximum number of DB Connect retries
  DB_RETRIES = 10
  ; Backoff time per DB retry (time.Duration)
-@@ -545,10 +545,10 @@ MAX_FILES = 5
- FORMAT =
+@@ -574,10 +574,10 @@ FORMAT =
+ DEFAULT_UI_LOCATION =
 
  [log]
 -ROOT_PATH =
@@ -38,7 +38,7 @@
  ; Buffer length of the channel, keep it as it is if you don't know what it is.
  BUFFER_LEN = 10000
  REDIRECT_MACARON_LOG = false
-@@ -573,7 +573,7 @@ LEVEL = Trace
+@@ -602,7 +602,7 @@ COLORIZE = false
 
  ; For "console" mode only
  [log.console]
@@ -47,4 +47,3 @@
  STDERR = false
 
  ; For "file" mode only
- [log.file]