mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/rust to 1.70.0-1
This commit is contained in:
parent
30be37d1cd
commit
5503722466
5 changed files with 22 additions and 25 deletions
|
@ -9,10 +9,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
||||
index 9b2b549612d8..80bb25199dcb 100644
|
||||
index 76aad16c1fc2..ec516c76f95e 100644
|
||||
--- a/src/bootstrap/dist.rs
|
||||
+++ b/src/bootstrap/dist.rs
|
||||
@@ -414,7 +414,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
@@ -420,7 +420,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
},
|
||||
builder.kind,
|
||||
) {
|
||||
|
@ -21,7 +21,7 @@ index 9b2b549612d8..80bb25199dcb 100644
|
|||
}
|
||||
|
||||
let libdir_relative = builder.libdir_relative(compiler);
|
||||
@@ -1064,7 +1064,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1073,7 +1073,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
|
||||
let dirent = dirent.expect("read dir entry");
|
||||
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
|
||||
|
@ -31,10 +31,10 @@ index 9b2b549612d8..80bb25199dcb 100644
|
|||
}
|
||||
|
||||
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
|
||||
index 3c9a154da9ab..3f57819fd96d 100644
|
||||
index d1fd2e8c42cb..26e8a5b6fbc8 100644
|
||||
--- a/src/bootstrap/tool.rs
|
||||
+++ b/src/bootstrap/tool.rs
|
||||
@@ -850,7 +850,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
@@ -851,7 +851,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
|
||||
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
||||
// so that r-a can use it.
|
||||
|
|
|
@ -8,10 +8,10 @@ Subject: [PATCH] cargo: Change libexec dir
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/cargo/util/auth.rs b/src/cargo/util/auth.rs
|
||||
index f7d0fc8c4a26..d296da754218 100644
|
||||
index f19acaebe080..9edc8d72cae9 100644
|
||||
--- a/src/cargo/util/auth.rs
|
||||
+++ b/src/cargo/util/auth.rs
|
||||
@@ -816,7 +816,7 @@ fn sysroot_credential(
|
||||
@@ -826,7 +826,7 @@ fn sysroot_credential(
|
||||
.parent()
|
||||
.and_then(|p| p.parent())
|
||||
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
||||
|
|
|
@ -24,10 +24,10 @@ targets, as things break when this is done:
|
|||
4 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index d4e4ace889b0..f653be447ab1 100644
|
||||
index 79eb31bb1050..69b49beb544a 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1930,7 +1930,7 @@ pub fn parse_target_triple(
|
||||
@@ -1946,7 +1946,7 @@ pub fn parse_target_triple(
|
||||
early_error(error_format, &format!("target file {path:?} does not exist"))
|
||||
})
|
||||
}
|
||||
|
@ -50,10 +50,10 @@ index 73e536a7e4d9..af48d437533c 100644
|
|||
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
|
||||
f64:32:64-f80:32-n8:16:32-S128"
|
||||
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
|
||||
index 0d86a3032a65..b663a6d4ddb1 100644
|
||||
index 4e5a821f0f6a..1813f299d7ac 100644
|
||||
--- a/compiler/rustc_target/src/spec/mod.rs
|
||||
+++ b/compiler/rustc_target/src/spec/mod.rs
|
||||
@@ -2964,6 +2964,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
@@ -2982,6 +2982,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
|
||||
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
|
||||
}
|
||||
|
||||
|
|
|
@ -9,10 +9,10 @@ We don't ship rust-lld.
|
|||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
index 625d3b37c4f2..413c98d5c237 100644
|
||||
index 341763aadbaf..dbb075affc18 100644
|
||||
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
||||
@@ -88,8 +88,7 @@ macro_rules! args {
|
||||
@@ -89,8 +89,7 @@ macro_rules! args {
|
||||
// arguments just yet
|
||||
limit_rdylib_exports: false,
|
||||
|
||||
|
|
|
@ -20,8 +20,8 @@ pkgname=(
|
|||
rust-src
|
||||
)
|
||||
epoch=1
|
||||
pkgver=1.69.0
|
||||
pkgrel=3
|
||||
pkgver=1.70.0
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
arch=(x86_64)
|
||||
|
@ -64,12 +64,12 @@ source=(
|
|||
0002-compiler-Change-LLVM-targets.patch
|
||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
b2sums=('1440ad3e7e52d1e31752c8a44f9e626b9c2b0388f7285ddbdf1d0f7802724e707daffe19c6ba4aec62c3dba0e60ec2426ebecf69268b1e20a0c89860964a64f3'
|
||||
b2sums=('5b1fd44eaa10bf2ab76f64a3bb5c20ee4008031d05a49b0a32b3a9cb2e97d5684cf0c9a6b6883089afca6cab7a37a0a9cfa06d928ed3e6a3b6484b605e18a0f3'
|
||||
'SKIP'
|
||||
'd1a029499dd221b24124b193f7d42e9cb766d4bb9c4faa61a4b60007550693c98f1d1ab6793dd16b9f5a229bc70f805d6cd5eca6e744b34c0fd2413701bc58b6'
|
||||
'9752dc3b5fc2248c8bec4efbb3d927088d48d9416229d545a05180374549a0dda6e9d6d9a8d0a3b03437f2e3c54f9c153aab3281d46411f4c81559033b8fb04a'
|
||||
'a92b1eb9bc4101e055f89d9810c99e6e6472b3bb27bb01f8ea8a4b35f7e25512858e1555c2807eb7e8175df22c2e7937753d6787013920f9c76587e71f8df2f4'
|
||||
'9f3f911088a22101f8966dc16a1ecc65da5facaad5c169d9464e721aa452dd45968d359a5b35ae74ff23bd98d44c60cb04c0b8bc89e10fb99549c1670371c902')
|
||||
'6de8373ee24ad9a5ae12b44a1288d474c8b8a1461ba54ccadbecefc87d034b6ef763b2909e2f1452fca30488504cabacad972c6ae78b240f74e47c0e01f25136'
|
||||
'0b1c8f41144b2c9fc6528c67e6ac5ac0f4ccbbdddc3fd3ede0b83033f1745efc603c6dbc90eb64d0518832d8daf3f82e60bbcd042ff94effab1b5a499758dace'
|
||||
'972b67b9ed47b9ff0d9f5156232ed63103a9d40617325ab99be000753c420a228a89a1ca098fa978fef14dc7eb11bb222b85d63a5d2aec444b8ebfdfca07fc67'
|
||||
'445802d26028848549781b9be7430f2f1cedcd0d1f960c61dbce870a66a867aff3b0c9905b4f81b6cefefd74d83a868742ec735dd9046943068ac98117d22987')
|
||||
validpgpkeys=(
|
||||
108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
474E22316ABF4785A88C6E8EA2C794A986419D8A # Tom Stellard <tstellar@redhat.com>
|
||||
|
@ -90,8 +90,8 @@ prepare() {
|
|||
patch -Np1 -i ../0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
|
||||
cat >config.toml <<END
|
||||
changelog-seen = 2
|
||||
profile = "user"
|
||||
changelog-seen = 2
|
||||
|
||||
[llvm]
|
||||
link-shared = true
|
||||
|
@ -107,7 +107,7 @@ tools = [
|
|||
"clippy",
|
||||
"rustdoc",
|
||||
"rustfmt",
|
||||
"rust-analyzer",
|
||||
"rust-analyzer-proc-macro-srv",
|
||||
"analysis",
|
||||
"src",
|
||||
"rust-demangler",
|
||||
|
@ -211,9 +211,6 @@ build() {
|
|||
rm usr/lib/rustlib/{components,install.log,rust-installer-version,uninstall.sh}
|
||||
rm usr/lib/rustlib/manifest-*
|
||||
|
||||
# built separately
|
||||
rm usr/bin/rust-analyzer
|
||||
|
||||
# rustbuild always installs copies of the shared libraries to /usr/lib,
|
||||
# overwrite them with symlinks to the per-architecture versions
|
||||
#mkdir -p usr/lib32
|
||||
|
|
Loading…
Reference in a new issue