mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-rpi to 6.1.50-2
This commit is contained in:
parent
ef841e1c29
commit
5524109b26
4 changed files with 10 additions and 139 deletions
|
@ -1,130 +0,0 @@
|
||||||
From b52602c6b36f687afa37076dca4ae61b264e31e3 Mon Sep 17 00:00:00 2001
|
|
||||||
Date: Sat, 11 Mar 2023 06:32:06 -0500
|
|
||||||
Subject: [PATCH] blk-cgroup: Revert changes causing NULL derefs on unmount
|
|
||||||
|
|
||||||
This reverts
|
|
||||||
|
|
||||||
- commit bfe46d2efe46 (blk-cgroup: synchronize pd_free_fn() from
|
|
||||||
blkg_free_workfn() and blkcg_deactivate_policy(), 2023-01-19) and
|
|
||||||
- commit 57a425badc05 (blk-cgroup: dropping parent refcount after
|
|
||||||
pd_free_fn() is done, 2023-01-19).
|
|
||||||
|
|
||||||
For: https://bugs.archlinux.org/task/77811
|
|
||||||
---
|
|
||||||
block/blk-cgroup.c | 39 ++++++++-------------------------------
|
|
||||||
include/linux/blkdev.h | 1 -
|
|
||||||
2 files changed, 8 insertions(+), 32 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/block/blk-cgroup.c b/block/blk-cgroup.c
|
|
||||||
index f8b21be..7c91d91 100644
|
|
||||||
--- a/block/blk-cgroup.c
|
|
||||||
+++ b/block/blk-cgroup.c
|
|
||||||
@@ -87,32 +87,14 @@ static void blkg_free_workfn(struct work_struct *work)
|
|
||||||
{
|
|
||||||
struct blkcg_gq *blkg = container_of(work, struct blkcg_gq,
|
|
||||||
free_work);
|
|
||||||
- struct request_queue *q = blkg->q;
|
|
||||||
int i;
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * pd_free_fn() can also be called from blkcg_deactivate_policy(),
|
|
||||||
- * in order to make sure pd_free_fn() is called in order, the deletion
|
|
||||||
- * of the list blkg->q_node is delayed to here from blkg_destroy(), and
|
|
||||||
- * blkcg_mutex is used to synchronize blkg_free_workfn() and
|
|
||||||
- * blkcg_deactivate_policy().
|
|
||||||
- */
|
|
||||||
- if (q)
|
|
||||||
- mutex_lock(&q->blkcg_mutex);
|
|
||||||
-
|
|
||||||
for (i = 0; i < BLKCG_MAX_POLS; i++)
|
|
||||||
if (blkg->pd[i])
|
|
||||||
blkcg_policy[i]->pd_free_fn(blkg->pd[i]);
|
|
||||||
|
|
||||||
- if (blkg->parent)
|
|
||||||
- blkg_put(blkg->parent);
|
|
||||||
-
|
|
||||||
- if (q) {
|
|
||||||
- list_del_init(&blkg->q_node);
|
|
||||||
- mutex_unlock(&q->blkcg_mutex);
|
|
||||||
- blk_put_queue(q);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
+ if (blkg->q)
|
|
||||||
+ blk_put_queue(blkg->q);
|
|
||||||
free_percpu(blkg->iostat_cpu);
|
|
||||||
percpu_ref_exit(&blkg->refcnt);
|
|
||||||
kfree(blkg);
|
|
||||||
@@ -145,6 +127,8 @@ static void __blkg_release(struct rcu_head *rcu)
|
|
||||||
|
|
||||||
/* release the blkcg and parent blkg refs this blkg has been holding */
|
|
||||||
css_put(&blkg->blkcg->css);
|
|
||||||
+ if (blkg->parent)
|
|
||||||
+ blkg_put(blkg->parent);
|
|
||||||
blkg_free(blkg);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -441,14 +425,9 @@ static void blkg_destroy(struct blkcg_gq *blkg)
|
|
||||||
lockdep_assert_held(&blkg->q->queue_lock);
|
|
||||||
lockdep_assert_held(&blkcg->lock);
|
|
||||||
|
|
||||||
- /*
|
|
||||||
- * blkg stays on the queue list until blkg_free_workfn(), see details in
|
|
||||||
- * blkg_free_workfn(), hence this function can be called from
|
|
||||||
- * blkcg_destroy_blkgs() first and again from blkg_destroy_all() before
|
|
||||||
- * blkg_free_workfn().
|
|
||||||
- */
|
|
||||||
- if (hlist_unhashed(&blkg->blkcg_node))
|
|
||||||
- return;
|
|
||||||
+ /* Something wrong if we are trying to remove same group twice */
|
|
||||||
+ WARN_ON_ONCE(list_empty(&blkg->q_node));
|
|
||||||
+ WARN_ON_ONCE(hlist_unhashed(&blkg->blkcg_node));
|
|
||||||
|
|
||||||
for (i = 0; i < BLKCG_MAX_POLS; i++) {
|
|
||||||
struct blkcg_policy *pol = blkcg_policy[i];
|
|
||||||
@@ -460,6 +439,7 @@ static void blkg_destroy(struct blkcg_gq *blkg)
|
|
||||||
blkg->online = false;
|
|
||||||
|
|
||||||
radix_tree_delete(&blkcg->blkg_tree, blkg->q->id);
|
|
||||||
+ list_del_init(&blkg->q_node);
|
|
||||||
hlist_del_init_rcu(&blkg->blkcg_node);
|
|
||||||
|
|
||||||
/*
|
|
||||||
@@ -1246,7 +1226,6 @@ int blkcg_init_disk(struct gendisk *disk)
|
|
||||||
int ret;
|
|
||||||
|
|
||||||
INIT_LIST_HEAD(&q->blkg_list);
|
|
||||||
- mutex_init(&q->blkcg_mutex);
|
|
||||||
|
|
||||||
new_blkg = blkg_alloc(&blkcg_root, disk, GFP_KERNEL);
|
|
||||||
if (!new_blkg)
|
|
||||||
@@ -1484,7 +1463,6 @@ void blkcg_deactivate_policy(struct request_queue *q,
|
|
||||||
if (queue_is_mq(q))
|
|
||||||
blk_mq_freeze_queue(q);
|
|
||||||
|
|
||||||
- mutex_lock(&q->blkcg_mutex);
|
|
||||||
spin_lock_irq(&q->queue_lock);
|
|
||||||
|
|
||||||
__clear_bit(pol->plid, q->blkcg_pols);
|
|
||||||
@@ -1503,7 +1481,6 @@ void blkcg_deactivate_policy(struct request_queue *q,
|
|
||||||
}
|
|
||||||
|
|
||||||
spin_unlock_irq(&q->queue_lock);
|
|
||||||
- mutex_unlock(&q->blkcg_mutex);
|
|
||||||
|
|
||||||
if (queue_is_mq(q))
|
|
||||||
blk_mq_unfreeze_queue(q);
|
|
||||||
diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h
|
|
||||||
index 1680b6e..891f8cb 100644
|
|
||||||
--- a/include/linux/blkdev.h
|
|
||||||
+++ b/include/linux/blkdev.h
|
|
||||||
@@ -487,7 +487,6 @@ struct request_queue {
|
|
||||||
DECLARE_BITMAP (blkcg_pols, BLKCG_MAX_POLS);
|
|
||||||
struct blkcg_gq *root_blkg;
|
|
||||||
struct list_head blkg_list;
|
|
||||||
- struct mutex blkcg_mutex;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
struct queue_limits limits;
|
|
||||||
--
|
|
||||||
2.39.2
|
|
||||||
|
|
|
@ -5,12 +5,12 @@
|
||||||
# Contributer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
# Contributer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
|
||||||
|
|
||||||
pkgbase=linux-rpi
|
pkgbase=linux-rpi
|
||||||
_commit=9b79cb06ad370cfd5fc52f7d85d82bdcff701828
|
_commit=65742d7116e89b08858fcd7d67bd521ee19ee837
|
||||||
_srcname=linux-${_commit}
|
_srcname=linux-${_commit}
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_regen=
|
_regen=1
|
||||||
pkgver=6.1.50
|
pkgver=6.1.50
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc='Linux'
|
pkgdesc='Linux'
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
arch=(armv7h aarch64)
|
arch=(armv7h aarch64)
|
||||||
|
@ -31,16 +31,16 @@ source=("linux-$pkgver-${_commit:0:10}.tar.gz::https://github.com/raspberrypi/li
|
||||||
90-linux.hook
|
90-linux.hook
|
||||||
archarm.diffconfig
|
archarm.diffconfig
|
||||||
)
|
)
|
||||||
md5sums=('c846d03ad0d97103524253c654afa93b'
|
md5sums=('33e0cf5441309ea91bee28697d4e523f'
|
||||||
'3bab7426d8c8818dda8353da3892a41f'
|
'3bab7426d8c8818dda8353da3892a41f'
|
||||||
'f66a7ea3feb708d398ef57e4da4815e9'
|
'f66a7ea3feb708d398ef57e4da4815e9'
|
||||||
'86d4a35722b5410e3b29fc92dae15d4b'
|
'86d4a35722b5410e3b29fc92dae15d4b'
|
||||||
'0a5f16bfec6ad982a2f6782724cca8ba'
|
'0a5f16bfec6ad982a2f6782724cca8ba'
|
||||||
'441ec084c47cddc53e592fb0cbce4edf'
|
'441ec084c47cddc53e592fb0cbce4edf'
|
||||||
'c8f84694321e249492c80149833671d7')
|
'c8f84694321e249492c80149833671d7')
|
||||||
md5sums_armv7h=('b7517575796de6d5d19003560b965b29'
|
md5sums_armv7h=('5d2c77b812e3e6d2094537458aa1461b'
|
||||||
'a99311daa39248cfc9b6541a0a0a5f09')
|
'a99311daa39248cfc9b6541a0a0a5f09')
|
||||||
md5sums_aarch64=('94f6a57768c36a88d8740c61bc44e698'
|
md5sums_aarch64=('e9d6af7b15b798c32e01381146936556'
|
||||||
'7e4403dea857e40005bf76beda9927ff')
|
'7e4403dea857e40005bf76beda9927ff')
|
||||||
|
|
||||||
# setup vars
|
# setup vars
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Automatically generated file; DO NOT EDIT.
|
# Automatically generated file; DO NOT EDIT.
|
||||||
# Linux/arm 6.1.37 Kernel Configuration
|
# Linux/arm 6.1.50 Kernel Configuration
|
||||||
#
|
#
|
||||||
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
|
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
|
||||||
CONFIG_CC_IS_GCC=y
|
CONFIG_CC_IS_GCC=y
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
#
|
#
|
||||||
# Automatically generated file; DO NOT EDIT.
|
# Automatically generated file; DO NOT EDIT.
|
||||||
# Linux/arm64 6.1.38 Kernel Configuration
|
# Linux/arm64 6.1.50 Kernel Configuration
|
||||||
#
|
#
|
||||||
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
|
CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
|
||||||
CONFIG_CC_IS_GCC=y
|
CONFIG_CC_IS_GCC=y
|
||||||
|
@ -341,6 +341,7 @@ CONFIG_ARCH_BCM2835=y
|
||||||
#
|
#
|
||||||
# ARM errata workarounds via the alternatives framework
|
# ARM errata workarounds via the alternatives framework
|
||||||
#
|
#
|
||||||
|
CONFIG_AMPERE_ERRATUM_AC03_CPU_38=y
|
||||||
CONFIG_ARM64_WORKAROUND_CLEAN_CACHE=y
|
CONFIG_ARM64_WORKAROUND_CLEAN_CACHE=y
|
||||||
CONFIG_ARM64_ERRATUM_826319=y
|
CONFIG_ARM64_ERRATUM_826319=y
|
||||||
CONFIG_ARM64_ERRATUM_827319=y
|
CONFIG_ARM64_ERRATUM_827319=y
|
||||||
|
@ -5398,7 +5399,7 @@ CONFIG_TINYDRM_HX8357D=m
|
||||||
# CONFIG_TINYDRM_ILI9163 is not set
|
# CONFIG_TINYDRM_ILI9163 is not set
|
||||||
CONFIG_TINYDRM_ILI9225=m
|
CONFIG_TINYDRM_ILI9225=m
|
||||||
CONFIG_TINYDRM_ILI9341=m
|
CONFIG_TINYDRM_ILI9341=m
|
||||||
# CONFIG_TINYDRM_ILI9486 is not set
|
CONFIG_TINYDRM_ILI9486=m
|
||||||
CONFIG_TINYDRM_MI0283QT=m
|
CONFIG_TINYDRM_MI0283QT=m
|
||||||
CONFIG_TINYDRM_REPAPER=m
|
CONFIG_TINYDRM_REPAPER=m
|
||||||
CONFIG_TINYDRM_ST7586=m
|
CONFIG_TINYDRM_ST7586=m
|
||||||
|
|
Loading…
Reference in a new issue