diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index 5cbf88c43..0e467295f 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -20,7 +20,7 @@ pkgname=(
   'gpio-utils'
   'iio-utils'
 )
-pkgver=4.16
+pkgver=4.18
 pkgrel=1
 license=('GPL2')
 arch=('x86_64')
@@ -45,7 +45,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz"
         'cpupower.systemd'
         'cpupower.service'
         'usbipd.service')
-md5sums=('1357fb4ee7c288fdeac5d4e0048f5c18'
+md5sums=('bee5fe53ee1c3142b8f0c12c0d3348f9'
          '56883c159381ba89e50ab8ea65efec77'
          '34f5ecc19770a1abbcd0fd65bfd1f065'
          '86c4e419e4ba80835c330d49ba3f56ad'
@@ -54,10 +54,6 @@ md5sums=('1357fb4ee7c288fdeac5d4e0048f5c18'
 prepare() {
   cd linux-$pkgver
 
-  # Fix "unwind-libunwind.c:109:11: error: ‘EINVAL’ undeclared" on i686
-  # Not sure why this wasn't an issue until now...
-  sed -i '1i #include <errno.h>' tools/perf/arch/x86/util/unwind-libunwind.c
-
   # apply patch from the source array (should be a pacman feature)
   local filename
   for filename in "${source[@]}"; do