mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/linux-odroid to 3.8.13.30-1
This commit is contained in:
parent
83ceeb060e
commit
554cd5afec
7 changed files with 140 additions and 12 deletions
|
@ -16,23 +16,23 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'git' 'inetutils' 'bc')
|
||||||
options=('!strip')
|
options=('!strip')
|
||||||
_commit=1130f8761789bfe79de0db2b7f5013ff3eb1f978
|
_commit=1130f8761789bfe79de0db2b7f5013ff3eb1f978
|
||||||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||||
'0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch'
|
|
||||||
'add-gcc5-support.patch'
|
'add-gcc5-support.patch'
|
||||||
'rtl8192cu_rtl8812au_rtl8712_fix.patch'
|
'gcc5-use-std89.patch'
|
||||||
'config_x'
|
'config_x'
|
||||||
'config_x2'
|
'config_x2'
|
||||||
'config_u2')
|
'config_u2')
|
||||||
md5sums=('d26d94527d4f8a4b5592f8983968e933'
|
md5sums=('9eec4534016d3bd8dc6fb372ec7ab574'
|
||||||
'57f724207784f97c76e2f1915ffccbef'
|
'2873a50f4311434fd07d7d52bccaade7'
|
||||||
'418189dad3c5da3718b70e63f80cf7f7'
|
'407619b134dd00b453ebba9f23dcabf5'
|
||||||
'686747466e2615ac796af3314018926a')
|
'127765de828e8c58382bc9ee56d26b38'
|
||||||
|
'4bb9df433c1f1d674d8e60aefafeb4d2'
|
||||||
|
'7d39581d46fa59366a7253b581b40148')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "${srcdir}/linux-${_commit}"
|
cd "${srcdir}/linux-${_commit}"
|
||||||
|
|
||||||
patch -Np1 -i ${srcdir}/0001-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
|
|
||||||
patch -Np1 -i ${srcdir}/add-gcc5-support.patch
|
patch -Np1 -i ${srcdir}/add-gcc5-support.patch
|
||||||
patch -Np1 -i ${srcdir}/rtl8192cu_rtl8812au_rtl8712_fix.patch
|
patch -Np1 -i ${srcdir}/gcc5-use-std89.patch
|
||||||
|
|
||||||
# add pkgrel to extraversion
|
# add pkgrel to extraversion
|
||||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||||
|
|
92
core/linux-odroid/add-gcc5-support.patch
Normal file
92
core/linux-odroid/add-gcc5-support.patch
Normal file
|
@ -0,0 +1,92 @@
|
||||||
|
commit 71458cfc782eafe4b27656e078d379a34e472adf upstream.
|
||||||
|
|
||||||
|
We're missing include/linux/compiler-gcc5.h which is required now
|
||||||
|
because gcc branched off to v5 in trunk.
|
||||||
|
|
||||||
|
Just copy the relevant bits out of include/linux/compiler-gcc4.h,
|
||||||
|
no new code is added as of now.
|
||||||
|
|
||||||
|
This fixes a build error when using gcc 5.
|
||||||
|
|
||||||
|
Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
|
||||||
|
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
|
||||||
|
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||||
|
Signed-off-by: Zefan Li <lizefan@huawei.com>
|
||||||
|
---
|
||||||
|
include/linux/compiler-gcc5.h | 66 +++++++++++++++++++++++++++++++++++++++++++
|
||||||
|
1 file changed, 66 insertions(+)
|
||||||
|
create mode 100644 include/linux/compiler-gcc5.h
|
||||||
|
diff --git a/include/linux/compiler-gcc5.h b/include/linux/compiler-gcc5.h
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..cdd1cc2
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/include/linux/compiler-gcc5.h
|
||||||
|
@@ -0,0 +1,66 @@
|
||||||
|
+#ifndef __LINUX_COMPILER_H
|
||||||
|
+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
+#define __used __attribute__((__used__))
|
||||||
|
+#define __must_check __attribute__((warn_unused_result))
|
||||||
|
+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||||
|
+
|
||||||
|
+/* Mark functions as cold. gcc will assume any path leading to a call
|
||||||
|
+ to them will be unlikely. This means a lot of manual unlikely()s
|
||||||
|
+ are unnecessary now for any paths leading to the usual suspects
|
||||||
|
+ like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||||
|
+ older compilers]
|
||||||
|
+
|
||||||
|
+ Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||||
|
+ in the preprocessor, but we can live with this because they're unreleased.
|
||||||
|
+ Maketime probing would be overkill here.
|
||||||
|
+
|
||||||
|
+ gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||||
|
+ a special section, but I don't see any sense in this right now in
|
||||||
|
+ the kernel context */
|
||||||
|
+#define __cold __attribute__((__cold__))
|
||||||
|
+
|
||||||
|
+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||||
|
+
|
||||||
|
+#ifndef __CHECKER__
|
||||||
|
+# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||||
|
+# define __compiletime_error(message) __attribute__((error(message)))
|
||||||
|
+#endif /* __CHECKER__ */
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * Mark a position in code as unreachable. This can be used to
|
||||||
|
+ * suppress control flow warnings after asm blocks that transfer
|
||||||
|
+ * control elsewhere.
|
||||||
|
+ *
|
||||||
|
+ * Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||||
|
+ * this in the preprocessor, but we can live with this because they're
|
||||||
|
+ * unreleased. Really, we need to have autoconf for the kernel.
|
||||||
|
+ */
|
||||||
|
+#define unreachable() __builtin_unreachable()
|
||||||
|
+
|
||||||
|
+/* Mark a function definition as prohibited from being cloned. */
|
||||||
|
+#define __noclone __attribute__((__noclone__))
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * Tell the optimizer that something else uses this function or variable.
|
||||||
|
+ */
|
||||||
|
+#define __visible __attribute__((externally_visible))
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * GCC 'asm goto' miscompiles certain code sequences:
|
||||||
|
+ *
|
||||||
|
+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||||
|
+ *
|
||||||
|
+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||||
|
+ * Fixed in GCC 4.8.2 and later versions.
|
||||||
|
+ *
|
||||||
|
+ * (asm goto is automatically volatile - the naming reflects this.)
|
||||||
|
+ */
|
||||||
|
+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||||
|
+
|
||||||
|
+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||||
|
+#define __HAVE_BUILTIN_BSWAP32__
|
||||||
|
+#define __HAVE_BUILTIN_BSWAP64__
|
||||||
|
+#define __HAVE_BUILTIN_BSWAP16__
|
||||||
|
+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||||
|
--
|
||||||
|
1.9.1
|
|
@ -2710,7 +2710,7 @@ CONFIG_MALI400=y
|
||||||
# CONFIG_MALI400_DEBUG is not set
|
# CONFIG_MALI400_DEBUG is not set
|
||||||
# CONFIG_MALI400_PROFILING is not set
|
# CONFIG_MALI400_PROFILING is not set
|
||||||
# CONFIG_MALI400_UMP is not set
|
# CONFIG_MALI400_UMP is not set
|
||||||
CONFIG_MALI_DVFS=y
|
# CONFIG_MALI_DVFS is not set
|
||||||
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
||||||
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
||||||
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
||||||
|
|
|
@ -2618,7 +2618,7 @@ CONFIG_MALI400=y
|
||||||
# CONFIG_MALI400_DEBUG is not set
|
# CONFIG_MALI400_DEBUG is not set
|
||||||
# CONFIG_MALI400_PROFILING is not set
|
# CONFIG_MALI400_PROFILING is not set
|
||||||
# CONFIG_MALI400_UMP is not set
|
# CONFIG_MALI400_UMP is not set
|
||||||
CONFIG_MALI_DVFS=y
|
# CONFIG_MALI_DVFS is not set
|
||||||
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
||||||
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
||||||
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
||||||
|
|
|
@ -2618,7 +2618,7 @@ CONFIG_MALI400=y
|
||||||
# CONFIG_MALI400_DEBUG is not set
|
# CONFIG_MALI400_DEBUG is not set
|
||||||
# CONFIG_MALI400_PROFILING is not set
|
# CONFIG_MALI400_PROFILING is not set
|
||||||
# CONFIG_MALI400_UMP is not set
|
# CONFIG_MALI400_UMP is not set
|
||||||
CONFIG_MALI_DVFS=y
|
# CONFIG_MALI_DVFS is not set
|
||||||
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
CONFIG_MALI_DMA_BUF_MAP_ON_ATTACH=y
|
||||||
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
# CONFIG_MALI_SHARED_INTERRUPTS is not set
|
||||||
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
# CONFIG_MALI_PMU_PARALLEL_POWER_UP is not set
|
||||||
|
|
36
core/linux-odroid/gcc5-use-std89.patch
Normal file
36
core/linux-odroid/gcc5-use-std89.patch
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
|
||||||
|
Signed-off-by: Sasha Levin <sasha.levin at oracle.com>
|
||||||
|
Singed-off-by: Kirill A. Shutemov <kirill.shutemov at linux.intel.com>
|
||||||
|
Signed-off-by: Linus Torvalds <torvalds at linux-foundation.org>
|
||||||
|
[ kamal: backport to 3.13-stable: context ]
|
||||||
|
Signed-off-by: Kamal Mostafa <kamal at canonical.com>
|
||||||
|
---
|
||||||
|
Makefile | 6 ++++--
|
||||||
|
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 1b0c93c..6f16559 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -244,7 +244,7 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
|
||||||
|
|
||||||
|
HOSTCC = gcc
|
||||||
|
HOSTCXX = g++
|
||||||
|
-HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||||
|
+HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu89
|
||||||
|
HOSTCXXFLAGS = -O2
|
||||||
|
|
||||||
|
# Decide whether to build built-in, modular, or both.
|
||||||
|
@@ -376,7 +376,9 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
|
||||||
|
-fno-strict-aliasing -fno-common \
|
||||||
|
-Werror-implicit-function-declaration \
|
||||||
|
-Wno-format-security \
|
||||||
|
- -fno-delete-null-pointer-checks
|
||||||
|
+ -fno-delete-null-pointer-checks \
|
||||||
|
+ -std=gnu89
|
||||||
|
+
|
||||||
|
KBUILD_AFLAGS_KERNEL :=
|
||||||
|
KBUILD_CFLAGS_KERNEL :=
|
||||||
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||||
|
--
|
||||||
|
1.9.1
|
|
@ -1,7 +1,7 @@
|
||||||
# arg 1: the new package version
|
# arg 1: the new package version
|
||||||
# arg 2: the old package versio
|
# arg 2: the old package versio
|
||||||
|
|
||||||
KERNEL_VERSION=3.8.13-1-ARCH
|
KERNEL_VERSION=3.8.13.30-1-ARCH
|
||||||
|
|
||||||
post_install () {
|
post_install () {
|
||||||
# updating module dependencies
|
# updating module dependencies
|
||||||
|
|
Loading…
Reference in a new issue