mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/meson to 0.49.2-1
This commit is contained in:
parent
6cf4dccafb
commit
554fcd406a
3 changed files with 42 additions and 21 deletions
26
extra/meson/4878.patch
Normal file
26
extra/meson/4878.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From c5544aea8d8480262b9792ac85b8e61d1fb08f74 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Corentin=20No=C3=ABl?= <corentin.noel@collabora.com>
|
||||
Date: Mon, 4 Feb 2019 13:49:01 +0100
|
||||
Subject: [PATCH] vala: Support position-independent executables
|
||||
|
||||
---
|
||||
mesonbuild/compilers/vala.py | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/mesonbuild/compilers/vala.py b/mesonbuild/compilers/vala.py
|
||||
index e64d57f366..5303298a62 100644
|
||||
--- a/mesonbuild/compilers/vala.py
|
||||
+++ b/mesonbuild/compilers/vala.py
|
||||
@@ -49,6 +49,12 @@ def get_compile_only_args(self):
|
||||
def get_pic_args(self):
|
||||
return []
|
||||
|
||||
+ def get_pie_args(self):
|
||||
+ return []
|
||||
+
|
||||
+ def get_pie_link_args(self):
|
||||
+ return []
|
||||
+
|
||||
def get_always_args(self):
|
||||
return ['-C']
|
||||
|
|
@ -7,7 +7,7 @@
|
|||
# - remove checkdepend on dmd
|
||||
|
||||
pkgname=meson
|
||||
pkgver=0.49.1
|
||||
pkgver=0.49.2
|
||||
pkgrel=1
|
||||
pkgdesc='High productivity build system'
|
||||
url='http://mesonbuild.com/'
|
||||
|
@ -20,15 +20,20 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt4' 'qt5-b
|
|||
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
|
||||
'libwmf' 'valgrind')
|
||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
||||
4878.patch
|
||||
arch-meson)
|
||||
sha512sums=('2a9a3d1e1eae3f9f21f47c0efb2ecd78861a71109fa5a660bf6403df2d5bd5c31fa2ef848080ca72d25257836b9e00e2fb89d5fc281647600ece0179c703cfe8'
|
||||
sha512sums=('d07a5dfd699f1e4b00af39c377ec186c91718d9595cb0ab506b4b40c0c63ddd14eccbe8afb446635272c431e2a78032888be0bc8f6064044da53e8c0b5f7be3f'
|
||||
'SKIP'
|
||||
'7d563d5c99a2a7144270c2f10f5b8ed571cae12f84d7f3dbd33d0b199eb21043eb03457e3d318f2e8fde1cfc69d7f8b90aaaf2af2276a1688b1395893a22a1ec')
|
||||
'ff1326c7b56da98eab615b40e07cba86d6ceee18d29e8b5c57ccf73980a7a466c8e5695cc0b96a36330cd0d51e52b8fed08456ebea6763edb736ae7116be2f4b'
|
||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
|
||||
# https://github.com/mesonbuild/meson/issues/4884
|
||||
patch -Np1 -i ../4878.patch
|
||||
|
||||
# Succeeds for us?
|
||||
mv 'test cases/failing/85 gtest dependency with version' 'test cases/frameworks/'
|
||||
}
|
||||
|
|
|
@ -3,21 +3,11 @@
|
|||
|
||||
exec meson setup \
|
||||
--prefix /usr \
|
||||
--libdir /usr/lib \
|
||||
--libexecdir /usr/lib \
|
||||
--bindir /usr/bin \
|
||||
--sbindir /usr/bin \
|
||||
--includedir /usr/include \
|
||||
--datadir /usr/share \
|
||||
--mandir /usr/share/man \
|
||||
--infodir /usr/share/info \
|
||||
--localedir /usr/share/locale \
|
||||
--sysconfdir /etc \
|
||||
--localstatedir /var \
|
||||
--sharedstatedir /var/lib \
|
||||
--buildtype release \
|
||||
--libexecdir lib \
|
||||
--sbindir bin \
|
||||
--buildtype plain \
|
||||
--auto-features enabled \
|
||||
--wrap-mode nofallback \
|
||||
--wrap-mode nodownload \
|
||||
-D b_lto=false \
|
||||
-D b_pie=true \
|
||||
"$@"
|
||||
|
|
Loading…
Reference in a new issue