extra/meson to 0.59.3-1

This commit is contained in:
David Beauchamp 2021-10-23 15:02:34 -04:00
parent 1c800ad965
commit 5577a99a37
2 changed files with 2 additions and 29 deletions

View file

@ -1,22 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Dominique Leuenberger <dimstar@opensuse.org>
Date: Wed, 29 Sep 2021 14:20:53 +0200
Subject: [PATCH] tests/rust: add libm to fix build with rust 1.55
Fixes #9309
---
test cases/rust/5 polyglot static/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/test cases/rust/5 polyglot static/meson.build b/test cases/rust/5 polyglot static/meson.build
index de2e61bcb..a6e9550b6 100644
--- a/test cases/rust/5 polyglot static/meson.build
+++ b/test cases/rust/5 polyglot static/meson.build
@@ -2,6 +2,7 @@ project('static rust and c polyglot executable', 'c', 'rust')
deps = [
meson.get_compiler('c').find_library('dl', required: false),
+ meson.get_compiler('c').find_library('m', required: false),
dependency('threads'),
]

View file

@ -6,7 +6,7 @@
# - disable lto in arch-meson
pkgname=meson
pkgver=0.59.2
pkgver=0.59.3
pkgrel=1
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
@ -20,12 +20,10 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
'python-pytest-xdist' 'python2-setuptools' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver/rc/.rc}/meson-${pkgver}.tar.gz{,.asc}
0001-tests-rust-add-libm-to-fix-build-with-rust-1.55.patch
skip-test.diff
arch-meson)
sha512sums=('910e4a8c9828506b576dc8ae0b5765efec24f44a34a5694f782c8a533d75053b10b4167564c06456d05f7a32c5fd9bd657faa62329e1e4ed24bfc4c9ac1ef73e'
sha512sums=('4ffca094474c09567a69f576b25588c38e18d3a96d0b1d592adb05493a5d6dcfcd1a6549a821862a5aabd3df34d81b3a90d01e012e62c7f46bd98152337c0ea6'
'SKIP'
'c366e149fa04ce41d572fa42a1116d3ddfb25e3e6192c918127d96f2f1e50214c503ce8864473fc7712f0452b63336ac92b4e94fe8ac7f0a9ae6933e07463abc'
'c00c3bbb6f6dfe41bb6e05e3eba94fb177f3ef9353bc132e33e54eabacc14d81ed7bff5fe965fb4d49ce8a586a7ebb887b625174f272a48b2f3c85d3288e23b1'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
@ -33,9 +31,6 @@ validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpak
prepare() {
cd ${pkgname}-${pkgver}
# Fix tests with Rust 1.55
patch -Np1 -i ../0001-tests-rust-add-libm-to-fix-build-with-rust-1.55.patch
# Our containers do not allow sanitizers to run
patch -Np1 -i ../skip-test.diff
}