mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-espressobin to 4.13.2-1
This commit is contained in:
parent
6301dc2e88
commit
55803aab41
14 changed files with 65 additions and 101 deletions
|
@ -1,7 +1,7 @@
|
|||
From 51039c207512ec118aeec2e18a22f8dafac5c66e Mon Sep 17 00:00:00 2001
|
||||
From 8cb51b7b1fce249f4a064e75f1fb8681906657fc Mon Sep 17 00:00:00 2001
|
||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||
Date: Sat, 1 Jul 2017 15:16:35 +0100
|
||||
Subject: [PATCH 02/13] ARM64: dts: marvell: armada37xx: Enable memory-mapped
|
||||
Subject: [PATCH 01/12] ARM64: dts: marvell: armada37xx: Enable memory-mapped
|
||||
GIC CPU interface
|
||||
|
||||
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
|
||||
|
@ -18,7 +18,7 @@ Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
|
|||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
index 506aee2e796b..2dfc09501f9f 100644
|
||||
index a92ac63addf0..b6f1e7a5e5ec 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
@@ -322,7 +322,10 @@
|
|
@ -1,33 +0,0 @@
|
|||
From 31a3b2d526aded19e5b8e577b95eed1ef534edd8 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||
Date: Sat, 1 Jul 2017 15:16:34 +0100
|
||||
Subject: [PATCH 01/13] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
|
||||
interrupt
|
||||
|
||||
The GIC-500 integrated in the Armada-37xx SoCs is compliant with
|
||||
the GICv3 architecture, and thus provides a maintenance interrupt
|
||||
that is required for hypervisors to function correctly.
|
||||
|
||||
With the interrupt provided in the DT, KVM now works as it should.
|
||||
Tested on an Espressobin system.
|
||||
|
||||
Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
|
||||
---
|
||||
arch/arm64/boot/dts/marvell/armada-37xx.dtsi | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
index dbcc3d4e2ed5..506aee2e796b 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
@@ -323,6 +323,7 @@
|
||||
interrupt-controller;
|
||||
reg = <0x1d00000 0x10000>, /* GICD */
|
||||
<0x1d40000 0x40000>; /* GICR */
|
||||
+ interrupts = <GIC_PPI 9 IRQ_TYPE_LEVEL_HIGH>;
|
||||
};
|
||||
};
|
||||
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 74c6836db73c9361c34dcc9dfd363f5b447d1b30 Mon Sep 17 00:00:00 2001
|
||||
From 291969f6c3444515961a1d3f6f99c9323f599b04 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||
Date: Sat, 1 Jul 2017 15:16:36 +0100
|
||||
Subject: [PATCH 03/13] ARM64: dts: marvell: armada37xx: Wire PMUv3
|
||||
Subject: [PATCH 02/12] ARM64: dts: marvell: armada37xx: Wire PMUv3
|
||||
|
||||
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
|
||||
a PMUv3, just like most ARMv8 cores.
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
|
|||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
index 2dfc09501f9f..d6a060d9f083 100644
|
||||
index b6f1e7a5e5ec..35307cd93db5 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
@@ -81,6 +81,11 @@
|
|
@ -1,7 +1,7 @@
|
|||
From bc0a98af7bd04356528338d287a734622d6ce7d1 Mon Sep 17 00:00:00 2001
|
||||
From 5b5e370b5903e65a3b8230c9182db13a5bd331fa Mon Sep 17 00:00:00 2001
|
||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||
Date: Sat, 1 Jul 2017 15:16:37 +0100
|
||||
Subject: [PATCH 04/13] ARM64: dts: marvell: armada37xx: Enable USB2 on
|
||||
Subject: [PATCH 03/12] ARM64: dts: marvell: armada37xx: Enable USB2 on
|
||||
espressobin
|
||||
|
||||
The Espressobin SBC has a USB2 interface available on J8. Let's
|
|
@ -1,7 +1,7 @@
|
|||
From 737f6a0e38813727892484840406ad51c48e0687 Mon Sep 17 00:00:00 2001
|
||||
From 757e191a5e3ebb62f98f5c7d9151f3f90b7a4e2f Mon Sep 17 00:00:00 2001
|
||||
From: Marcin Wojtas <mw@semihalf.com>
|
||||
Date: Fri, 21 Jul 2017 01:50:36 +0200
|
||||
Subject: [PATCH 05/13] ARM64: dts: marvell: armada-37xx: Enable uSD on
|
||||
Subject: [PATCH 04/12] ARM64: dts: marvell: armada-37xx: Enable uSD on
|
||||
ESPRESSObin
|
||||
|
||||
The ESPRESSObin board exposes one of the SDHCI interfaces
|
|
@ -1,7 +1,7 @@
|
|||
From 70883393eeeec4e74164996eee427d3d4b506b77 Mon Sep 17 00:00:00 2001
|
||||
From 379313975431e6318d9994a873311ecfd82cee16 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 19:25:28 -0600
|
||||
Subject: [PATCH 06/13] arm64: dts: marvell: armada37xx: Add eth0 alias
|
||||
Subject: [PATCH 05/12] arm64: dts: marvell: armada37xx: Add eth0 alias
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
index d6a060d9f083..d977c760e587 100644
|
||||
index 35307cd93db5..d4133fbe47dc 100644
|
||||
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
||||
@@ -54,6 +54,7 @@
|
|
@ -1,7 +1,7 @@
|
|||
From f1e6e40e9a67f39dc559ff49ee7e017cd3165e13 Mon Sep 17 00:00:00 2001
|
||||
From 19f028017f93b19bd4142840a0714fc3b5c447a1 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:42 +0200
|
||||
Subject: [PATCH 07/13] PCI: aardvark: fix logic in PCI configuration
|
||||
Subject: [PATCH 06/12] PCI: aardvark: fix logic in PCI configuration
|
||||
read/write functions
|
||||
|
||||
The PCI configuration space read/write functions were special casing
|
|
@ -1,7 +1,7 @@
|
|||
From 05e816c4b086bfba96abccf6a3dd8527213bd75d Mon Sep 17 00:00:00 2001
|
||||
From e692c4478048fdcc01c939f28e9801aebdd622d3 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:43 +0200
|
||||
Subject: [PATCH 08/13] PCI: aardvark: set PIO_ADDR_LS correctly in
|
||||
Subject: [PATCH 07/12] PCI: aardvark: set PIO_ADDR_LS correctly in
|
||||
advk_pcie_rd_conf()
|
||||
|
||||
When setting the PIO_ADDR_LS register during a configuration read, we
|
|
@ -1,7 +1,7 @@
|
|||
From 867894fceeaf74327d334f71a14318d4ec847399 Mon Sep 17 00:00:00 2001
|
||||
From 6ce52078a28550c7103b79b2b26de08185035bda Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:44 +0200
|
||||
Subject: [PATCH 09/13] PCI: aardvark: set host and device to the same MAX
|
||||
Subject: [PATCH 08/12] PCI: aardvark: set host and device to the same MAX
|
||||
payload size
|
||||
|
||||
Since the Aardvark does not implement a PCIe root bus, the Linux PCIe
|
|
@ -1,7 +1,7 @@
|
|||
From 8059cc047ea434de114cf1ddebc12843ad7acef7 Mon Sep 17 00:00:00 2001
|
||||
From 2473c44af66f1714e4f57b1a96e1bb687f6b06ea Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:45 +0200
|
||||
Subject: [PATCH 10/13] PCI: aardvark: use isr1 instead of isr0 interrupt in
|
||||
Subject: [PATCH 09/12] PCI: aardvark: use isr1 instead of isr0 interrupt in
|
||||
legacy irq mode
|
||||
|
||||
The Aardvark has two interrupts sets:
|
|
@ -1,7 +1,7 @@
|
|||
From a433673c37b7306dbf1d268b95243ee42aa273db Mon Sep 17 00:00:00 2001
|
||||
From b081f4e3b6b03881b336991e3c8ddd8a88b1c3d3 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Gu <xigu@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:46 +0200
|
||||
Subject: [PATCH 11/13] PCI: aardvark: disable LOS state by default
|
||||
Subject: [PATCH 10/12] PCI: aardvark: disable LOS state by default
|
||||
|
||||
Some PCIe devices do not support LOS, and will cause timeouts if the
|
||||
root complex forces the LOS state. This patch disables the LOS state
|
|
@ -1,7 +1,7 @@
|
|||
From 7ba663f19c23e67d01a433486e302462ba30dc1a Mon Sep 17 00:00:00 2001
|
||||
From d94d6e8f5096f4eb245782bd2723f9d22e00a76c Mon Sep 17 00:00:00 2001
|
||||
From: Evan Wang <xswang@marvell.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:47 +0200
|
||||
Subject: [PATCH 12/13] PCI: aardvark: fix PCIe max read request size setting
|
||||
Subject: [PATCH 11/12] PCI: aardvark: fix PCIe max read request size setting
|
||||
|
||||
There is an obvious typo issue in the definition of the PCIe maximum
|
||||
read request size: a bit shift is directly used as a value, while it
|
|
@ -1,7 +1,7 @@
|
|||
From 0873f17aef726c64c5abb5ccdb35280a2239fc73 Mon Sep 17 00:00:00 2001
|
||||
From e1387e57b57b39a22d626d6f6f8ae5e6fa1a4567 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Date: Fri, 8 Sep 2017 11:53:48 +0200
|
||||
Subject: [PATCH 13/13] PCI: aardvark: define IRQ related hooks in
|
||||
Subject: [PATCH 12/12] PCI: aardvark: define IRQ related hooks in
|
||||
pci_host_bridge
|
||||
|
||||
Commit 769b461fc0c0 ("arm64: PCI: Drop DT IRQ allocation from
|
|
@ -7,7 +7,7 @@ pkgbase=linux-espressobin
|
|||
_srcname=linux-4.13
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Globalscale ESPRESSOBin"
|
||||
pkgver=4.13.1
|
||||
pkgver=4.13.2
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -16,36 +16,34 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
|||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
'0001-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch'
|
||||
'0002-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch'
|
||||
'0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch'
|
||||
'0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch'
|
||||
'0005-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch'
|
||||
'0006-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
|
||||
'0007-PCI-aardvark-fix-logic-in-PCI-configuration-read-wri.patch'
|
||||
'0008-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_.patch'
|
||||
'0009-PCI-aardvark-set-host-and-device-to-the-same-MAX-pay.patch'
|
||||
'0010-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-l.patch'
|
||||
'0011-PCI-aardvark-disable-LOS-state-by-default.patch'
|
||||
'0012-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch'
|
||||
'0013-PCI-aardvark-define-IRQ-related-hooks-in-pci_host_br.patch'
|
||||
'0001-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch'
|
||||
'0002-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch'
|
||||
'0003-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch'
|
||||
'0004-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch'
|
||||
'0005-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
|
||||
'0006-PCI-aardvark-fix-logic-in-PCI-configuration-read-wri.patch'
|
||||
'0007-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_.patch'
|
||||
'0008-PCI-aardvark-set-host-and-device-to-the-same-MAX-pay.patch'
|
||||
'0009-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-l.patch'
|
||||
'0010-PCI-aardvark-disable-LOS-state-by-default.patch'
|
||||
'0011-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch'
|
||||
'0012-PCI-aardvark-define-IRQ-related-hooks-in-pci_host_br.patch'
|
||||
'config'
|
||||
'linux.preset')
|
||||
md5sums=('ab1a2abc6f37b752dd2595338bec4e78'
|
||||
'e2824a53597a9af0bfb2c533386842f0'
|
||||
'58d3c4d2dda70d6bf5a241b8c6363c7e'
|
||||
'4bce2be25214c81f1bf1e46e6a4c7d70'
|
||||
'903386a648fe7c1fd54f5c0384ce0db3'
|
||||
'125ada93f7b77dc1062310acae35f8a5'
|
||||
'f7051fe596af5844ec9c321f985d05b3'
|
||||
'd7854dc2004728203ffb21b9b07979ca'
|
||||
'ec9be172d832feaf53514ac712a634a9'
|
||||
'd971ded67792286617f0143f577ab0f8'
|
||||
'b4d9ab7e846ef77562cfed6baa36ab4c'
|
||||
'a275b90e133c3d045af1858d9f44faf8'
|
||||
'88b158d5e0f650c08b37bd2dd394b8ad'
|
||||
'98e275e9c5e48dd1e337bddf48934f85'
|
||||
'20f31fa87e111c8ec1b0335c6d059466'
|
||||
'0aed60167525cb5cecdd29e78fc5f58e'
|
||||
'e10174ecfd529e00cc4c787472c77ae2'
|
||||
'004d238d28d14525c2a3e6f2a2d5c517'
|
||||
'ef62415d87a24d38f3dcb756ba7a1739'
|
||||
'4e340f6e4f03cce707575cc925a7b264'
|
||||
'35bc446f5cbcf2771a4f9147ccb33c34'
|
||||
'4e60b850c7bfe7874bf0a2e00c33c06f'
|
||||
'05a28cf5faa535d3814324abcec279bb'
|
||||
'8b9d57b22b256437038036b219f581fe'
|
||||
'a1a48018d94c19dc3d62756fd5261a56'
|
||||
'56cfdb16e99145ab796964f14cba4173'
|
||||
'899ff6e03408b4eb5e0dd600402e2420'
|
||||
'a330eecd9d5fd0a771f9d1882aea2157'
|
||||
'0bca6f08768f5757e62d5ee56f1a7c6b'
|
||||
'd8d30aa4a9d4c2b8d4ea53faf46ccf80')
|
||||
|
||||
|
@ -56,19 +54,18 @@ prepare() {
|
|||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-ARM64-dts-marvell-armada37xx-Fix-GIC-maintenance-int.patch
|
||||
git apply ../0002-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch
|
||||
git apply ../0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch
|
||||
git apply ../0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch
|
||||
git apply ../0005-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch
|
||||
git apply ../0006-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
|
||||
git apply ../0007-PCI-aardvark-fix-logic-in-PCI-configuration-read-wri.patch
|
||||
git apply ../0008-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_.patch
|
||||
git apply ../0009-PCI-aardvark-set-host-and-device-to-the-same-MAX-pay.patch
|
||||
git apply ../0010-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-l.patch
|
||||
git apply ../0011-PCI-aardvark-disable-LOS-state-by-default.patch
|
||||
git apply ../0012-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch
|
||||
git apply ../0013-PCI-aardvark-define-IRQ-related-hooks-in-pci_host_br.patch
|
||||
git apply ../0001-ARM64-dts-marvell-armada37xx-Enable-memory-mapped-GI.patch
|
||||
git apply ../0002-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch
|
||||
git apply ../0003-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch
|
||||
git apply ../0004-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch
|
||||
git apply ../0005-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
|
||||
git apply ../0006-PCI-aardvark-fix-logic-in-PCI-configuration-read-wri.patch
|
||||
git apply ../0007-PCI-aardvark-set-PIO_ADDR_LS-correctly-in-advk_pcie_.patch
|
||||
git apply ../0008-PCI-aardvark-set-host-and-device-to-the-same-MAX-pay.patch
|
||||
git apply ../0009-PCI-aardvark-use-isr1-instead-of-isr0-interrupt-in-l.patch
|
||||
git apply ../0010-PCI-aardvark-disable-LOS-state-by-default.patch
|
||||
git apply ../0011-PCI-aardvark-fix-PCIe-max-read-request-size-setting.patch
|
||||
git apply ../0012-PCI-aardvark-define-IRQ-related-hooks-in-pci_host_br.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
Loading…
Reference in a new issue