community/gitlab to 9.0.5-1

This commit is contained in:
Kevin Mihelich 2017-04-16 03:02:13 +00:00
parent 5f18a7f844
commit 558b40d300
2 changed files with 42 additions and 8 deletions

View file

@ -0,0 +1,28 @@
From e46f67a5123433f132da28770e4027542062fc81 Mon Sep 17 00:00:00 2001
From: Jacob Vosmaer <jacob@gitlab.com>
Date: Mon, 10 Apr 2017 13:24:14 +0200
Subject: [PATCH] Use gRPC 1.2.2
Fixes LoadError after local compilation.
https://github.com/grpc/grpc/issues/9998
---
Gemfile.lock | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Gemfile.lock b/Gemfile.lock
index d7e3f73..965c888 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -330,7 +330,7 @@ GEM
grape-entity (0.6.0)
activesupport
multi_json (>= 1.3.2)
- grpc (1.1.2)
+ grpc (1.2.2)
google-protobuf (~> 3.1)
googleauth (~> 0.5.1)
haml (4.0.7)
--
2.10.2

View file

@ -11,14 +11,14 @@
# - disable webpack build
pkgname=gitlab
pkgver=8.17.4
pkgver=9.0.5
pkgrel=1
pkgdesc="Project management and code hosting application"
arch=('i686' 'x86_64')
url="https://gitlab.com/gitlab-org/gitlab-ce/tree/master#README"
license=('MIT')
depends=('ruby2.3' 'git' 'ruby2.3-bundler' 'gitlab-workhorse' 'openssh' 'redis' 'libxslt' 'icu' 'nodejs')
makedepends=('cmake' 'postgresql' 'mariadb' 'npm')
makedepends=('cmake' 'postgresql' 'mariadb' 'yarn')
optdepends=('postgresql: database backend'
'mysql: database backend'
'python2-docutils: reStructuredText markup language support'
@ -43,9 +43,10 @@ source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/gitlab-org/gitlab-ce/reposi
apache2.2-ssl.conf.example
nginx.conf.example
nginx-ssl.conf.example
lighttpd.conf.example)
lighttpd.conf.example
10589.patch)
install='gitlab.install'
sha512sums=('d76f2ae679b6e80a0383df0cc2d3ceb7318e7fe3b5435eaf1e69539ecca8f7c0fe838809264d46ea9a352b724da70208aedae775ebe039dfc4d5a5f53774ddd9'
sha512sums=('a925bc99c72f2c2475b58267f06c2ee21dc397a6057186915acc4636f15b4fab97cb85e458e7a0aefaf39c292c65ad3b36c6cab2faa747b94e9d1512c4347387'
'56cce150645ef74fa42a6100c8bc7689c4012579e1f3ba237c06c367b121246b39e968044615fa21c4757bc8e9d06f37f8ac8d39aa8b808c758e716857553f66'
'52651e4a5dd2d632e31b7275283f9b8ab2c32c4d56b63d17bd843f300e273e382e339e5aed66222b1b2279273357cbb73aa38119f04784fe380d1550346f1ff3'
'79cfb8ee740ab30f970c3113659b8349128abeae5e32cc81bb905f89a6db9941b7778040a094b884262daf020f66a1aee49a12d34fbb94efce6ade946bb4625b'
@ -60,7 +61,8 @@ sha512sums=('d76f2ae679b6e80a0383df0cc2d3ceb7318e7fe3b5435eaf1e69539ecca8f7c0fe8
'248d47b44fa5ed65e2a940f2b60d0482c481b3a438357ca510848221370367ffbc0d83ce046d688bebbbc75d4e321b140f6a5ce1a9d7ec0b034fafcf92dee107'
'53a9d6d6f87874b29e48a8fb2e207094ebc1a80af478562ec4b591926d59e135a3166c20966704aa948ca7063ba63c1ec4ac290a343832fa18025ec3d85081ba'
'6d3006da591acefcc534c6e3f1da8e812d0b3b21fc416bfaa8678b8e2d922be6b17d1c92b0d7164de3b8ad864139253707107ca082f78e823d23f3b65fcb5914'
'c78b6f46abcf603d8db6e38cf50868e14145928422ddfe17c88e2f006b5b910dddf456ec5d6d724b250994530643963809688a98f7e12ebd5b5dabf7f96f0e06')
'c78b6f46abcf603d8db6e38cf50868e14145928422ddfe17c88e2f006b5b910dddf456ec5d6d724b250994530643963809688a98f7e12ebd5b5dabf7f96f0e06'
'364408ad2cc7fd866c1f78a336fead0876c6af694cc45744a7dda680d40ad12bc2c35f18b54f4043af3f144a43a64ced5155e61210a88f814918152f041e1bb6')
_datadir="/usr/share/webapps/${pkgname}"
_etcdir="/etc/webapps/${pkgname}"
@ -71,6 +73,11 @@ _srcdir="gitlab-ce-v${pkgver}"
prepare() {
cd "${srcdir}/${_srcdir}"*
# https://gitlab.com/gitlab-org/gitlab-ce/merge_requests/10589
# https://gitlab.com/gitlab-org/gitlab-ce/issues/29562
# https://gitlab.com/gitlab-org/gitlab-ce/issues/30124
patch -Np1 < "${srcdir}"/10589.patch
export SKIP_STORAGE_VALIDATION='true'
# Patching config files:
@ -127,9 +134,8 @@ build() {
bundle-2.3 exec rake assets:precompile RAILS_ENV=production --trace
# npm install --production
# bundle-2.3 exec rake gitlab:assets:clean gitlab:assets:compile cache:clear RAILS_ENV=production --trace
# bundle-2.3 exec rake webpack:compile RAILS_ENV=production --trace
# yarn install --production --pure-lockfile
# bundle-2.3 exec rake gitlab:assets:compile RAILS_ENV=production NODE_ENV=production
# After building assets, clean this up again
rm config/database.yml config/database.yml.postgresql.orig