mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/texmacs to 1.99.13-1
This commit is contained in:
parent
92479f9d82
commit
55aa28391f
2 changed files with 44 additions and 10 deletions
|
@ -5,13 +5,13 @@
|
|||
# - patch to fix size_t check on ARM
|
||||
|
||||
pkgname=texmacs
|
||||
pkgver=1.99.12
|
||||
pkgrel=2
|
||||
pkgver=1.99.13
|
||||
pkgrel=1
|
||||
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
|
||||
arch=('x86_64')
|
||||
url="http://www.texmacs.org/"
|
||||
license=('GPL')
|
||||
depends=('perl' 'guile1.8' 'texlive-core' 'python2' 'libxext' 'freetype2' 'qt5-base')
|
||||
depends=('perl' 'guile1.8' 'texlive-core' 'python' 'libxext' 'freetype2' 'qt5-base')
|
||||
# do not remove texlive-core dependency, as it is needed!
|
||||
optdepends=('transfig: convert images using fig2ps'
|
||||
'gawk: conversion of some files'
|
||||
|
@ -20,22 +20,22 @@ optdepends=('transfig: convert images using fig2ps'
|
|||
'aspell: spell checking')
|
||||
makedepends=('ghostscript' 'cmake')
|
||||
source=(http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-${pkgver}-src.tar.gz
|
||||
texmacs-qt-5.15.patch
|
||||
fix-size_t-check.patch)
|
||||
options=('!emptydirs')
|
||||
sha256sums=('e43da849d5c3770f7d4f7ad9ac6367ab4174a1df83f37dfa41f8f00f1eb6f142'
|
||||
sha256sums=('02ad1c4b8ed0aa61501de97146300d7899605c25da827611ca4a40abbc07a9b4'
|
||||
'0e8555ce855977858565c7eedd415a22e640eea0f1ce69adce1be0396542200d'
|
||||
'09de18741b6a3b8590e76be52c571b2799b906cc3ecdd0eb6594c2ffdef3ad83')
|
||||
|
||||
prepare() {
|
||||
cd TeXmacs-${pkgver}-src
|
||||
|
||||
find -name '*.py' | xargs sed -i 's/env python/env python2/'
|
||||
sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
|
||||
cd TeXmacs-${pkgver}
|
||||
|
||||
patch -p1 -i ../texmacs-qt-5.15.patch # Fix build with Qt 5.15
|
||||
patch -p1 -i ../fix-size_t-check.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd TeXmacs-${pkgver}-src
|
||||
cd TeXmacs-${pkgver}
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
@ -47,7 +47,7 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd TeXmacs-${pkgver}-src/build
|
||||
cd TeXmacs-${pkgver}/build
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
# fix fig2ps script
|
||||
|
|
34
extra/texmacs/texmacs-qt-5.15.patch
Normal file
34
extra/texmacs/texmacs-qt-5.15.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
From 3cf56af92326b74538f5e943928199ba6e963d0b Mon Sep 17 00:00:00 2001
|
||||
From: rezso <rezso@rezso.net>
|
||||
Date: Wed, 3 Jun 2020 19:33:29 +0200
|
||||
Subject: [PATCH] Fix build with Qt 5.15
|
||||
|
||||
---
|
||||
src/Plugins/Qt/QTMStyle.cpp | 1 +
|
||||
src/Plugins/Qt/qt_renderer.cpp | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/Plugins/Qt/QTMStyle.cpp b/src/Plugins/Qt/QTMStyle.cpp
|
||||
index e1c05ece3..2bc819fac 100644
|
||||
--- a/src/Plugins/Qt/QTMStyle.cpp
|
||||
+++ b/src/Plugins/Qt/QTMStyle.cpp
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <QStyleOptionMenuItem>
|
||||
#include <qdrawutil.h>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
#include <QMainWindow>
|
||||
|
||||
int
|
||||
diff --git a/src/Plugins/Qt/qt_renderer.cpp b/src/Plugins/Qt/qt_renderer.cpp
|
||||
index ceba13939..776759bcf 100644
|
||||
--- a/src/Plugins/Qt/qt_renderer.cpp
|
||||
+++ b/src/Plugins/Qt/qt_renderer.cpp
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <QObject>
|
||||
#include <QWidget>
|
||||
#include <QPaintDevice>
|
||||
+#include <QPainterPath>
|
||||
#include <QPixmap>
|
||||
|
||||
/******************************************************************************
|
Loading…
Reference in a new issue