mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added extra/bogofilter
This commit is contained in:
parent
452e5d94c9
commit
55ab8e00a5
2 changed files with 73 additions and 0 deletions
62
extra/bogofilter/PKGBUILD
Normal file
62
extra/bogofilter/PKGBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# $Id$
|
||||
# Maintainer: AndyRTR <andyrtr@archlinux.org>
|
||||
# Contributor: tobias <tobias@archlinux.org>
|
||||
# Contributor: Low Kian Seong <fastmail_low@speedymail.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - drop valgrind makedepend
|
||||
|
||||
pkgname=bogofilter
|
||||
pkgver=1.2.4
|
||||
pkgrel=2
|
||||
pkgdesc="A fast Bayesian spam filtering tool"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3')
|
||||
url="http://bogofilter.sourceforge.net"
|
||||
depends=('db' 'perl' 'gsl') # 'sqlite'
|
||||
makedepends=('xmlto')
|
||||
backup=('etc/bogofilter/bogofilter.cf')
|
||||
source=(http://sourceforge.net/projects/${pkgname}/files/${pkgname}-current/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2
|
||||
bogofilter-1.2.4-test-env.patch)
|
||||
md5sums=('d0a5eebb3274b23ceabe766a6443a1c5'
|
||||
'd01f23755ee9b4f5807b9feefea0b42d')
|
||||
|
||||
# keep Berkeley DB as backend for now
|
||||
# sqlite3 based backend doesn't allow
|
||||
# to use db-transaction option that is
|
||||
# used to bf_compact the wordlist.db
|
||||
# other backend aren't available
|
||||
# currently in Arch repos
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
# taken from Gentoo
|
||||
patch -Np1 -i $srcdir/bogofilter-1.2.4-test-env.patch
|
||||
chmod +x src/tests/t.{ctype,leakfind,lexer.qpcr,lexer.eoh,message_id,queue_id}
|
||||
autoreconf -vfi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
./configure --prefix=/usr \
|
||||
--sysconfdir=/etc/bogofilter \
|
||||
--localstatedir=/var \
|
||||
--enable-transactions \
|
||||
--with-database=db #--help
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
make -k -C src check || /bin/true
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
mv "${pkgdir}/etc/bogofilter/bogofilter.cf.example" "${pkgdir}/etc/bogofilter/bogofilter.cf"
|
||||
|
||||
install -dm755 "${pkgdir}/usr/share/${pkgname}/contrib"
|
||||
install -m644 contrib/* "${pkgdir}/usr/share/${pkgname}/contrib/"
|
||||
}
|
11
extra/bogofilter/bogofilter-1.2.4-test-env.patch
Normal file
11
extra/bogofilter/bogofilter-1.2.4-test-env.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/tests/Makefile.am
|
||||
+++ b/src/tests/Makefile.am
|
||||
@@ -67,7 +67,7 @@
|
||||
|
||||
TESTS=$(BUILT_TESTS) $(TESTSCRIPTS)
|
||||
|
||||
-TESTS_ENVIRONMENT=RUN_FROM_MAKE=1 AWK=$(AWK) srcdir=$(srcdir) SHELL="$(SHELL)" $(SHELL) $(VERBOSE)
|
||||
+TESTS_ENVIRONMENT=RUN_FROM_MAKE=1 AWK=$(AWK) srcdir=$(srcdir) SHELL="$(SHELL)" $(VERBOSE)
|
||||
|
||||
EXTRA_DIST=$(TESTSCRIPTS) t.frame t.save t.skel \
|
||||
printcore t._abort unsort.pl \
|
Loading…
Reference in a new issue