mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt4 to 4.8.7-16
This commit is contained in:
parent
abff0fc50c
commit
55f0732dad
2 changed files with 19 additions and 3 deletions
|
@ -12,7 +12,7 @@
|
|||
|
||||
pkgname=qt4
|
||||
pkgver=4.8.7
|
||||
pkgrel=14
|
||||
pkgrel=16
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
|
@ -62,7 +62,7 @@ md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
|
|||
'addc5e88d538ee55e17bd49ba337ca67'
|
||||
'98e00c5c7e5fee12e11ecbedd03f01ff'
|
||||
'a6e217c159d9c0f588d4b5611493f0ea'
|
||||
'2a9572f3b758fc3ca9ff5fc40012a2a4')
|
||||
'296a06554222ff5839cccc41c5d3987e')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -114,7 +114,6 @@ build() {
|
|||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
export CXXFLAGS+=" -std=gnu++98" # Fix build with GCC 6
|
||||
# export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig/
|
||||
# export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
|
||||
# export CXXFLAGS+=" -I/usr/include/openssl-1.0"
|
||||
|
||||
|
|
|
@ -11,3 +11,20 @@ qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h
|
|||
|
||||
#define QT_PACKAGEDATE_STR "2015-05-07"
|
||||
|
||||
diff -up qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp.QTBUG-22829 qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp.QTBUG-22829 2015-05-07 09:14:44.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.7/src/tools/moc/main.cpp 2016-12-08 12:32:46.638962448 -0600
|
||||
@@ -188,10 +188,12 @@ int runMoc(int _argc, char **_argv)
|
||||
pp.macros["Q_MOC_RUN"];
|
||||
pp.macros["__cplusplus"];
|
||||
|
||||
- // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
|
||||
+ // Workaround a bugs while parsing some boost headers. See QTBUG-22829
|
||||
pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
|
||||
pp.macros["BOOST_LEXICAL_CAST_INCLUDED"];
|
||||
pp.macros["BOOST_NEXT_PRIOR_HPP_INCLUDED"];
|
||||
+ pp.macros["BOOST_TYPE_TRAITS_HPP"];
|
||||
+ pp.macros["_SYS_SYSMACROS_H_OUTER"];
|
||||
|
||||
QByteArray filename;
|
||||
QByteArray output;
|
||||
|
|
Loading…
Reference in a new issue