extra/qt4 to 4.8.7-14

This commit is contained in:
Kevin Mihelich 2017-03-13 19:10:12 +00:00
parent 24ba3ff3d1
commit 56203c034d
2 changed files with 25 additions and 5 deletions

View file

@ -12,13 +12,13 @@
pkgname=qt4
pkgver=4.8.7
pkgrel=12
pkgrel=14
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
pkgdesc='A cross-platform application and UI framework'
depends=('sqlite' 'ca-certificates' 'fontconfig' 'libgl' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'libmng' 'dbus')
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'libmng' 'dbus') # 'openssl-1.0'
makedepends=('postgresql-libs' 'mariadb' 'unixodbc' 'cups' 'gtk2'
'mesa')
optdepends=('postgresql-libs: PostgreSQL driver'
@ -44,7 +44,7 @@ source=("http://download.qt.io/official_releases/qt/4.8/${pkgver}/${_pkgfqn}.tar
'disable-sslv3.patch'
'l-qclipboard_fix_recursive.patch'
'l-qclipboard_delay.patch'
'qt4-gcc6.patch'
'qt4-gcc6.patch' 'qt4-glibc-2.25.patch'
'qt-aarch64.patch')
md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
'a16638f4781e56e7887ff8212a322ecc'
@ -61,6 +61,7 @@ md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
'009de09b4e589a7770fba74405656c99'
'addc5e88d538ee55e17bd49ba337ca67'
'98e00c5c7e5fee12e11ecbedd03f01ff'
'a6e217c159d9c0f588d4b5611493f0ea'
'2a9572f3b758fc3ca9ff5fc40012a2a4')
prepare() {
@ -104,20 +105,26 @@ prepare() {
# Fix build with GCC6 (Fedora)
patch -p1 -i "$srcdir"/qt4-gcc6.patch
# Fix build of Qt4 applications with glibc 2.25 (Fedora)
patch -p1 -i "$srcdir"/qt4-glibc-2.25.patch
}
build() {
export QT4DIR="${srcdir}"/${_pkgfqn}
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
export CXXFLAGS+=" -std=gnu++98" # Fix build with GCC 6
# export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig/
# export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
# export CXXFLAGS+=" -I/usr/include/openssl-1.0"
cd ${_pkgfqn}
if [[ $CARCH == "aarch64" ]]; then
MAKEFLAGS="-j3"
CONFIG="-platform linux-g++"
fi
cd ${_pkgfqn}
./configure -confirm-license -opensource \
-prefix /usr \
-bindir /usr/lib/qt4/bin \

View file

@ -0,0 +1,13 @@
diff -up qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h.majmin
qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h
--- qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h.majmin 2015-05-07 09:14:48.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.7/src/corelib/global/qglobal.h 2016-12-08 12:10:29.677359701 -0600
@@ -52,7 +52,7 @@
/*
can be used like #if (QT_VERSION >= QT_VERSION_CHECK(4, 4, 0))
*/
-#define QT_VERSION_CHECK(major, minor, patch) ((major<<16)|(minor<<8)|(patch))
+#define QT_VERSION_CHECK(qt_version_check_major, qt_version_check_minor, qt_version_check_patch) ((qt_version_check_major<<16)|(qt_version_check_minor<<8)|(qt_version_check_patch))
#define QT_PACKAGEDATE_STR "2015-05-07"