mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Adding Raspberry Pi kernel and headers
This commit is contained in:
parent
df7d35df38
commit
563cd42729
9 changed files with 494 additions and 0 deletions
243
core/kernel26-raspberrypi/PKGBUILD
Normal file
243
core/kernel26-raspberrypi/PKGBUILD
Normal file
|
@ -0,0 +1,243 @@
|
|||
# Maintainer: Mike Staszel <mikestaszel@plugapps.com>
|
||||
|
||||
# Rasberry Pi kernel and headers
|
||||
|
||||
noautobuild=1
|
||||
plugrel=2
|
||||
#ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.35.7.tar.bz2
|
||||
pkgbase="kernel26-raspberrypi"
|
||||
pkgname=('kernel26-raspberrypi' 'kernel26-headers-raspberrypi')
|
||||
#_kernelname=${pkgname#kernel26}
|
||||
_kernelname=""
|
||||
_basekernel=2.6.35
|
||||
pkgver=${_basekernel}.7
|
||||
_pkgrel=1
|
||||
pkgrel=${_pkgrel}
|
||||
#pkgrel=${_pkgrel}.${plugrel}
|
||||
makedepends=('xmlto' 'docbook-xsl' 'make' 'python2')
|
||||
_patchname="patch-${pkgver}-${_pkgrel}-ARCH"
|
||||
arch=(arm)
|
||||
KARCH=arm
|
||||
LDFLAGS=""
|
||||
license=('GPL2')
|
||||
url="http://www.kernel.org"
|
||||
source=('armdma.patch'
|
||||
'args-uncompressed.txt'
|
||||
'boot-uncompressed.txt'
|
||||
'imagetool-uncompressed.py'
|
||||
'ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.35.7.tar.bz2'
|
||||
'rp-patches.tar.gz'
|
||||
'sys_accept4.patch')
|
||||
md5sums=('6e7667c6c6348bfeca22eaaa05462d62'
|
||||
'9335d1263fd426215db69841a380ea26'
|
||||
'a00e424e2fbb8c5a5f77ba2c4871bed4'
|
||||
'2f82dbe5752af65ff409d737caf11954'
|
||||
'f741879bcd3a5366a1bbe0ad5cdb7935'
|
||||
'968a3a9468b90a8a50dae8cafb276760'
|
||||
'fdbbc3c4f34d5959504f027bdc1e7a73')
|
||||
|
||||
options=('!distcc' '!ccache')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/linux-${pkgver}"
|
||||
|
||||
# Copy in the ethernet firmware, needed for make!
|
||||
cp ${srcdir}/args-uncompressed.txt arch/arm/boot/
|
||||
cp ${srcdir}/boot-uncompressed.txt arch/arm/boot/
|
||||
cp ${srcdir}/imagetool-uncompressed.py arch/arm/boot/
|
||||
|
||||
# Prepare sources
|
||||
#make prepare
|
||||
make clean # sometimes git isn't clean
|
||||
make mrproper # same as above
|
||||
# Configure the kernel. Replace the line below with one of your choice.
|
||||
#make menuconfig # CLI menu for configuration
|
||||
#make nconfig # new CLI menu for configuration
|
||||
#make oldconfig # using old config from previous kernel version
|
||||
|
||||
# ALARM: add dma_coherent_write_sync calls to USB EHCI driver
|
||||
patch -Np1 -i "${srcdir}/rp-patches/rpdh1.patch"
|
||||
patch -Np1 -i "${srcdir}/rp-patches/smsc95xx.patch"
|
||||
patch -Np1 -i "${srcdir}/armdma.patch"
|
||||
patch -Np1 -i "${srcdir}/sys_accept4.patch"
|
||||
|
||||
# Make the config compatible with Arch Linux's naming scheme
|
||||
# sed 's|CONFIG_LOCALVERSION="-trimslice-1.02"|CONFIG_LOCALVERSION="-ARCH"|g' -i .config
|
||||
|
||||
# Copy back our configuration (use with new kernel version)
|
||||
#cp ./.config ../${_basekernel}.config
|
||||
|
||||
# Halt the build for configuration only
|
||||
#return 1
|
||||
|
||||
# Build!
|
||||
make -j2 #${MAKEFLAGS}
|
||||
}
|
||||
|
||||
package_kernel26-raspberrypi() {
|
||||
pkgdesc="The Linux Kernel and modules"
|
||||
groups=('base')
|
||||
depends=('coreutils' 'module-init-tools>=3.12-2')
|
||||
replaces=('kernel24' 'kernel24-scsi' 'kernel26-scsi'
|
||||
'alsa-driver' 'ieee80211' 'hostap-driver26'
|
||||
'pwc' 'nforce' 'squashfs' 'unionfs' 'ivtv'
|
||||
'zd1211' 'kvm-modules' 'iwlwifi' 'rt2x00-cvs'
|
||||
'gspcav1' 'atl2' 'wlan-ng26' 'rt2500' 'nouveau-drm')
|
||||
provides=('kernel26=2.6.38')
|
||||
conflicts=('kernel26' 'kernel26-tegra' 'kernel26-omap')
|
||||
install=kernel26.install
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
|
||||
KARCH=arm
|
||||
cd "${srcdir}/linux-${pkgver}"
|
||||
# get kernel version
|
||||
_kernver="$(make kernelrelease)"
|
||||
mkdir -p ${pkgdir}/{lib/modules,lib/firmware,boot}
|
||||
make INSTALL_MOD_PATH=${pkgdir} modules_install
|
||||
# cp System.map ${pkgdir}/boot/System.map26${_kernelname}
|
||||
cd arch/$KARCH/boot/
|
||||
/usr/bin/python2 imagetool-uncompressed.py
|
||||
cd "${srcdir}/linux-${pkgver}"
|
||||
cp arch/$KARCH/boot/kernel.img ${pkgdir}/boot/kernel.img
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i $startdir/kernel26.install
|
||||
|
||||
# remove build and source links
|
||||
rm -f ${pkgdir}/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf ${pkgdir}/lib/firmware
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
|
||||
}
|
||||
|
||||
package_kernel26-headers-raspberrypi() {
|
||||
pkgdesc="Header files and scripts for building modules for kernel26"
|
||||
provides=('kernel26-headers=2.35.7')
|
||||
conflicts=('kernel26-headers' 'kernel26-headers-tegra' 'kernel26-headers-omap')
|
||||
KARCH=arm
|
||||
|
||||
mkdir -p ${pkgdir}/lib/modules/${_kernver}
|
||||
cd ${pkgdir}/lib/modules/${_kernver}
|
||||
ln -sf ../../../usr/src/linux-${_kernver} build
|
||||
cd "${srcdir}/linux-${pkgver}"
|
||||
install -D -m644 Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Makefile
|
||||
install -D -m644 kernel/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile
|
||||
install -D -m644 .config \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/.config
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include
|
||||
|
||||
for i in acpi asm-generic config generated linux math-emu media net pcmcia scsi sound trace video xen; do
|
||||
cp -a include/$i ${pkgdir}/usr/src/linux-${_kernver}/include/
|
||||
done
|
||||
|
||||
# copy arch includes for external modules
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-bcm2708
|
||||
cp -a arch/$KARCH/mach-bcm2708/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-bcm2708/
|
||||
|
||||
# copy files necessary for later builds, like nvidia and vmware
|
||||
cp Module.symvers ${pkgdir}/usr/src/linux-${_kernver}
|
||||
cp -a scripts ${pkgdir}/usr/src/linux-${_kernver}
|
||||
# fix permissions on scripts dir
|
||||
chmod og-w -R ${pkgdir}/usr/src/linux-${_kernver}/scripts
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions
|
||||
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel
|
||||
|
||||
cp arch/$KARCH/Makefile ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
if [ "$CARCH" = "i686" ]; then
|
||||
cp arch/$KARCH/Makefile_32.cpu ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
fi
|
||||
cp arch/$KARCH/kernel/asm-offsets.s ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/kernel/
|
||||
|
||||
# add headers for lirc package
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video
|
||||
cp drivers/media/video/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/
|
||||
for i in bt8xx cpia2 cx25840 cx88 em28xx et61x251 pwc saa7134 sn9c102; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
cp -a drivers/media/video/$i/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/$i
|
||||
done
|
||||
# mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/staging/usbvideo/
|
||||
# cp -a drivers/staging/usbvideo/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/staging/usbvideo/
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile
|
||||
# add dm headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
cp drivers/md/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/md
|
||||
# add inotify.h
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/linux
|
||||
cp include/linux/inotify.h ${pkgdir}/usr/src/linux-${_kernver}/include/linux/
|
||||
# add wireless headers
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
cp net/mac80211/*.h ${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/9912
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core
|
||||
cp drivers/media/dvb/dvb-core/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-core/
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/11194
|
||||
#mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
#cp include/config/dvb/*.h ${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/
|
||||
# add dvb headers for http://mcentral.de/hg/~mrec/em28xx-new
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/13146
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/dvb/frontends/lgdt330x.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
cp drivers/media/video/msp3400-driver.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
# add dvb headers
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/20402
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb
|
||||
cp drivers/media/dvb/dvb-usb/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/dvb-usb/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends
|
||||
cp drivers/media/dvb/frontends/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb/frontends/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners
|
||||
cp drivers/media/common/tuners/*.h ${pkgdir}/usr/src/linux-${_kernver}/drivers/media/common/tuners/
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/mm
|
||||
cp fs/xfs/xfs_sb.h ${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h
|
||||
# add headers vor virtualbox
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/14568
|
||||
cp -a include/drm $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# add headers for broadcom wl
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/14568
|
||||
cp -a include/trace $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# add headers for crypto modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/22081
|
||||
cp -a include/crypto $pkgdir/usr/src/linux-${_kernver}/include/
|
||||
# copy in Kconfig files
|
||||
for i in `find . -name "Kconfig*"`; do
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/`echo $i | sed 's|/Kconfig.*||'`
|
||||
cp $i ${pkgdir}/usr/src/linux-${_kernver}/$i
|
||||
done
|
||||
|
||||
chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
|
||||
find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
|
||||
# strip scripts directory
|
||||
find ${pkgdir}/usr/src/linux-${_kernver}/scripts -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "$binary")" in
|
||||
*application/x-sharedlib*) # Libraries (.so)
|
||||
/usr/bin/strip $STRIP_SHARED "$binary";;
|
||||
*application/x-archive*) # Libraries (.a)
|
||||
/usr/bin/strip $STRIP_STATIC "$binary";;
|
||||
*application/x-executable*) # Binaries
|
||||
/usr/bin/strip $STRIP_BINARIES "$binary";;
|
||||
esac
|
||||
done
|
||||
# remove unneeded architectures
|
||||
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,xtensa}
|
||||
}
|
12
core/kernel26-raspberrypi/args-uncompressed.txt
Normal file
12
core/kernel26-raspberrypi/args-uncompressed.txt
Normal file
|
@ -0,0 +1,12 @@
|
|||
; kernel args (place at 0x00000100)
|
||||
0x00000005
|
||||
0x54410001
|
||||
0x00000001
|
||||
0x00001000
|
||||
0x00000000
|
||||
0x00000004
|
||||
0x54410002
|
||||
0x08000000
|
||||
0x00000000
|
||||
0x00000000
|
||||
0x00000000
|
122
core/kernel26-raspberrypi/armdma.patch
Normal file
122
core/kernel26-raspberrypi/armdma.patch
Normal file
|
@ -0,0 +1,122 @@
|
|||
diff -urN linux-3.1-rc4-a/arch/arm/include/asm/dma-mapping.h linux-3.1-rc4-b/arch/arm/include/asm/dma-mapping.h
|
||||
--- linux-3.1-rc4-a/arch/arm/include/asm/dma-mapping.h 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/arch/arm/include/asm/dma-mapping.h 2011-09-02 12:09:00.000000000 +0100
|
||||
@@ -205,6 +205,15 @@
|
||||
int dma_mmap_writecombine(struct device *, struct vm_area_struct *,
|
||||
void *, dma_addr_t, size_t);
|
||||
|
||||
+#ifdef CONFIG_ARM_DMA_MEM_BUFFERABLE
|
||||
+#define ARCH_HAS_DMA_COHERENT_WRITE_SYNC
|
||||
+
|
||||
+static inline void dma_coherent_write_sync(void)
|
||||
+{
|
||||
+ dsb();
|
||||
+ outer_sync();
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#ifdef CONFIG_DMABOUNCE
|
||||
/*
|
||||
diff -urN linux-3.1-rc4-a/Documentation/DMA-API-HOWTO.txt linux-3.1-rc4-b/Documentation/DMA-API-HOWTO.txt
|
||||
--- linux-3.1-rc4-a/Documentation/DMA-API-HOWTO.txt 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/Documentation/DMA-API-HOWTO.txt 2011-09-02 12:01:09.000000000 +0100
|
||||
@@ -400,6 +400,22 @@
|
||||
from a pool before you destroy the pool. This function may not
|
||||
be called in interrupt context.
|
||||
|
||||
+Some architectures which supporting DMA coherent memory may still have write
|
||||
+buffering between the CPU and DMA memory. This buffering may delay CPU writes
|
||||
+from reaching coherent memory in a timely manner. These delays in turn can
|
||||
+lead lead to dramatic performance issues in certain cases. An architecture
|
||||
+may mitigate this problem to a large degree by having a write buffer flush
|
||||
+implicit in the MMIO functions used to write to device registers. This works
|
||||
+for the most common cases where a driver needs to write to a register to tell
|
||||
+a device that something was written to the shared coherent memory. There are
|
||||
+other cases where the device polls the dma-coherent memory for data written
|
||||
+by the driver. In such cases, the driver needs to explicity force write buffer
|
||||
+data to memory by calling:
|
||||
+
|
||||
+ dma_coherent_write_sync();
|
||||
+
|
||||
+
|
||||
+
|
||||
DMA Direction
|
||||
|
||||
The interfaces described in subsequent portions of this document
|
||||
diff -urN linux-3.1-rc4-a/Documentation/DMA-API.txt linux-3.1-rc4-b/Documentation/DMA-API.txt
|
||||
--- linux-3.1-rc4-a/Documentation/DMA-API.txt 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/Documentation/DMA-API.txt 2011-09-02 12:03:06.000000000 +0100
|
||||
@@ -418,6 +418,18 @@
|
||||
....
|
||||
|
||||
|
||||
+Part Ie - Write buffering to dma-coherent memory
|
||||
+------------------------------------------------
|
||||
+
|
||||
+Some architectures supporting DMA coherent memory may have write
|
||||
+buffering between the CPU and DMA memory. This buffering may delay
|
||||
+CPU writes from reaching coherent memory in a timely manner.
|
||||
+
|
||||
+ void
|
||||
+ dma_coherent_write_sync()
|
||||
+
|
||||
+Force any outstanding coherent writes to memory.
|
||||
+
|
||||
Part II - Advanced dma_ usage
|
||||
-----------------------------
|
||||
|
||||
diff -urN linux-3.1-rc4-a/drivers/usb/host/ehci-q.c linux-3.1-rc4-b/drivers/usb/host/ehci-q.c
|
||||
--- linux-3.1-rc4-a/drivers/usb/host/ehci-q.c 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/drivers/usb/host/ehci-q.c 2011-09-02 12:17:20.000000000 +0100
|
||||
@@ -114,6 +114,7 @@
|
||||
/* HC must see latest qtd and qh data before we clear ACTIVE+HALT */
|
||||
wmb ();
|
||||
hw->hw_token &= cpu_to_hc32(ehci, QTD_TOGGLE | QTD_STS_PING);
|
||||
+ dma_coherent_write_sync();
|
||||
}
|
||||
|
||||
/* if it weren't for a common silicon quirk (writing the dummy into the qh
|
||||
@@ -404,6 +405,7 @@
|
||||
wmb();
|
||||
hw->hw_token = cpu_to_hc32(ehci,
|
||||
token);
|
||||
+ dma_coherent_write_sync();
|
||||
goto retry_xacterr;
|
||||
}
|
||||
stopped = 1;
|
||||
@@ -753,8 +755,10 @@
|
||||
}
|
||||
|
||||
/* by default, enable interrupt on urb completion */
|
||||
- if (likely (!(urb->transfer_flags & URB_NO_INTERRUPT)))
|
||||
+ if (likely(!(urb->transfer_flags & URB_NO_INTERRUPT))) {
|
||||
qtd->hw_token |= cpu_to_hc32(ehci, QTD_IOC);
|
||||
+ dma_coherent_write_sync();
|
||||
+ }
|
||||
return head;
|
||||
|
||||
cleanup:
|
||||
@@ -1081,6 +1085,7 @@
|
||||
/* let the hc process these next qtds */
|
||||
wmb ();
|
||||
dummy->hw_token = token;
|
||||
+ dma_coherent_write_sync();
|
||||
|
||||
urb->hcpriv = qh_get (qh);
|
||||
}
|
||||
diff -urN linux-3.1-rc4-a/include/linux/dma-mapping.h linux-3.1-rc4-b/include/linux/dma-mapping.h
|
||||
--- linux-3.1-rc4-a/include/linux/dma-mapping.h 2011-08-29 05:16:01.000000000 +0100
|
||||
+++ linux-3.1-rc4-b/include/linux/dma-mapping.h 2011-09-02 12:06:06.000000000 +0100
|
||||
@@ -154,6 +154,12 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifndef ARCH_HAS_DMA_COHERENT_WRITE_SYNC
|
||||
+static inline void dma_coherent_write_sync(void)
|
||||
+{
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/*
|
||||
* Managed DMA API
|
||||
*/
|
17
core/kernel26-raspberrypi/boot-uncompressed.txt
Normal file
17
core/kernel26-raspberrypi/boot-uncompressed.txt
Normal file
|
@ -0,0 +1,17 @@
|
|||
; bootloader (place at 0x00000000)
|
||||
0xea000006
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
0xe1a00000
|
||||
|
||||
0xe3a00000
|
||||
0xe3a01042
|
||||
0xe3811c0c
|
||||
0xe59f2000
|
||||
0xe59ff000
|
||||
0x00000100
|
||||
0x00008000
|
41
core/kernel26-raspberrypi/imagetool-uncompressed.py
Normal file
41
core/kernel26-raspberrypi/imagetool-uncompressed.py
Normal file
|
@ -0,0 +1,41 @@
|
|||
#!/usr/bin/python2
|
||||
|
||||
import os
|
||||
import re
|
||||
import sys
|
||||
|
||||
try:
|
||||
linuxdir = sys.argv[1]
|
||||
except:
|
||||
linuxdir = "linux"
|
||||
|
||||
re_line = re.compile(r"0x(?P<value>[0-9a-f]{8})")
|
||||
|
||||
mem = [0 for i in range(32768)]
|
||||
|
||||
def load_to_mem(name, addr):
|
||||
f = open(name)
|
||||
|
||||
for l in f.readlines():
|
||||
m = re_line.match(l)
|
||||
|
||||
if m:
|
||||
value = int(m.group("value"), 16)
|
||||
|
||||
for i in range(4):
|
||||
mem[addr] = int(value >> i * 8 & 0xff)
|
||||
addr += 1
|
||||
|
||||
f.close()
|
||||
|
||||
load_to_mem("boot-uncompressed.txt", 0x00000000)
|
||||
load_to_mem("args-uncompressed.txt", 0x00000100)
|
||||
|
||||
f = open("first32k.bin", "wb")
|
||||
|
||||
for m in mem:
|
||||
f.write(chr(m))
|
||||
|
||||
f.close()
|
||||
|
||||
os.system("cat first32k.bin Image > kernel.img")
|
20
core/kernel26-raspberrypi/kernel26.install
Normal file
20
core/kernel26-raspberrypi/kernel26.install
Normal file
|
@ -0,0 +1,20 @@
|
|||
KERNEL_NAME=
|
||||
KERNEL_VERSION=2.6.35.7
|
||||
|
||||
post_install() {
|
||||
# ARM doesn't use mkinitcpio or anything like that
|
||||
# so we skip it here
|
||||
echo -e "\033[1mNotice\033[0m"
|
||||
echo ""
|
||||
echo "This package is built for the Raspberry Pi."
|
||||
echo ""
|
||||
/sbin/depmod ${KERNEL_VERSION}
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
$op $*
|
17
core/kernel26-raspberrypi/kernel26.preset
Normal file
17
core/kernel26-raspberrypi/kernel26.preset
Normal file
|
@ -0,0 +1,17 @@
|
|||
# mkinitcpio preset file for kernel26
|
||||
|
||||
########################################
|
||||
# DO NOT EDIT THIS LINE:
|
||||
source /etc/mkinitcpio.d/kernel26.kver
|
||||
########################################
|
||||
ALL_config="/etc/mkinitcpio.conf"
|
||||
|
||||
PRESETS=('default' 'fallback')
|
||||
|
||||
#default_config="/etc/mkinitcpio.conf"
|
||||
default_image="/boot/kernel26.img"
|
||||
#default_options=""
|
||||
|
||||
#fallback_config="/etc/mkinitcpio.conf"
|
||||
fallback_image="/boot/kernel26-fallback.img"
|
||||
fallback_options="-S autodetect"
|
BIN
core/kernel26-raspberrypi/rp-patches.tar.gz
Normal file
BIN
core/kernel26-raspberrypi/rp-patches.tar.gz
Normal file
Binary file not shown.
22
core/kernel26-raspberrypi/sys_accept4.patch
Normal file
22
core/kernel26-raspberrypi/sys_accept4.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff -rupN linux-2.6.35/arch/arm/include/asm/unistd.h linux-2.6.35.arm-sys_accept4/arch/arm/include/asm/unistd.h
|
||||
--- linux-2.6.35/arch/arm/include/asm/unistd.h 2010-05-17 19:51:29.000000000 +0200
|
||||
+++ linux-2.6.35.arm-sys_accept4/arch/arm/include/asm/unistd.h 2010-08-03 14:34:35.000000000 +0200
|
||||
@@ -392,6 +392,7 @@
|
||||
#define __NR_rt_tgsigqueueinfo (__NR_SYSCALL_BASE+363)
|
||||
#define __NR_perf_event_open (__NR_SYSCALL_BASE+364)
|
||||
#define __NR_recvmmsg (__NR_SYSCALL_BASE+365)
|
||||
+#define __NR_accept4 (__NR_SYSCALL_BASE+366)
|
||||
|
||||
/*
|
||||
* The following SWIs are ARM private.
|
||||
diff -rupN linux-2.6.35/arch/arm/kernel/calls.S linux-2.6.35.arm-sys_accept4/arch/arm/kernel/calls.S
|
||||
--- linux-2.6.35/arch/arm/kernel/calls.S 2010-05-17 19:51:29.000000000 +0200
|
||||
+++ linux-2.6.35.arm-sys_accept4/arch/arm/kernel/calls.S 2010-08-03 14:34:35.000000000 +0200
|
||||
@@ -375,6 +375,7 @@
|
||||
CALL(sys_rt_tgsigqueueinfo)
|
||||
CALL(sys_perf_event_open)
|
||||
/* 365 */ CALL(sys_recvmmsg)
|
||||
+ CALL(sys_accept4)
|
||||
#ifndef syscalls_counted
|
||||
.equ syscalls_padding, ((NR_syscalls + 3) & ~3) - NR_syscalls
|
||||
#define syscalls_counted
|
Loading…
Reference in a new issue