community/lmms to 1.1.3-2

This commit is contained in:
Kevin Mihelich 2015-12-10 05:06:18 +00:00
parent cfd635c2b4
commit 56646bd8e1
2 changed files with 35 additions and 5 deletions

View file

@ -1,5 +1,5 @@
# $Id: PKGBUILD 80173 2012-11-17 12:51:55Z lfleischer $
# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
# Contributor: Mateusz Herych <heniekk@gmail.com>
# Contributor: Storyteller <spiralsorrow@hotmail.com>
@ -9,7 +9,7 @@
pkgname=lmms
pkgver=1.1.3
pkgrel=1
pkgrel=2
pkgdesc='The Linux MultiMedia Studio.'
arch=('i686' 'x86_64')
url='http://lmms.sourceforge.net/'
@ -24,14 +24,22 @@ provides=('lmms-extras')
conflicts=('lmms-extras')
options=('!makeflags')
install=lmms.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/LMMS/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=('88d9e66d240b711c37315e3c9da644a1')
source=("$pkgname-$pkgver.tar.gz::https://github.com/LMMS/${pkgname}/archive/v${pkgver}.tar.gz"
"make-werrror-optional.patch")
md5sums=('88d9e66d240b711c37315e3c9da644a1'
'2c6e51b665c34fa61dc8b23e129404a9')
build() {
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i 's|lib64|lib|g' cmake/modules/DetectMachine.cmake
patch -Np1 -i ../make-werrror-optional.patch
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
cmake . -DCMAKE_INSTALL_PREFIX=/usr
make
}

View file

@ -0,0 +1,22 @@
From 9cc1a5931c34535436a2fb82e51031121b3a53d1 Mon Sep 17 00:00:00 2001
From: Lukas W <lukaswhl@gmail.com>
Date: Thu, 22 Jan 2015 12:39:20 +0100
Subject: [PATCH] Make -Werror optional
---
CMakeLists.txt | 3 ++-
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cb7407..a526df3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -358,7 +358,8 @@ CONFIGURE_FILE("${CMAKE_SOURCE_DIR}/plugins/zynaddsubfx/zynaddsubfx.rc.in" "${CM
# set compiler flags
SET(WERROR_FLAGS "-Wall -Werror=unused-function -Wno-sign-compare -Wno-strict-overflow")
-IF(NOT LMMS_BUILD_APPLE)
+OPTION(USE_WERROR "Add -werror to the build flags. Stops the build on warnings" OFF)
+IF(${USE_WERROR})
SET(WERROR_FLAGS "${WERROR_FLAGS} -Werror")
ENDIF()