mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
core/linux-mvebu: new smile.patch
This commit is contained in:
parent
ec9a053a52
commit
56b86267ed
1 changed files with 137 additions and 51 deletions
|
@ -1,72 +1,158 @@
|
|||
diff -urN a/arch/arm/boot/dts/armada-370-mirabox.dts b/arch/arm/boot/dts/armada-370-mirabox.dts
|
||||
--- a/arch/arm/boot/dts/armada-370-mirabox.dts 2013-07-12 23:18:35.979098009 -0600
|
||||
+++ b/arch/arm/boot/dts/armada-370-mirabox.dts 2013-07-13 00:33:39.920059395 -0600
|
||||
@@ -12,7 +12,7 @@
|
||||
/include/ "armada-370.dtsi"
|
||||
|
||||
/ {
|
||||
- model = "Globalscale Mirabox";
|
||||
diff -urN a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
--- a/arch/arm/boot/dts/armada-370-smileplug.dts 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts 2013-08-01 09:41:26.157246690 -0600
|
||||
@@ -0,0 +1,143 @@
|
||||
+/*
|
||||
+ * Device Tree file for Marvell SMILE Plug
|
||||
+ *
|
||||
+ * Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
+ * Gregory CLEMENT <gregory.clement@free-electrons.com>
|
||||
+ *
|
||||
+ * This file is licensed under the terms of the GNU General Public
|
||||
+ * License version 2. This program is licensed "as is" without any
|
||||
+ * warranty of any kind, whether express or implied.
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+/include/ "armada-370.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Marvell SMILE Plug";
|
||||
compatible = "globalscale,mirabox", "marvell,armada370", "marvell,armada-370-xp";
|
||||
|
||||
chosen {
|
||||
@@ -36,13 +36,8 @@
|
||||
};
|
||||
|
||||
pinctrl {
|
||||
- pwr_led_pin: pwr-led-pin {
|
||||
- marvell,pins = "mpp63";
|
||||
- marvell,function = "gpo";
|
||||
- };
|
||||
-
|
||||
- stat_led_pins: stat-led-pins {
|
||||
- marvell,pins = "mpp64", "mpp65";
|
||||
+ compatible = "marvell,smileplug", "marvell,armada370", "marvell,armada-370-xp";
|
||||
+
|
||||
+ chosen {
|
||||
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ device_type = "memory";
|
||||
+ reg = <0x00000000 0x20000000>; /* 512 MB */
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ internal-regs {
|
||||
+ serial@12000 {
|
||||
+ clock-frequency = <200000000>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ timer@20300 {
|
||||
+ clock-frequency = <600000000>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ pinctrl {
|
||||
+ smile_led_pins: smile-led-pins {
|
||||
+ marvell,pins = "mpp63", "mpp64", "mpp47", "mpp59";
|
||||
marvell,function = "gpio";
|
||||
};
|
||||
};
|
||||
@@ -50,25 +45,31 @@
|
||||
gpio_leds {
|
||||
compatible = "gpio-leds";
|
||||
pinctrl-names = "default";
|
||||
- pinctrl-0 = <&pwr_led_pin &stat_led_pins>;
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ gpio_leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&smile_led_pins>;
|
||||
|
||||
- green_pwr_led {
|
||||
- label = "mirabox:green:pwr";
|
||||
- gpios = <&gpio1 31 1>;
|
||||
- linux,default-trigger = "heartbeat";
|
||||
+
|
||||
+ red_eyes_led {
|
||||
+ label = "smileplug:red:eyes";
|
||||
+ gpios = <&gpio1 31 0>;
|
||||
+ default-state = "off";
|
||||
};
|
||||
|
||||
- blue_stat_led {
|
||||
- label = "mirabox:blue:stat";
|
||||
- gpios = <&gpio2 0 1>;
|
||||
- linux,default-trigger = "cpu0";
|
||||
+ };
|
||||
+
|
||||
+ green_eyes_led {
|
||||
+ label = "smileplug:green:eyes";
|
||||
+ gpios = <&gpio2 0 0>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
};
|
||||
|
||||
- green_stat_led {
|
||||
- label = "mirabox:green:stat";
|
||||
- gpios = <&gpio2 1 1>;
|
||||
+ };
|
||||
+
|
||||
+ red_smile_led {
|
||||
+ label = "smileplug:red:smile";
|
||||
+ gpios = <&gpio1 15 0>;
|
||||
default-state = "off";
|
||||
};
|
||||
+ default-state = "off";
|
||||
+ };
|
||||
+
|
||||
+ green_smile_led {
|
||||
+ label = "smileplug:green:smile";
|
||||
+ gpios = <&gpio1 27 0>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
+ };
|
||||
};
|
||||
|
||||
mdio {
|
||||
+ };
|
||||
+
|
||||
+ mdio {
|
||||
+ phy0: ethernet-phy@0 {
|
||||
+ reg = <0>;
|
||||
+ };
|
||||
+
|
||||
+ phy1: ethernet-phy@1 {
|
||||
+ reg = <1>;
|
||||
+ };
|
||||
+ };
|
||||
+ ethernet@70000 {
|
||||
+ status = "okay";
|
||||
+ phy = <&phy0>;
|
||||
+ phy-mode = "rgmii-id";
|
||||
+ };
|
||||
+ ethernet@74000 {
|
||||
+ status = "okay";
|
||||
+ phy = <&phy1>;
|
||||
+ phy-mode = "rgmii-id";
|
||||
+ };
|
||||
+
|
||||
+ mvsdio@d4000 {
|
||||
+ pinctrl-0 = <&sdio_pins3>;
|
||||
+ pinctrl-names = "default";
|
||||
+ status = "okay";
|
||||
+ /*
|
||||
+ * No CD or WP GPIOs: SDIO interface used for
|
||||
+ * Wifi/Bluetooth chip
|
||||
+ */
|
||||
+ broken-cd;
|
||||
+ };
|
||||
+
|
||||
+ usb@50000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ usb@51000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ i2c@11000 {
|
||||
+ status = "okay";
|
||||
+ clock-frequency = <100000>;
|
||||
+ pca9505: pca9505@25 {
|
||||
+ compatible = "nxp,pca9505";
|
||||
+ gpio-controller;
|
||||
+ #gpio-cells = <2>;
|
||||
+ reg = <0x25>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ pcie-controller {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ /* Internal mini-PCIe connector */
|
||||
+ pcie@1,0 {
|
||||
+ /* Port 0, Lane 0 */
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ /* Connected on the PCB to a USB 3.0 XHCI controller */
|
||||
+ pcie@2,0 {
|
||||
+ /* Port 1, Lane 0 */
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
diff -urN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
--- a/arch/arm/boot/dts/Makefile 2013-07-28 21:53:33.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/Makefile 2013-08-01 09:42:47.346872657 -0600
|
||||
@@ -100,6 +100,7 @@
|
||||
msm8960-cdp.dtb
|
||||
dtb-$(CONFIG_ARCH_MVEBU) += armada-370-db.dtb \
|
||||
armada-370-mirabox.dtb \
|
||||
+ armada-370-smileplug.dtb \
|
||||
armada-370-rd.dtb \
|
||||
armada-xp-db.dtb \
|
||||
armada-xp-gp.dtb \
|
||||
|
|
Loading…
Reference in a new issue