mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/texlive-bin to 2020.54586-3
This commit is contained in:
parent
5b2f936ce5
commit
56bb507428
5 changed files with 47 additions and 1570 deletions
|
@ -8,8 +8,8 @@
|
|||
# drop clisp and ffcall makedepends
|
||||
|
||||
pkgname=('texlive-bin' 'libsynctex')
|
||||
pkgver=2019.51075
|
||||
pkgrel=10
|
||||
pkgver=2020.54586
|
||||
pkgrel=3
|
||||
license=('GPL')
|
||||
arch=('x86_64')
|
||||
makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
|
||||
|
@ -17,14 +17,9 @@ makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd' 'poppler'
|
|||
'icu' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
|
||||
'perl')
|
||||
url='https://tug.org/texlive/'
|
||||
_commit=74c2495978a4a84ffae10252c0fd244f1140228e # texlive-2019.2 r51075
|
||||
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}"
|
||||
"pdftex-poppler0.76.patch" texlive-poppler-0.83.patch texlive-poppler-0.84.patch texlive-poppler-0.86.patch)
|
||||
sha256sums=('SKIP'
|
||||
'5da9f5356ca14d950c222108b431baaf5c27667460ffab9597b29ef11b426c0f'
|
||||
'ae68858b3ed60f6ef49cf29f31f601d0660908551484afe86283bc6054e9d9f8'
|
||||
'4a4ff82c85cecafc5bbf544e568d80022e9456c3223648fa8d64e699526646c5'
|
||||
'3438c1a3b7e1422ca964819b5cdf9ece086881c6448d0e2e3cfffdc1b082bb5d')
|
||||
_commit=8e5e0e89d413d09cca133c8966d1a3af8a2ac440 # svn://tug.org/texlive/trunk/Build/source@54586
|
||||
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}")
|
||||
sha256sums=('SKIP')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/texlive-source"
|
||||
|
@ -32,14 +27,9 @@ prepare() {
|
|||
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
|
||||
sed -i s/SELFAUTOPARENT/TEXMFROOT/ texk/tex4htk/t4ht.c
|
||||
|
||||
# pdftex poppler compatibility (upstream patches)
|
||||
patch -Np1 -i "$srcdir/pdftex-poppler0.76.patch"
|
||||
cp -pv texk/web2c/pdftexdir/pdftoepdf{-poppler0.76.0,}.cc
|
||||
cp -pv texk/web2c/pdftexdir/pdftosrc{-poppler0.76.0,}.cc
|
||||
|
||||
patch -p1 -i ../texlive-poppler-0.83.patch
|
||||
patch -p1 -i ../texlive-poppler-0.84.patch # Gentoo patch
|
||||
patch -p1 -i ../texlive-poppler-0.86.patch
|
||||
# pdftex poppler compatibility
|
||||
cp -pv texk/web2c/pdftexdir/pdftoepdf{-poppler0.86.0,}.cc
|
||||
cp -pv texk/web2c/pdftexdir/pdftosrc{-poppler0.83.0,}.cc
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -137,34 +127,34 @@ package_texlive-bin() {
|
|||
rm -rf "${pkgdir}"/usr/{texmf,share/texmf-dist}
|
||||
|
||||
## symlink engines by hand. texlinks has moved to texlive-core...
|
||||
mkdir -p ${pkgdir}/usr/bin
|
||||
ln -s eptex ${pkgdir}/usr/bin/platex
|
||||
ln -s euptex ${pkgdir}/usr/bin/uplatex
|
||||
ln -s luatex ${pkgdir}/usr/bin/dvilualatex
|
||||
ln -s luatex ${pkgdir}/usr/bin/dviluatex
|
||||
ln -s luatex ${pkgdir}/usr/bin/lualatex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/amstex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/cslatex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/csplain
|
||||
ln -s pdftex ${pkgdir}/usr/bin/eplain
|
||||
ln -s pdftex ${pkgdir}/usr/bin/etex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/jadetex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/latex
|
||||
ln -s tex ${pkgdir}/usr/bin/lollipop
|
||||
ln -s pdftex ${pkgdir}/usr/bin/mex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/mllatex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/mltex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfetex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfcslatex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfcsplain
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfjadetex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdflatex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfmex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/pdfxmltex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/texsis
|
||||
ln -s pdftex ${pkgdir}/usr/bin/utf8mex
|
||||
ln -s pdftex ${pkgdir}/usr/bin/xmltex
|
||||
ln -s xetex ${pkgdir}/usr/bin/xelatex
|
||||
mkdir -p "${pkgdir}"/usr/bin
|
||||
ln -s eptex "${pkgdir}"/usr/bin/platex
|
||||
ln -s euptex "${pkgdir}"/usr/bin/uplatex
|
||||
ln -s luatex "${pkgdir}"/usr/bin/dvilualatex
|
||||
ln -s luatex "${pkgdir}"/usr/bin/dviluatex
|
||||
ln -s luahbtex "${pkgdir}"/usr/bin/lualatex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/amstex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/cslatex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/csplain
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/eplain
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/etex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/jadetex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/latex
|
||||
ln -s tex "${pkgdir}"/usr/bin/lollipop
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/mex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/mllatex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/mltex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfetex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfcslatex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfcsplain
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfjadetex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdflatex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfmex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/pdfxmltex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/texsis
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/utf8mex
|
||||
ln -s pdftex "${pkgdir}"/usr/bin/xmltex
|
||||
ln -s xetex "${pkgdir}"/usr/bin/xelatex
|
||||
|
||||
#############################################################
|
||||
# remove dangling symlinks
|
||||
|
@ -196,9 +186,12 @@ autoinst
|
|||
bundledoc
|
||||
checkcites
|
||||
checklistings
|
||||
chklref
|
||||
chkweb
|
||||
cjk-gs-integrate
|
||||
cluttex
|
||||
cllualatex
|
||||
clxelatex
|
||||
context
|
||||
contextjit
|
||||
ctanbib
|
||||
|
@ -232,6 +225,7 @@ htxelatex
|
|||
htxetex
|
||||
installfont-tl
|
||||
jfmutil
|
||||
ketcindy
|
||||
kpsepath
|
||||
kpsetool
|
||||
kpsewhere
|
||||
|
@ -251,7 +245,6 @@ latexrevise
|
|||
listings-ext.sh
|
||||
ltxfileinfo
|
||||
ltximg
|
||||
lua2dox_filter
|
||||
luaotfload-tool
|
||||
luatools
|
||||
lwarpmk
|
||||
|
@ -262,26 +255,20 @@ mk4ht
|
|||
mkjobtexmf
|
||||
mkt1font
|
||||
mktexfmt
|
||||
mktexlsr
|
||||
mktexmf
|
||||
mktexpk
|
||||
mktextfm
|
||||
mptopdf
|
||||
mtxrun
|
||||
mtxrunjit
|
||||
ot2kpx
|
||||
pdf180
|
||||
pdf270
|
||||
pdf90
|
||||
pamphletangler
|
||||
pdfatfi
|
||||
pdfbook
|
||||
pdfbook2
|
||||
pdfcrop
|
||||
pdfflip
|
||||
pdfjam
|
||||
pdfjam-pocketmod
|
||||
pdfjam-slides3up
|
||||
pdfjam-slides6up
|
||||
pdfjoin
|
||||
pdflatexpicscale
|
||||
pdfnup
|
||||
pdfpun
|
||||
pdftex-quiet
|
||||
pdfxup
|
||||
pfarrei
|
||||
|
@ -310,6 +297,7 @@ texdoc
|
|||
texdoctk
|
||||
texexec
|
||||
texfot
|
||||
texhash
|
||||
texlinks
|
||||
texliveonfly
|
||||
texloganalyser
|
||||
|
@ -317,6 +305,7 @@ texmfstart
|
|||
texosquery
|
||||
texosquery-jre5
|
||||
texosquery-jre8
|
||||
texplate
|
||||
thumbpdf
|
||||
tlcockpit
|
||||
tlshell
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,46 +0,0 @@
|
|||
diff -ru texlive-source-orig/texk/web2c/pdftexdir/pdftoepdf.cc texlive-source/texk/web2c/pdftexdir/pdftoepdf.cc
|
||||
--- texlive-source-orig/texk/web2c/pdftexdir/pdftoepdf.cc 2020-01-07 22:42:03.717667766 +0000
|
||||
+++ texlive-source/texk/web2c/pdftexdir/pdftoepdf.cc 2020-01-07 22:47:42.818888622 +0000
|
||||
@@ -723,7 +723,7 @@
|
||||
#endif
|
||||
// initialize
|
||||
if (!isInit) {
|
||||
- globalParams = new GlobalParams();
|
||||
+ globalParams.reset(new GlobalParams());
|
||||
globalParams->setErrQuiet(false);
|
||||
isInit = true;
|
||||
}
|
||||
@@ -1108,6 +1108,5 @@
|
||||
delete_document(p);
|
||||
}
|
||||
// see above for globalParams
|
||||
- delete globalParams;
|
||||
}
|
||||
}
|
||||
diff -ru texlive-source-orig/texk/web2c/pdftexdir/pdftosrc.cc texlive-source/texk/web2c/pdftexdir/pdftosrc.cc
|
||||
--- texlive-source-orig/texk/web2c/pdftexdir/pdftosrc.cc 2020-01-07 22:42:03.714334387 +0000
|
||||
+++ texlive-source/texk/web2c/pdftexdir/pdftosrc.cc 2020-01-07 22:50:08.070708640 +0000
|
||||
@@ -79,7 +79,7 @@
|
||||
exit(1);
|
||||
}
|
||||
fileName = new GString(argv[1]);
|
||||
- globalParams = new GlobalParams();
|
||||
+ globalParams.reset(new GlobalParams());
|
||||
doc = new PDFDoc(fileName);
|
||||
if (!doc->isOk()) {
|
||||
fprintf(stderr, "Invalid PDF file\n");
|
||||
@@ -100,7 +100,7 @@
|
||||
if (objnum == 0) {
|
||||
srcStream = catalogDict.dictLookup("SourceObject");
|
||||
static char const_SourceFile[] = "SourceFile";
|
||||
- if (!srcStream.isStream(const_SourceFile)) {
|
||||
+ if (!srcStream.isDict(const_SourceFile)) {
|
||||
fprintf(stderr, "No SourceObject found\n");
|
||||
exit(1);
|
||||
}
|
||||
@@ -202,5 +202,4 @@
|
||||
fprintf(stderr, "Cross-reference table extracted to %s\n", outname);
|
||||
fclose(outfile);
|
||||
delete doc;
|
||||
- delete globalParams;
|
||||
}
|
|
@ -1,44 +0,0 @@
|
|||
From cf05aae9685e5c6a46b4313e7bfce49edc6f51f9 Mon Sep 17 00:00:00 2001
|
||||
From: Mikle Kolyada <zlogene@gentoo.org>
|
||||
Date: Tue, 31 Dec 2019 11:29:30 +0300
|
||||
Subject: [PATCH] poppler-0.84 compat
|
||||
|
||||
Upstream report: https://tug.org/pipermail/tex-k/2019-December/003096.html
|
||||
|
||||
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
|
||||
---
|
||||
texk/web2c/pdftexdir/utils.c | 1 -
|
||||
texk/web2c/xetexdir/XeTeX_ext.c | 3 +++
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/texk/web2c/pdftexdir/utils.c b/texk/web2c/pdftexdir/utils.c
|
||||
index c93a8781..6f866e76 100644
|
||||
--- a/texk/web2c/pdftexdir/utils.c
|
||||
+++ b/texk/web2c/pdftexdir/utils.c
|
||||
@@ -33,7 +33,6 @@ with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
#include "ptexlib.h"
|
||||
#include <png.h>
|
||||
#ifdef POPPLER_VERSION
|
||||
-#include <poppler-config.h>
|
||||
#define xpdfVersion POPPLER_VERSION
|
||||
#define xpdfString "poppler"
|
||||
#else
|
||||
diff --git a/texk/web2c/xetexdir/XeTeX_ext.c b/texk/web2c/xetexdir/XeTeX_ext.c
|
||||
index 4968ee41..0aee4ee3 100644
|
||||
--- a/texk/web2c/xetexdir/XeTeX_ext.c
|
||||
+++ b/texk/web2c/xetexdir/XeTeX_ext.c
|
||||
@@ -38,7 +38,10 @@ authorization from the copyright holders.
|
||||
|
||||
#include <w2c/config.h>
|
||||
|
||||
+#ifndef POPPLER_VERSION
|
||||
#include <poppler-config.h>
|
||||
+#endif
|
||||
+
|
||||
#include <png.h>
|
||||
#include <zlib.h>
|
||||
#include <graphite2/Font.h>
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- a/texk/web2c/pdftexdir/pdftoepdf.cc 2020-03-03 21:11:35.102711802 +0000
|
||||
+++ b/texk/web2c/pdftexdir/pdftoepdf.cc 2020-03-03 21:13:13.057420111 +0000
|
||||
@@ -757,7 +757,7 @@
|
||||
if (page_name) {
|
||||
// get page by name
|
||||
GString name(page_name);
|
||||
- LinkDest *link = pdf_doc->doc->findDest(&name);
|
||||
+ LinkDest *link = pdf_doc->doc->findDest(&name).get();
|
||||
if (link == 0 || !link->isOk())
|
||||
pdftex_fail("PDF inclusion: invalid destination <%s>", page_name);
|
||||
Ref ref = link->getPageRef();
|
Loading…
Reference in a new issue