community/java-rxtx to 2.2pre2-6.1

This commit is contained in:
Kevin Mihelich 2019-10-19 17:24:25 +00:00
parent 5acfe751bb
commit 56c8461eeb
2 changed files with 19 additions and 3 deletions

View file

@ -4,11 +4,12 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org> # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - (make)depend on java-runtime and -environmennt >=8 (fails to build with 7) # - (make)depend on java-runtime and -environmennt >=8 (fails to build with 7)
# - patch from debian to fix build on ARM # - patch from debian to fix build on ARM
# - patch from Fedora to fix undefined symbol error
pkgname=java-rxtx pkgname=java-rxtx
_pkgname=rxtx _pkgname=rxtx
pkgver=2.2pre2 pkgver=2.2pre2
pkgrel=6 pkgrel=6.1
pkgdesc="Java library for serial IO" pkgdesc="Java library for serial IO"
arch=('x86_64') arch=('x86_64')
url="http://rxtx.qbang.org/" url="http://rxtx.qbang.org/"
@ -24,14 +25,16 @@ source=(http://rxtx.qbang.org/pub/$_pkgname/$_pkgname-$pkgver.zip
rxtx-2.2-fhs_lock.patch rxtx-2.2-fhs_lock.patch
ttyACM_port.patch ttyACM_port.patch
java10.patch java10.patch
rxtx-sys_io_h_check.patch) rxtx-sys_io_h_check.patch
rxtx-2.2-minor.patch)
md5sums=('7eedb18e3f33a427e2b0e9be8ce3f94c' md5sums=('7eedb18e3f33a427e2b0e9be8ce3f94c'
'2f21ec5eb108f871815242698b6150f1' '2f21ec5eb108f871815242698b6150f1'
'1f7c43d582bfe9daea22d7f7057436da' '1f7c43d582bfe9daea22d7f7057436da'
'f4d22d263f45cd1d4db6242dd0ac78ae' 'f4d22d263f45cd1d4db6242dd0ac78ae'
'903a3fe0067d0682dd5f64483c741df6' '903a3fe0067d0682dd5f64483c741df6'
'683dd95e6e419b2b63851c08ede7ca86' '683dd95e6e419b2b63851c08ede7ca86'
'6fa4482df20625f652ecad818e92614a') '6fa4482df20625f652ecad818e92614a'
'5d2a20641b82e46b31330267d1a5c19b')
prepare() { prepare() {
cd $_pkgname-$pkgver cd $_pkgname-$pkgver
@ -54,6 +57,9 @@ prepare() {
# Fix ARM build # Fix ARM build
patch -Np1 -i ../rxtx-sys_io_h_check.patch patch -Np1 -i ../rxtx-sys_io_h_check.patch
# Fix undefined symbol error
patch -Np1 -i ../rxtx-2.2-minor.patch
rm *.m4 rm *.m4
autoreconf -fi autoreconf -fi
} }

View file

@ -0,0 +1,10 @@
--- rxtx-20100211.orig/src/SerialImp.c 2018-11-04 13:02:53.306800091 +0100
+++ rxtx-20100211.new/src/SerialImp.c 2018-11-04 13:01:39.495497644 +0100
@@ -148,6 +148,7 @@
#endif /* LIBLOCKDEV */
extern int errno;
+#include <sys/sysmacros.h>
#include "SerialImp.h"