extra/chromium to 49.0.2623.75-1

This commit is contained in:
Kevin Mihelich 2016-03-03 13:09:15 +00:00
parent 3f16700775
commit 577932c58b
3 changed files with 2 additions and 43 deletions

View file

@ -18,7 +18,7 @@
buildarch=4
pkgname=chromium
pkgver=48.0.2564.116
pkgver=49.0.2623.75
pkgrel=1
_launcher_ver=3
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
@ -40,16 +40,12 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
chromium-use-non-versioned-icu-namespace.patch
chromium-fix-print-preview-on-en_GB-locale.patch
arm-webrtc-fix.patch
chromium-arm-r0.patch
chromium-widevine.patch)
sha256sums=('6a1eb9b4c853f15eeec0a55af7ac3b41835f0fc592ba6c0a500873cb12a84d0f'
sha256sums=('a4fd4c85b12b021789d8afc33b27555396e47d9f67c8a062ee3609c4d6b582f5'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'e4192446cc0ab6a5c540599c8a149f4f2208f0014da2786ada6c9544913d7426'
'6fff45aafa31fb35a032b4e2175a341e08f9d2a9b37c5cf080c318180f558378'
'9db0f01517c52e3236ff52e8a664840542a19144a54923ae6aabea3dcfa92c52'
'df4be49770d508b772f98eda9fc5f37fa71d4c0459437e12f7f3db5892aa1611'
'4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c')
@ -72,12 +68,6 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=541273
sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
# https://codereview.chromium.org/1505763002
patch -Np1 -i ../chromium-use-non-versioned-icu-namespace.patch
# https://code.google.com/p/chromium/issues/detail?id=480415
patch -Np1 -i ../chromium-fix-print-preview-on-en_GB-locale.patch
# Enable support for the Widevine CDM plugin
# libwidevinecdm.so is not included, but can be copied over from Chrome
# (Version string doesn't seem to matter so let's go with "Pinkie Pie")

View file

@ -1,17 +0,0 @@
Index: chrome/browser/ui/webui/print_preview/print_preview_handler.cc
diff --git a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
index 6cfd861387c9f8b145fb33472b10025537986213..c936a9c1dadb13c00418e8ae79a8a1987c1d36cd 100644
--- a/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
+++ b/chrome/browser/ui/webui/print_preview/print_preview_handler.cc
@@ -1222,7 +1222,10 @@ void PrintPreviewHandler::GetNumberFormatAndMeasurementSystem(
UErrorCode errorCode = U_ZERO_ERROR;
const char* locale = g_browser_process->GetApplicationLocale().c_str();
UMeasurementSystem system = ulocdata_getMeasurementSystem(locale, &errorCode);
- if (errorCode > U_ZERO_ERROR || system == UMS_LIMIT)
+ // On error, assume the units are SI.
+ // Since the only measurement units print preview's WebUI cares about are
+ // those for measuring distance, assume anything non-US is SI.
+ if (errorCode > U_ZERO_ERROR || system != UMS_US)
system = UMS_SI;
// Getting the number formatting based on the locale and writing to

View file

@ -1,14 +0,0 @@
Index: components/autofill/core/common/autofill_l10n_util.cc
diff --git a/components/autofill/core/common/autofill_l10n_util.cc b/components/autofill/core/common/autofill_l10n_util.cc
index 2ee517faf82b1feb224f83ae533092ae3b31f5af..c29b0a299b7215895874adf9241e4705247161ab 100644
--- a/components/autofill/core/common/autofill_l10n_util.cc
+++ b/components/autofill/core/common/autofill_l10n_util.cc
@@ -22,7 +22,7 @@ CaseInsensitiveCompare::CaseInsensitiveCompare(const icu::Locale& locale) {
// library. This could be due to a device-specific issue (has been seen in
// the wild on Android devices). In the failure case, |collator_| will be
// null. See http://crbug.com/558625.
- icu_54::UnicodeString name;
+ icu::UnicodeString name;
std::string locale_name;
locale.getDisplayName(name).toUTF8String(locale_name);
LOG(ERROR) << "Failed to initialize the ICU Collator for "