community/consul to 1.2.0-1

This commit is contained in:
Kevin Mihelich 2018-06-26 12:47:02 +00:00
parent c1086208b7
commit 5856c973f8
3 changed files with 15 additions and 55 deletions

View file

@ -1,27 +1,25 @@
From 3f7dd8f6fa2a9e6bd1b57830df24fb83f6b4a951 Mon Sep 17 00:00:00 2001
From ea2da7ffd718d4b9d8448fdac97ea5b387ab72d9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 23 May 2018 19:47:32 -0600
Date: Tue, 26 Jun 2018 06:43:01 -0600
Subject: [PATCH] fix ARM build
---
GNUmakefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
GNUmakefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/GNUmakefile b/GNUmakefile
index 124e9cb4..dd7ef190 100644
index 1a89de16..e4e1d97d 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -57,8 +57,8 @@ changelogfmt:
@@ -119,7 +119,7 @@ changelogfmt:
# linux builds a linux package independent of the source platform
linux:
- mkdir -p pkg/linux_amd64/
- GOOS=linux GOARCH=amd64 go build -buildmode=pie -ldflags '$(GOLDFLAGS)' -tags '$(GOTAGS)' -o pkg/linux_amd64/consul
+ mkdir -p pkg/$(GOOS)_$(GOARCH)
+ GOOS=linux GOARCH=$(GOARCH) go build -buildmode=pie -ldflags '$(GOLDFLAGS)' -tags '$(GOTAGS)' -o pkg/$(GOOS)_$(GOARCH)/consul
- @$(SHELL) $(CURDIR)/build-support/scripts/build-local.sh -o linux -a amd64
+ @$(SHELL) $(CURDIR)/build-support/scripts/build-local.sh -o linux -a $(GOARCH)
# dist builds binaries for all platforms and packages them for distribution
dist:
--
2.17.0
2.17.1

View file

@ -4,11 +4,10 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix ARM build
# - use GOARCH in packaging path
pkgname=consul
pkgver=1.1.0
pkgrel=2
pkgver=1.2.0
pkgrel=1
pkgdesc="A tool for service discovery, monitoring and configuration."
arch=('x86_64')
_gocli_commit='65fcae5817c8600da98ada9d7edf26dd1a84837b' # HEAD
@ -23,20 +22,18 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/consul/archive/v$
'consul.sysusers'
'example.json'
'disable-broken-api-test.patch'
'force-pie-build.patch'
'fix-build-version-info.patch'
'0001-fix-ARM-build.patch')
install=consul.install
sha512sums=('80c16a42fc58930234cb277bfdd21c3f1d9f7fe1cf2fea6284056a47f602a40a15ddd447779e83fc5b42502ca8a507a819f5ad7d11689c0bcbb0da739b217721'
sha512sums=('1c018a5f35164a899a086ccdae94cb5e6e2a490e4c788d65b0026dbf448950d0c1038b2d61cb10f5e8c9ad22a1affad64dd4a7086b59dffd115d40aa7b3d0cce'
'SKIP'
'c70b9d1556f6c7ecb2e915ab685f289cef0e31198bd2e50c74a0483bbfb387beec67334f539a90adbf68b61b07946e98b300ab8a8e26e53b35f4ab4894adeb04'
'ec5a800529a297c709fa383c094ecf106351cf0f8ac7b613b972d415d77fe001088902d7ab805e63e78a8e6360323fec1b795db5a4446df1e21b9b4ed31e7079'
'ef872aedb2bc022a29292b7972a792b22e684c1ccb904a2b2cfec6d8966c28fb19be1452ce060821c419f1b646b236ba2e783175595e4bb6926d164c27a15c87'
'c4292b8f56ee955ed7385a49843fd90d6434029891b3e1e724cb2fc841514c06e2554a26d3937c114371b18c2168c4e64319eb2cbd726ee8b35870df19089348'
'ad5b5ea1fd4ec443c98a89da9fb581d32894c4583dec3707ce9096ed45706bc800f8eb20e5a0c68f6de437d228e09a97bad5815b5bba9b18ae339bcf9a42f8f7'
'2c7323b889e9a040f8e2732aa192fbef87bb5eb81072a06a48f536cbdd93d7d219ea17b61e89dfebf915e85861cbb60dd889cb03a14e0a8197b081595e2a2783'
'e2fa5674343cd26e17bf08d0a4f2bd923870617511aed49fdc98aaa88a7590916b67e886301385988fdea93747f380f6a7322d1eac3ba14cf81b4baff452cb12'
'dc85ba1cab2f77dd9b7cf0032866ee7a09df1644f888656ea74d1af2ec03bf487837c2e05a36cd9248712938f398bc31142d9e2dde7e53a4fa117d48d9c5b656')
'6709e51ff57fbe8118e7c9b38c99ef096a62d0c88ac2694e8c86065052cd2600f65dd9ac7f4a7e60712c26d15355f938cd9d98684955f4a02b2d5adfe1c2c04e'
'b9be57fc21ffccd5083ceccd96937d8d1e83b9e411b0ad1c4b79daad74aa11746afa360b937724cd6d559a9d679774e0abbaefe519bca6ad0b94462c57159f58')
prepare() {
export GOPATH="${srcdir}"
@ -49,9 +46,6 @@ prepare() {
cd "src/github.com/hashicorp/${pkgname}"
# force pie build
patch -p1 -N -l -i "${srcdir}/force-pie-build.patch"
# use proper release build version string (w/o '-dev' suffix)
patch -p1 -N -l -i "${srcdir}/fix-build-version-info.patch"
@ -93,7 +87,7 @@ package() {
install -D -m644 "${srcdir}/consul.default" "${pkgdir}/etc/default/consul"
install -D -m640 -o 0 -g 208 "${srcdir}/example.json" "${pkgdir}/etc/consul.d/example.json"
install -Dm755 pkg/linux_$(go env GOARCH)/consul "${pkgdir}/usr/bin/consul"
install -Dm755 "bin/consul" "${pkgdir}/usr/bin/consul"
install -Dm644 "${srcdir}/consul.service" "${pkgdir}/usr/lib/systemd/system/consul.service"
install -Dm644 "${srcdir}/consul.sysusers" "${pkgdir}/usr/lib/sysusers.d/consul.conf"

View file

@ -1,32 +0,0 @@
--- a/version/version.go 2018-05-11 20:57:42.000000000 +0200
+++ b/version/version.go 2018-05-22 14:05:53.639672108 +0200
@@ -1,7 +1,6 @@
package version
import (
- "fmt"
"strings"
)
@@ -27,21 +26,6 @@
// for displaying to humans.
func GetHumanVersion() string {
version := Version
- if GitDescribe != "" {
- version = GitDescribe
- }
-
- release := VersionPrerelease
- if GitDescribe == "" && release == "" {
- release = "dev"
- }
- if release != "" {
- version += fmt.Sprintf("-%s", release)
- if GitCommit != "" {
- version += fmt.Sprintf(" (%s)", GitCommit)
- }
- }
-
// Strip off any single quotes added by the git information.
return strings.Replace(version, "'", "", -1)
}