mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-odroid to 2016.07-1
This commit is contained in:
parent
f26f6e4cd2
commit
586e583ce2
3 changed files with 23 additions and 26 deletions
|
@ -1,14 +1,14 @@
|
|||
From 50713702485708abcf718cd885825baa8a4a48c9 Mon Sep 17 00:00:00 2001
|
||||
From def7823985d4a7b7670c1ed6eea8a28482ae4642 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 22 Aug 2014 17:51:41 -0600
|
||||
Subject: [PATCH 1/2] arch linux arm modifications
|
||||
|
||||
---
|
||||
include/configs/odroid.h | 174 ++++++++++++++++++-----------------------------
|
||||
1 file changed, 65 insertions(+), 109 deletions(-)
|
||||
include/configs/odroid.h | 173 ++++++++++++++++++-----------------------------
|
||||
1 file changed, 64 insertions(+), 109 deletions(-)
|
||||
|
||||
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
|
||||
index 4c85e85..8ae43e8 100644
|
||||
index 12b7dc5..306ff07 100644
|
||||
--- a/include/configs/odroid.h
|
||||
+++ b/include/configs/odroid.h
|
||||
@@ -14,6 +14,7 @@
|
||||
|
@ -27,21 +27,18 @@ index 4c85e85..8ae43e8 100644
|
|||
|
||||
#include <linux/sizes.h>
|
||||
|
||||
@@ -47,11 +49,10 @@
|
||||
@@ -46,10 +48,6 @@
|
||||
#define CONFIG_SYS_CONSOLE_INFO_QUIET
|
||||
#define CONFIG_SYS_CONSOLE_IS_IN_ENV
|
||||
|
||||
#define CONFIG_CMD_BOOTZ
|
||||
+#define CONFIG_CMD_FS_GENERIC
|
||||
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||
#define CONFIG_FIT
|
||||
#define CONFIG_FIT_VERBOSE
|
||||
-#define CONFIG_BOOTARGS "Please use defined boot"
|
||||
-#define CONFIG_BOOTCOMMAND "run autoboot"
|
||||
-#define CONFIG_DEFAULT_CONSOLE "console=ttySAC1,115200n8\0"
|
||||
|
||||
-
|
||||
#define CONFIG_SYS_INIT_SP_ADDR (CONFIG_SYS_LOAD_ADDR \
|
||||
- GENERATED_GBL_DATA_SIZE)
|
||||
@@ -64,35 +65,6 @@
|
||||
|
||||
@@ -61,34 +59,7 @@
|
||||
#define CONFIG_ENV_OFFSET (SZ_1K * 1280) /* 1.25 MiB offset */
|
||||
#define CONFIG_ENV_OVERWRITE
|
||||
|
||||
|
@ -73,11 +70,11 @@ index 4c85e85..8ae43e8 100644
|
|||
- "bl1 raw 0x1 0x1e;" \
|
||||
- "bl2 raw 0x1f 0x1d;" \
|
||||
- "tzsw raw 0x83f 0x138\0"
|
||||
-
|
||||
+#define CONFIG_SUPPORT_RAW_INITRD
|
||||
|
||||
/*
|
||||
* Bootable media layout:
|
||||
* dev: SD eMMC(part boot)
|
||||
@@ -101,85 +73,69 @@
|
||||
@@ -98,85 +69,69 @@
|
||||
* UBOOT 63 62
|
||||
* TZSW 2111 2110
|
||||
* ENV 2560 2560(part user)
|
||||
|
@ -223,7 +220,7 @@ index 4c85e85..8ae43e8 100644
|
|||
+ "run mmcboot;"
|
||||
|
||||
/* I2C */
|
||||
#define CONFIG_CMD_I2C
|
||||
#define CONFIG_SYS_I2C_S3C24X0
|
||||
--
|
||||
2.6.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 0eaca48880b25df1a04dff34e7d5740e1df188f9 Mon Sep 17 00:00:00 2001
|
||||
From fb927d726489ef96f4af524870e74d32ee846140 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 6 Feb 2015 05:40:56 -0700
|
||||
Subject: [PATCH 2/2] odroid-x support
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH 2/2] odroid-x support
|
|||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/board/samsung/odroid/odroid.c b/board/samsung/odroid/odroid.c
|
||||
index 32155f1..f6fa7b7 100644
|
||||
index b4cb332..d025d06 100644
|
||||
--- a/board/samsung/odroid/odroid.c
|
||||
+++ b/board/samsung/odroid/odroid.c
|
||||
@@ -64,7 +64,7 @@ void set_board_type(void)
|
||||
@@ -57,7 +57,7 @@ void set_board_type(void)
|
||||
|
||||
const char *get_board_type(void)
|
||||
{
|
||||
|
@ -22,7 +22,7 @@ index 32155f1..f6fa7b7 100644
|
|||
return board_type[gd->board_type];
|
||||
}
|
||||
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
|
||||
index 8ae43e8..9ed9e5e 100644
|
||||
index 306ff07..460c796 100644
|
||||
--- a/include/configs/odroid.h
|
||||
+++ b/include/configs/odroid.h
|
||||
@@ -23,7 +23,7 @@
|
||||
|
@ -35,5 +35,5 @@ index 8ae43e8..9ed9e5e 100644
|
|||
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
|
||||
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
|
||||
--
|
||||
2.6.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -5,7 +5,7 @@ buildarch=4
|
|||
|
||||
pkgbase=uboot-odroid
|
||||
pkgname=('uboot-odroid' 'uboot-odroid-x')
|
||||
pkgver=2016.03
|
||||
pkgver=2016.07
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url='http://www.denx.de/wiki/U-Boot/WebHome'
|
||||
|
@ -22,13 +22,13 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
|||
'0001-arch-linux-arm-modifications.patch'
|
||||
'0002-odroid-x-support.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('973c1d896be751321cc3aafa564f64b2'
|
||||
md5sums=('425a3fa610a7d972e5092a0e92276c70'
|
||||
'3ab6d3cc2061bc2590d60320254017c6'
|
||||
'841502de02bd42f2898e36c89c260b0f'
|
||||
'c38faafa02a6a1ae834457f378c82113'
|
||||
'17909ae93a0ae7b4c155234040105035'
|
||||
'a54a0045f6c2021cf91bc9fc9aa4566c'
|
||||
'cb47c5faedc37609731e4bc2f23b5ce2'
|
||||
'afe3b7a5b224e257b2ce7f5af03daa8d'
|
||||
'f4f8c8b6217e6646b9659de642264a3f'
|
||||
'fb5c9ea3108afa298087549f0453b00f')
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue