mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/gpgme to 1.23.0-1
This commit is contained in:
parent
623a1b9c52
commit
588ebfb441
4 changed files with 51 additions and 85 deletions
47
core/gpgme/.SRCINFO
Normal file
47
core/gpgme/.SRCINFO
Normal file
|
@ -0,0 +1,47 @@
|
|||
pkgbase = gpgme
|
||||
pkgdesc = A C wrapper library for GnuPG
|
||||
pkgver = 1.23.0
|
||||
pkgrel = 1
|
||||
url = https://www.gnupg.org/related_software/gpgme/
|
||||
arch = x86_64
|
||||
license = LGPL
|
||||
makedepends = gnupg
|
||||
makedepends = libgpg-error
|
||||
makedepends = python
|
||||
makedepends = python-build
|
||||
makedepends = python-installer
|
||||
makedepends = python-setuptools
|
||||
makedepends = python-wheel
|
||||
makedepends = qt5-base
|
||||
makedepends = qt6-base
|
||||
makedepends = swig
|
||||
source = https://www.gnupg.org/ftp/gcrypt/gpgme/gpgme-1.23.0.tar.bz2
|
||||
source = https://www.gnupg.org/ftp/gcrypt/gpgme/gpgme-1.23.0.tar.bz2.sig
|
||||
validpgpkeys = 6DAA6E64A76D2840571B4902528897B826403ADA
|
||||
validpgpkeys = AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD
|
||||
sha256sums = 043e2efe18b4ad22b96d434dde763fbed32cf8d6c220dc69df0d0ffb9dc66fc6
|
||||
sha256sums = SKIP
|
||||
|
||||
pkgname = gpgme
|
||||
depends = libgpg-error
|
||||
depends = gnupg>=2
|
||||
provides = libgpgme.so
|
||||
provides = libgpgmepp.so
|
||||
options = !emptydirs
|
||||
|
||||
pkgname = qgpgme-qt5
|
||||
pkgdesc = Qt5 bindings for GPGme
|
||||
depends = gpgme
|
||||
depends = qt5-base
|
||||
provides = qgpgme
|
||||
replaces = qgpgme
|
||||
|
||||
pkgname = qgpgme-qt6
|
||||
pkgdesc = Qt6 bindings for GPGme
|
||||
depends = gpgme
|
||||
depends = qt6-base
|
||||
|
||||
pkgname = python-gpgme
|
||||
pkgdesc = Python bindings for GPGme
|
||||
depends = gpgme
|
||||
depends = python
|
|
@ -1,37 +0,0 @@
|
|||
From d23528cadf4284f508bc4ba05e1b5c14b46bd354 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
|
||||
Date: Mon, 21 Aug 2023 21:08:01 +0200
|
||||
Subject: qt,tests: Fix build in source directory
|
||||
|
||||
* lang/qt/tests/Makefile.am (AM_CPPFLAGS): Include Qt binding sources
|
||||
before C++ binding sources and C sources.
|
||||
--
|
||||
|
||||
This fixes the problem that the debug.h in the C sources was found
|
||||
before the one in the Qt bindings.
|
||||
|
||||
GnuPG-bug-id: 6673
|
||||
---
|
||||
lang/qt/tests/Makefile.am | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lang/qt/tests/Makefile.am b/lang/qt/tests/Makefile.am
|
||||
index 32ad6466..aedd3264 100644
|
||||
--- a/lang/qt/tests/Makefile.am
|
||||
+++ b/lang/qt/tests/Makefile.am
|
||||
@@ -51,10 +51,10 @@ LDADD = ../../cpp/src/libgpgmepp.la ../src/libqgpgme.la \
|
||||
../../../src/libgpgme.la @GPGME_QT5_LIBS@ @GPG_ERROR_LIBS@ \
|
||||
@GPGME_QT5TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
|
||||
|
||||
-AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
|
||||
+ -I$(top_builddir)/src \
|
||||
@GPG_ERROR_CFLAGS@ @GPGME_QT5_CFLAGS@ @GPG_ERROR_CFLAGS@ \
|
||||
@LIBASSUAN_CFLAGS@ @GPGME_QT5TEST_CFLAGS@ -DBUILDING_QGPGME \
|
||||
- -I$(top_srcdir)/lang/qt/src \
|
||||
-DTOP_SRCDIR="$(top_srcdir)"
|
||||
endif
|
||||
if WANT_QT6
|
||||
--
|
||||
2.42.0
|
||||
|
|
@ -1,37 +0,0 @@
|
|||
From 2d570b3f80b306ccdbc49b4a8e71c4945486fd1c Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hesse <mail@eworm.de>
|
||||
Date: Mon, 21 Aug 2023 23:53:47 +0200
|
||||
Subject: [PATCH 1/1] qt,tests: Fix build in source directory, part 2
|
||||
|
||||
* lang/qt/tests/Makefile.am (AM_CPPFLAGS): Include Qt binding sources
|
||||
before C++ binding sources and C sources.
|
||||
|
||||
This fixes the problem that the debug.h in the C sources was found
|
||||
before the one in the Qt bindings.
|
||||
|
||||
Commit d23528cadf4284f508bc4ba05e1b5c14b46bd354 fixed it for Qt5, we
|
||||
need Qt6 as well.
|
||||
---
|
||||
lang/qt/tests/Makefile.am | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lang/qt/tests/Makefile.am b/lang/qt/tests/Makefile.am
|
||||
index aedd3264..615daf6d 100644
|
||||
--- a/lang/qt/tests/Makefile.am
|
||||
+++ b/lang/qt/tests/Makefile.am
|
||||
@@ -62,10 +62,10 @@ LDADD = ../../cpp/src/libgpgmepp.la ../src/libqgpgmeqt6.la \
|
||||
../../../src/libgpgme.la @GPGME_QT6_LIBS@ @GPG_ERROR_LIBS@ \
|
||||
@GPGME_QT6TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
|
||||
|
||||
-AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
|
||||
+ -I$(top_builddir)/src \
|
||||
@GPG_ERROR_CFLAGS@ @GPGME_QT6_CFLAGS@ @GPG_ERROR_CFLAGS@ \
|
||||
@LIBASSUAN_CFLAGS@ @GPGME_QT6TEST_CFLAGS@ -DBUILDING_QGPGME \
|
||||
- -I$(top_srcdir)/lang/qt/src \
|
||||
-DTOP_SRCDIR="$(top_srcdir)"
|
||||
endif
|
||||
|
||||
--
|
||||
2.42.0
|
||||
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgbase=gpgme
|
||||
pkgname=(gpgme qgpgme-qt5 qgpgme-qt6 python-gpgme)
|
||||
pkgver=1.22.0
|
||||
pkgver=1.23.0
|
||||
pkgrel=1
|
||||
pkgdesc='A C wrapper library for GnuPG'
|
||||
arch=('x86_64')
|
||||
|
@ -27,20 +27,13 @@ makedepends=(
|
|||
)
|
||||
validpgpkeys=('6DAA6E64A76D2840571B4902528897B826403ADA' # Werner Koch (dist signing 2020)
|
||||
'AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD') # Niibe Yutaka (GnuPG Release Key)
|
||||
source=("https://www.gnupg.org/ftp/gcrypt/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2"{,.sig}
|
||||
'0001-qt-tests-Fix-build-in-source-directory.patch'
|
||||
'0002-qt-tests-Fix-build-in-source-directory-part-2.patch')
|
||||
sha256sums=('9551e37081ad3bde81018a0d24f245c3f8206990549598fb31a97a68380a7b71'
|
||||
'SKIP'
|
||||
'a0d3d02c46e7053cfc887271fea7d38f64439b9f67b14eaacec3e602de5dccd4'
|
||||
'eaeae9b9818dd94c08954bb5c3535f43a80583f9c97d5e7f8ca62a104deeebe9')
|
||||
source=("https://www.gnupg.org/ftp/gcrypt/${pkgbase}/${pkgbase}-${pkgver}.tar.bz2"{,.sig})
|
||||
sha256sums=('043e2efe18b4ad22b96d434dde763fbed32cf8d6c220dc69df0d0ffb9dc66fc6'
|
||||
'SKIP')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgbase}-${pkgver}/
|
||||
|
||||
patch -Np1 < ../0001-qt-tests-Fix-build-in-source-directory.patch
|
||||
patch -Np1 < ../0002-qt-tests-Fix-build-in-source-directory-part-2.patch
|
||||
|
||||
sed -i 's/-unknown//' autogen.sh
|
||||
autoreconf -fi
|
||||
|
||||
|
|
Loading…
Reference in a new issue