mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/libreoffice-still to 6.0.6-6
This commit is contained in:
parent
3e97c0b95e
commit
58abf30eba
2 changed files with 174 additions and 1 deletions
|
@ -20,7 +20,7 @@ pkgbase=libreoffice-still
|
|||
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
|
||||
_LOver=6.0.6.2
|
||||
pkgver=6.0.6
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="http://www.libreoffice.org/"
|
||||
|
@ -65,6 +65,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
poppler-0.70.patch
|
||||
libreoffice-poppler-0.71.patch
|
||||
emfio.patch
|
||||
libreoffice-still.sh libreoffice-still.csh)
|
||||
noextract=(boost_1_65_1.tar.bz2
|
||||
|
@ -109,6 +110,7 @@ sha256sums=('f1666430abf616a3813e4c886b51f157366f592102ae0e874abc17f3d58c6a8e'
|
|||
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
|
||||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
|
||||
'ffe1698d3db3320a9213a459e7619f4962c9792a8b256ea0fe2b7e0af1df430a'
|
||||
'8b4815788be087940750b775690b5890c4cf9e121f11006a72ccab834f212abb'
|
||||
'52e90a5a3d8d5b626caa51675b601aba508463c2b9caa98d07cfa35220fc0b22'
|
||||
'531de4133cb6ff5c841e4251fdafe69521ccd195f5933eb8c113291d3eff183a')
|
||||
|
@ -148,6 +150,8 @@ prepare() {
|
|||
|
||||
# fix build with poppler 0.70
|
||||
patch -Np1 -i ../poppler-0.70.patch
|
||||
# fix build with poppler 0.71
|
||||
patch -p1 -i ../libreoffice-poppler-0.71.patch
|
||||
|
||||
#use the CFLAGS but remove the LibO overridden ones
|
||||
for i in $CFLAGS; do
|
||||
|
|
169
extra/libreoffice-still/libreoffice-poppler-0.71.patch
Normal file
169
extra/libreoffice-still/libreoffice-poppler-0.71.patch
Normal file
|
@ -0,0 +1,169 @@
|
|||
diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.cxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
||||
--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.cxx 2018-11-01 20:43:55.802520387 +0000
|
||||
+++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2018-11-01 20:44:33.399286879 +0000
|
||||
@@ -514,7 +514,7 @@
|
||||
PDFOutDev::PDFOutDev( PDFDoc* pDoc ) :
|
||||
m_pDoc( pDoc ),
|
||||
m_aFontMap(),
|
||||
- m_pUtf8Map( new UnicodeMap("UTF-8", gTrue, &mapUTF8) ),
|
||||
+ m_pUtf8Map( new UnicodeMap("UTF-8", true, &mapUTF8) ),
|
||||
m_bSkipImages(false)
|
||||
{
|
||||
}
|
||||
@@ -943,11 +943,11 @@
|
||||
}
|
||||
|
||||
void PDFOutDev::drawImageMask(GfxState* pState, Object*, Stream* str,
|
||||
- int width, int height, GBool invert,
|
||||
+ int width, int height, bool invert,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool /*interpolate*/,
|
||||
+ bool /*interpolate*/,
|
||||
#endif
|
||||
- GBool /*inlineImg*/ )
|
||||
+ bool /*inlineImg*/ )
|
||||
{
|
||||
if (m_bSkipImages)
|
||||
return;
|
||||
@@ -976,9 +976,9 @@
|
||||
void PDFOutDev::drawImage(GfxState*, Object*, Stream* str,
|
||||
int width, int height, GfxImageColorMap* colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool /*interpolate*/,
|
||||
+ bool /*interpolate*/,
|
||||
#endif
|
||||
- int* maskColors, GBool /*inlineImg*/ )
|
||||
+ int* maskColors, bool /*inlineImg*/ )
|
||||
{
|
||||
if (m_bSkipImages)
|
||||
return;
|
||||
@@ -1027,13 +1027,13 @@
|
||||
int width, int height,
|
||||
GfxImageColorMap* colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool /*interpolate*/,
|
||||
+ bool /*interpolate*/,
|
||||
#endif
|
||||
Stream* maskStr,
|
||||
int maskWidth, int maskHeight,
|
||||
- GBool maskInvert
|
||||
+ bool maskInvert
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- , GBool /*maskInterpolate*/
|
||||
+ , bool /*maskInterpolate*/
|
||||
#endif
|
||||
)
|
||||
{
|
||||
@@ -1049,13 +1049,13 @@
|
||||
int width, int height,
|
||||
GfxImageColorMap* colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool /*interpolate*/,
|
||||
+ bool /*interpolate*/,
|
||||
#endif
|
||||
Stream* maskStr,
|
||||
int maskWidth, int maskHeight,
|
||||
GfxImageColorMap* maskColorMap
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- , GBool /*maskInterpolate*/
|
||||
+ , bool /*maskInterpolate*/
|
||||
#endif
|
||||
)
|
||||
{
|
||||
diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.hxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
||||
--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/pdfioutdev_gpl.hxx 2018-11-01 20:43:55.802520387 +0000
|
||||
+++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2018-11-01 20:44:33.402620221 +0000
|
||||
@@ -151,17 +151,17 @@
|
||||
|
||||
// Does this device use upside-down coordinates?
|
||||
// (Upside-down means (0,0) is the top left corner of the page.)
|
||||
- virtual GBool upsideDown() override { return gTrue; }
|
||||
+ virtual bool upsideDown() override { return true; }
|
||||
|
||||
// Does this device use drawChar() or drawString()?
|
||||
- virtual GBool useDrawChar() override { return gTrue; }
|
||||
+ virtual bool useDrawChar() override { return true; }
|
||||
|
||||
// Does this device use beginType3Char/endType3Char? Otherwise,
|
||||
// text in Type 3 fonts will be drawn with drawChar/drawString.
|
||||
- virtual GBool interpretType3Chars() override { return gFalse; }
|
||||
+ virtual bool interpretType3Chars() override { return false; }
|
||||
|
||||
// Does this device need non-text content?
|
||||
- virtual GBool needNonText() override { return gTrue; }
|
||||
+ virtual bool needNonText() override { return true; }
|
||||
|
||||
//----- initialization and control
|
||||
|
||||
@@ -237,40 +237,40 @@
|
||||
|
||||
//----- image drawing
|
||||
virtual void drawImageMask(GfxState *state, Object *ref, Stream *str,
|
||||
- int width, int height, GBool invert,
|
||||
+ int width, int height, bool invert,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool interpolate,
|
||||
+ bool interpolate,
|
||||
#endif
|
||||
- GBool inlineImg) override;
|
||||
+ bool inlineImg) override;
|
||||
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
|
||||
int width, int height, GfxImageColorMap *colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool interpolate,
|
||||
+ bool interpolate,
|
||||
#endif
|
||||
- int *maskColors, GBool inlineImg) override;
|
||||
+ int *maskColors, bool inlineImg) override;
|
||||
virtual void drawMaskedImage(GfxState *state, Object *ref, Stream *str,
|
||||
int width, int height,
|
||||
GfxImageColorMap *colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool interpolate,
|
||||
+ bool interpolate,
|
||||
#endif
|
||||
Stream *maskStr, int maskWidth, int maskHeight,
|
||||
- GBool maskInvert
|
||||
+ bool maskInvert
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- , GBool maskInterpolate
|
||||
+ , bool maskInterpolate
|
||||
#endif
|
||||
) override;
|
||||
virtual void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,
|
||||
int width, int height,
|
||||
GfxImageColorMap *colorMap,
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- GBool interpolate,
|
||||
+ bool interpolate,
|
||||
#endif
|
||||
Stream *maskStr,
|
||||
int maskWidth, int maskHeight,
|
||||
GfxImageColorMap *maskColorMap
|
||||
#if POPPLER_CHECK_VERSION(0, 12, 0)
|
||||
- , GBool maskInterpolate
|
||||
+ , bool maskInterpolate
|
||||
#endif
|
||||
) override;
|
||||
|
||||
diff -ru libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/wrapper_gpl.cxx libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
|
||||
--- libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper.orig/wrapper_gpl.cxx 2018-11-01 20:43:55.802520387 +0000
|
||||
+++ libreoffice-6.1.2.1/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx 2018-11-01 20:44:33.402620221 +0000
|
||||
@@ -69,7 +69,7 @@
|
||||
|
||||
// read config file
|
||||
globalParams = new GlobalParams();
|
||||
- globalParams->setErrQuiet(gTrue);
|
||||
+ globalParams->setErrQuiet(true);
|
||||
#if defined(_MSC_VER)
|
||||
globalParams->setupBaseFonts(nullptr);
|
||||
#endif
|
||||
@@ -143,7 +143,7 @@
|
||||
i,
|
||||
PDFI_OUTDEV_RESOLUTION,
|
||||
PDFI_OUTDEV_RESOLUTION,
|
||||
- 0, gTrue, gTrue, gTrue);
|
||||
+ 0, true, true, true);
|
||||
rDoc.processLinks(&aOutDev, i);
|
||||
}
|
||||
|
Loading…
Reference in a new issue