diff --git a/core/initscripts/PKGBUILD b/core/initscripts/PKGBUILD
index ce687b758..fad144128 100644
--- a/core/initscripts/PKGBUILD
+++ b/core/initscripts/PKGBUILD
@@ -8,10 +8,9 @@
 #  - patch to adjust naming to ALARM, fix remounting root, turn off LEDs on shutdown
 
 plugrel=1
-noautobuild=1
 
 pkgname=initscripts
-pkgver=2012.01.3
+pkgver=2012.05.1
 pkgrel=1
 pkgdesc="System initialization/bootup scripts"
 arch=('any')
@@ -19,7 +18,7 @@ url="http://www.archlinux.org"
 license=('GPL2')
 groups=('base')
 backup=(etc/inittab etc/rc.conf etc/rc.local etc/rc.local.shutdown etc/conf.d/wireless)
-depends=('glibc' 'bash' 'grep' 'coreutils' 'udev>=174' 'iproute2'
+depends=('glibc' 'bash' 'grep' 'coreutils' 'udev>=182' 'iproute2'
          'ncurses' 'kbd' 'findutils' 'sysvinit')
 optdepends=('bridge-utils: Network bridging support'
             'dhcpcd: DHCP network configuration'
@@ -31,9 +30,9 @@ source=("ftp://ftp.archlinux.org/other/initscripts/${pkgname}-${pkgver}.tar.xz"
         'wireless.conf.d'
         'alarm.patch'
         'rc.conf')
-md5sums=('3d4e02ddefb0c7e8ae7000161ae89448'
+md5sums=('13cff6a6638f12351892d7085d7e6fb9'
          '027576534885b8d5dded9be546057b12'
-         '7593a88cdc36d92bd286687ca4340eb1'
+         'e77890fd546ca599a2bd129b040c0b05'
          'c618e099f522f861e08a475f8960a6c2')
 
 package() {
diff --git a/core/initscripts/alarm.patch b/core/initscripts/alarm.patch
index 4b4d7ccf0..fa2ca8715 100644
--- a/core/initscripts/alarm.patch
+++ b/core/initscripts/alarm.patch
@@ -1,6 +1,6 @@
 diff -urN a/inittab b/inittab
---- a/inittab	2012-01-18 16:02:04.000000000 -0700
-+++ b/inittab	2012-01-21 14:44:00.000000000 -0700
+--- a/inittab	2012-05-05 08:25:45.000000000 -0600
++++ b/inittab	2012-05-05 11:55:08.000000000 -0600
 @@ -24,12 +24,13 @@
  su:S:wait:/sbin/sulogin -p
  
@@ -20,8 +20,8 @@ diff -urN a/inittab b/inittab
  # Serial Virtual Console for KVM and others VMs
  #s0:2345:respawn:/sbin/agetty -8 -s 9600 ttyS0 linux
 diff -urN a/rc.shutdown b/rc.shutdown
---- a/rc.shutdown	2012-01-18 16:02:04.000000000 -0700
-+++ b/rc.shutdown	2012-01-21 14:44:00.000000000 -0700
+--- a/rc.shutdown	2012-05-05 08:25:45.000000000 -0600
++++ b/rc.shutdown	2012-05-05 11:55:08.000000000 -0600
 @@ -87,6 +87,10 @@
  
  run_hook shutdown_poweroff
@@ -34,8 +34,8 @@ diff -urN a/rc.shutdown b/rc.shutdown
  
  	# decide what we want to do
 diff -urN a/rc.sysinit b/rc.sysinit
---- a/rc.sysinit	2012-01-18 16:02:04.000000000 -0700
-+++ b/rc.sysinit	2012-01-21 14:44:22.000000000 -0700
+--- a/rc.sysinit	2012-05-05 08:25:45.000000000 -0600
++++ b/rc.sysinit	2012-05-05 11:55:08.000000000 -0600
 @@ -7,8 +7,8 @@
  . /etc/rc.d/functions
  
@@ -46,8 +46,8 @@ diff -urN a/rc.sysinit b/rc.sysinit
 +printhl "${C_H2}http://www.archlinuxarm.org"
  printsep
  
- # mount /proc, /sys, /run, /dev, /run/lock, /dev/pts, /dev/shm (the api filesystems)
-@@ -190,7 +190,7 @@
+ # mount the api filesystems
+@@ -148,7 +148,7 @@
  fsck_reboot $fsckret
  
  status "Remounting Root" \