mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Merge branch 'master' of github.com:archlinuxarm/PKGBUILDs
This commit is contained in:
commit
58ee18105d
11 changed files with 332 additions and 166 deletions
|
@ -42,7 +42,7 @@ pkgname=(
|
|||
# 'koffice-kdgantt' # still an empty package
|
||||
)
|
||||
pkgver=2.3.3
|
||||
pkgrel=11
|
||||
pkgrel=12
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://koffice.kde.org'
|
||||
license=('GPL' 'LGPL' 'FDL')
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
# $Id: PKGBUILD 84755 2010-07-04 03:32:01Z eric $
|
||||
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
|
||||
# Mantainer: Roberto Carvajal <roberto@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>>
|
||||
# - update to version 2.0.0, something compatible with v4l2
|
||||
# - can probably remove this package when upstream catches up
|
||||
|
||||
plugrel=1
|
||||
|
||||
pkgname=mjpegtools
|
||||
pkgver=2.0.0
|
||||
pkgrel=1
|
||||
pkgdesc="Set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video"
|
||||
arch=(i686 x86_64)
|
||||
license=('GPL')
|
||||
url="http://mjpeg.sourceforge.net/"
|
||||
depends=('libjpeg>=8' 'libpng>=1.4.0' 'sdl' 'gcc-libs' 'libdv')
|
||||
makedepends=('gtk2>=2.18.6')
|
||||
optdepends=('gtk2: glav GUI')
|
||||
options=('!makeflags' '!libtool')
|
||||
install=mjpegtools.install
|
||||
source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz)
|
||||
md5sums=('903e1e3b967eebcc5fe5626d7517dc46')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
sed -i -e '/ARCHFLAGS=/s:=.*:=:' configure
|
||||
./configure --prefix=/usr --enable-largefile
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -m644 mpeg2enc/mpeg2syntaxcodes.h "${pkgdir}/usr/include/mjpegtools/mpeg2enc/"
|
||||
}
|
|
@ -1,16 +0,0 @@
|
|||
infodir=/usr/share/info
|
||||
file=mjpeg-howto.info
|
||||
|
||||
post_install() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
install-info $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
}
|
|
@ -13,7 +13,7 @@ pkgname=('opencv' 'opencv-docs' 'opencv-samples')
|
|||
_realname=OpenCV
|
||||
pkgver=2.3.1_a
|
||||
_realver=2.3.1
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="Open Source Computer Vision Library"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('BSD')
|
||||
|
|
|
@ -14,7 +14,7 @@ plugrel=1
|
|||
pkgbase=qt
|
||||
pkgname=('qt' 'qt-private-headers')
|
||||
pkgver=4.8.0
|
||||
pkgrel=2
|
||||
pkgrel=4
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
|
@ -26,22 +26,27 @@ options=('!libtool' '!distcc' '!ccache')
|
|||
_pkgfqn="${pkgbase}-everywhere-opensource-src-${pkgver}"
|
||||
source=("http://get.qt.nokia.com/qt/source/${_pkgfqn}.tar.gz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop'
|
||||
'qtconfig.desktop')
|
||||
'qtconfig.desktop'
|
||||
'fix-qurl.patch')
|
||||
md5sums=('e8a5fdbeba2927c948d9f477a6abe904'
|
||||
'fc211414130ab2764132e7370f8e5caa'
|
||||
'85179f5e0437514f8639957e1d8baf62'
|
||||
'f11852b97583610f3dbb669ebc3e21bc'
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd')
|
||||
'6b771c8a81dd90b45e8a79afa0e5bbfd'
|
||||
'7bc255a36733d0fbc80c1902ade4beca')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"/${_pkgfqn}
|
||||
|
||||
# (FS#27757)
|
||||
patch -p1 -i "${srcdir}"/fix-qurl.patch
|
||||
|
||||
export QT4DIR="${srcdir}"/${_pkgfqn}
|
||||
export LD_LIBRARY_PATH=${QT4DIR}/lib:${LD_LIBRARY_PATH}
|
||||
|
||||
export CXXFLAGS="$CXXFLAGS -fno-strict-volatile-bitfields"
|
||||
|
||||
sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/g++-base.conf
|
||||
sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
|
||||
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" mkspecs/common/gcc-base-unix.conf
|
||||
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" mkspecs/common/gcc-base.conf
|
||||
|
||||
|
|
13
extra/qt/fix-qurl.patch
Normal file
13
extra/qt/fix-qurl.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -up qt-everywhere-opensource-src-4.8.0/src/corelib/io/qurl.cpp.toLocalFile qt-everywhere-opensource-src-4.8.0/src/corelib/io/qurl.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.0/src/corelib/io/qurl.cpp.toLocalFile 2011-10-03 22:44:32.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.0/src/corelib/io/qurl.cpp 2011-10-27 12:58:35.706815049 -0500
|
||||
@@ -6158,7 +6158,8 @@ QUrl QUrl::fromLocalFile(const QString &
|
||||
QString QUrl::toLocalFile() const
|
||||
{
|
||||
// the call to isLocalFile() also ensures that we're parsed
|
||||
- if (!isLocalFile())
|
||||
+ // Treat URLs with no scheme as local for backward compatibility
|
||||
+ if (!isLocalFile() && (!d || !d->scheme.isEmpty()))
|
||||
return QString();
|
||||
|
||||
QString tmp;
|
|
@ -9,7 +9,7 @@ plugrel=1
|
|||
|
||||
pkgname=qt3
|
||||
pkgver=3.3.8
|
||||
pkgrel=21
|
||||
pkgrel=22
|
||||
pkgdesc="The QT3 gui toolkit"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.trolltech.com/products/qt/index.html"
|
||||
|
@ -21,12 +21,12 @@ optdepends=('libmysqlclient' 'postgresql-libs' 'unixodbc')
|
|||
options=('!libtool')
|
||||
install=qt.install
|
||||
source=(ftp://ftp.trolltech.com/qt/source/qt-x11-free-${pkgver}.tar.bz2
|
||||
qt.profile qt3-png14.patch qt-copy-kde-patches.tar.bz2
|
||||
qt.profile qt3-png15.patch qt-copy-kde-patches.tar.bz2
|
||||
qt-patches.tar.bz2 utf8-bug-qt3.diff qt-font-default-subst.diff
|
||||
mysql.patch eastern_asian_languagues.diff qt-odbc.patch gcc-4.6.patch arm.patch)
|
||||
sha1sums=('91b192cb8e80679607d24ae35d6e20ed68d149d7'
|
||||
'd2e257a9011208b2cb81b9cf47915b9a2f9dab83'
|
||||
'c8ea644266f4d6d6be9adf894f03138b8eca3fc2'
|
||||
'3d19510c46016a1a211d97bf8f82b01498b1b33c'
|
||||
'9cb2e5bec782069692ee337cfa171539d9d73753'
|
||||
'116afa0e737bdf27ea27f9b3653aeb56db9ec151'
|
||||
'ca5ecb29c7f1c826d48703339a3371038e306bb7'
|
||||
|
@ -68,7 +68,7 @@ build() {
|
|||
# fix build with gcc 4.6.0
|
||||
patch -p1 -i "${srcdir}"/gcc-4.6.patch
|
||||
|
||||
patch -p0 -i "${srcdir}"/qt3-png14.patch
|
||||
patch -p0 -i "${srcdir}"/qt3-png15.patch
|
||||
# Arch Linux ARM patch
|
||||
patch -p1 -i ${srcdir}/arm.patch
|
||||
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
--- src/kernel/qpngio.cpp.orig 2010-01-16 22:02:41.000000000 +0100
|
||||
+++ src/kernel/qpngio.cpp 2010-01-16 22:03:56.000000000 +0100
|
||||
@@ -159,7 +159,7 @@
|
||||
image.setColor( i, qRgba(c,c,c,0xff) );
|
||||
}
|
||||
if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
|
||||
- const int g = info_ptr->trans_values.gray;
|
||||
+ const int g = info_ptr->trans_color.gray;
|
||||
if (g < ncols) {
|
||||
image.setAlphaBuffer(TRUE);
|
||||
image.setColor(g, image.color(g) & RGB_MASK);
|
||||
@@ -187,7 +187,7 @@
|
||||
info_ptr->palette[i].red,
|
||||
info_ptr->palette[i].green,
|
||||
info_ptr->palette[i].blue,
|
||||
- info_ptr->trans[i]
|
||||
+ info_ptr->trans_alpha[i]
|
||||
)
|
||||
);
|
||||
i++;
|
||||
@@ -321,9 +321,9 @@
|
||||
png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)
|
||||
if (image.depth()==32 && png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
|
||||
QRgb trans = 0xFF000000 | qRgb(
|
||||
- (info_ptr->trans_values.red << 8 >> bit_depth)&0xff,
|
||||
- (info_ptr->trans_values.green << 8 >> bit_depth)&0xff,
|
||||
- (info_ptr->trans_values.blue << 8 >> bit_depth)&0xff);
|
||||
+ (info_ptr->trans_color.red << 8 >> bit_depth)&0xff,
|
||||
+ (info_ptr->trans_color.green << 8 >> bit_depth)&0xff,
|
||||
+ (info_ptr->trans_color.blue << 8 >> bit_depth)&0xff);
|
||||
for (uint y=0; y<height; y++) {
|
||||
for (uint x=0; x<info_ptr->width; x++) {
|
||||
if (((uint**)jt)[y][x] == trans) {
|
212
extra/qt3/qt3-png15.patch
Normal file
212
extra/qt3/qt3-png15.patch
Normal file
|
@ -0,0 +1,212 @@
|
|||
$NetBSD: patch-as,v 1.5 2011/03/25 15:28:26 wiz Exp $
|
||||
|
||||
--- src/kernel/qpngio.cpp.orig 2007-02-02 10:01:15.000000000 -0400
|
||||
+++ src/kernel/qpngio.cpp
|
||||
@@ -43,6 +43,7 @@
|
||||
#include "qiodevice.h"
|
||||
|
||||
#include <png.h>
|
||||
+#include <zlib.h>
|
||||
|
||||
|
||||
#ifdef Q_OS_TEMP
|
||||
@@ -123,9 +124,24 @@ void setup_qt( QImage& image, png_struct
|
||||
png_get_IHDR(png_ptr, info_ptr, &width, &height, &bit_depth, &color_type,
|
||||
0, 0, 0);
|
||||
|
||||
+ png_colorp info_ptr_palette = NULL;
|
||||
+ int info_ptr_num_palette = 0;
|
||||
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)) {
|
||||
+ png_get_PLTE(png_ptr, info_ptr, &info_ptr_palette, &info_ptr_num_palette);
|
||||
+ }
|
||||
+
|
||||
+ png_bytep info_ptr_trans_alpha = NULL;
|
||||
+ int info_ptr_num_trans = 0;
|
||||
+ png_color_16p info_ptr_trans_color = NULL;
|
||||
+
|
||||
+ if (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)) {
|
||||
+ png_get_tRNS(png_ptr, info_ptr, &info_ptr_trans_alpha, &info_ptr_num_trans, &info_ptr_trans_color);
|
||||
+ }
|
||||
+
|
||||
+
|
||||
if ( color_type == PNG_COLOR_TYPE_GRAY ) {
|
||||
// Black & White or 8-bit grayscale
|
||||
- if ( bit_depth == 1 && info_ptr->channels == 1 ) {
|
||||
+ if ( bit_depth == 1 && png_get_channels(png_ptr, info_ptr) == 1 ) {
|
||||
png_set_invert_mono( png_ptr );
|
||||
png_read_update_info( png_ptr, info_ptr );
|
||||
if (!image.create( width, height, 1, 2, QImage::BigEndian ))
|
||||
@@ -159,7 +175,7 @@ void setup_qt( QImage& image, png_struct
|
||||
image.setColor( i, qRgba(c,c,c,0xff) );
|
||||
}
|
||||
if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
|
||||
- const int g = info_ptr->trans_values.gray;
|
||||
+ const int g = info_ptr_trans_color->gray;
|
||||
if (g < ncols) {
|
||||
image.setAlphaBuffer(TRUE);
|
||||
image.setColor(g, image.color(g) & RGB_MASK);
|
||||
@@ -168,7 +184,7 @@ void setup_qt( QImage& image, png_struct
|
||||
}
|
||||
} else if ( color_type == PNG_COLOR_TYPE_PALETTE
|
||||
&& png_get_valid(png_ptr, info_ptr, PNG_INFO_PLTE)
|
||||
- && info_ptr->num_palette <= 256 )
|
||||
+ && info_ptr_num_palette <= 256 )
|
||||
{
|
||||
// 1-bit and 8-bit color
|
||||
if ( bit_depth != 1 )
|
||||
@@ -176,28 +192,28 @@ void setup_qt( QImage& image, png_struct
|
||||
png_read_update_info( png_ptr, info_ptr );
|
||||
png_get_IHDR(png_ptr, info_ptr,
|
||||
&width, &height, &bit_depth, &color_type, 0, 0, 0);
|
||||
- if (!image.create(width, height, bit_depth, info_ptr->num_palette,
|
||||
+ if (!image.create(width, height, bit_depth, info_ptr_num_palette,
|
||||
QImage::BigEndian))
|
||||
return;
|
||||
int i = 0;
|
||||
if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
|
||||
image.setAlphaBuffer( TRUE );
|
||||
- while ( i < info_ptr->num_trans ) {
|
||||
+ while ( i < info_ptr_num_trans ) {
|
||||
image.setColor(i, qRgba(
|
||||
- info_ptr->palette[i].red,
|
||||
- info_ptr->palette[i].green,
|
||||
- info_ptr->palette[i].blue,
|
||||
- info_ptr->trans[i]
|
||||
+ info_ptr_palette[i].red,
|
||||
+ info_ptr_palette[i].green,
|
||||
+ info_ptr_palette[i].blue,
|
||||
+ info_ptr_trans_alpha[i]
|
||||
)
|
||||
);
|
||||
i++;
|
||||
}
|
||||
}
|
||||
- while ( i < info_ptr->num_palette ) {
|
||||
+ while ( i < info_ptr_num_palette ) {
|
||||
image.setColor(i, qRgba(
|
||||
- info_ptr->palette[i].red,
|
||||
- info_ptr->palette[i].green,
|
||||
- info_ptr->palette[i].blue,
|
||||
+ info_ptr_palette[i].red,
|
||||
+ info_ptr_palette[i].green,
|
||||
+ info_ptr_palette[i].blue,
|
||||
0xff
|
||||
)
|
||||
);
|
||||
@@ -284,7 +300,7 @@ void read_png_image(QImageIO* iio)
|
||||
return;
|
||||
}
|
||||
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
|
||||
iio->setStatus(-4);
|
||||
return;
|
||||
@@ -469,7 +485,7 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
png_destroy_write_struct(&png_ptr, &info_ptr);
|
||||
return FALSE;
|
||||
}
|
||||
@@ -491,10 +507,16 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
|
||||
png_set_write_fn(png_ptr, (void*)this, qpiw_write_fn, qpiw_flush_fn);
|
||||
|
||||
+#warning XXXtnn not too sure about this
|
||||
+/*
|
||||
+according to png.h, channels is only used on read, not writes, so we
|
||||
+should be able to comment this out.
|
||||
+
|
||||
info_ptr->channels =
|
||||
(image.depth() == 32)
|
||||
? (image.hasAlphaBuffer() ? 4 : 3)
|
||||
: 1;
|
||||
+*/
|
||||
|
||||
png_set_IHDR(png_ptr, info_ptr, image.width(), image.height(),
|
||||
image.depth() == 1 ? 1 : 8 /* per channel */,
|
||||
@@ -504,11 +526,12 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
: PNG_COLOR_TYPE_RGB
|
||||
: PNG_COLOR_TYPE_PALETTE, 0, 0, 0);
|
||||
|
||||
+ png_color_8 sig_bit;
|
||||
+ sig_bit.red = 8;
|
||||
+ sig_bit.green = 8;
|
||||
+ sig_bit.blue = 8;
|
||||
+ png_set_sBIT(png_ptr, info_ptr, &sig_bit);
|
||||
|
||||
- //png_set_sBIT(png_ptr, info_ptr, 8);
|
||||
- info_ptr->sig_bit.red = 8;
|
||||
- info_ptr->sig_bit.green = 8;
|
||||
- info_ptr->sig_bit.blue = 8;
|
||||
|
||||
if (image.depth() == 1 && image.bitOrder() == QImage::LittleEndian)
|
||||
png_set_packswap(png_ptr);
|
||||
@@ -522,11 +545,14 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
png_set_PLTE(png_ptr, info_ptr, palette, num_palette);
|
||||
int* trans = new int[num_palette];
|
||||
int num_trans = 0;
|
||||
+ png_colorp info_ptr_palette = NULL;
|
||||
+ int tmp;
|
||||
+ png_get_PLTE(png_ptr, info_ptr, &info_ptr_palette, &tmp);
|
||||
for (int i=0; i<num_palette; i++) {
|
||||
QRgb rgb=image.color(i);
|
||||
- info_ptr->palette[i].red = qRed(rgb);
|
||||
- info_ptr->palette[i].green = qGreen(rgb);
|
||||
- info_ptr->palette[i].blue = qBlue(rgb);
|
||||
+ info_ptr_palette[i].red = qRed(rgb);
|
||||
+ info_ptr_palette[i].green = qGreen(rgb);
|
||||
+ info_ptr_palette[i].blue = qBlue(rgb);
|
||||
if (image.hasAlphaBuffer()) {
|
||||
trans[i] = rgb >> 24;
|
||||
if (trans[i] < 255) {
|
||||
@@ -534,6 +560,7 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
}
|
||||
}
|
||||
}
|
||||
+ png_set_PLTE(png_ptr, info_ptr, info_ptr_palette, num_palette);
|
||||
if (num_trans) {
|
||||
copy_trans = new png_byte[num_trans];
|
||||
for (int i=0; i<num_trans; i++)
|
||||
@@ -544,7 +571,10 @@ bool QPNGImageWriter::writeImage(const Q
|
||||
}
|
||||
|
||||
if ( image.hasAlphaBuffer() ) {
|
||||
- info_ptr->sig_bit.alpha = 8;
|
||||
+ png_color_8p sig_bit;
|
||||
+ png_get_sBIT(png_ptr, info_ptr, &sig_bit);
|
||||
+ sig_bit->alpha = 8;
|
||||
+ png_set_sBIT(png_ptr, info_ptr, sig_bit);
|
||||
}
|
||||
|
||||
// Swap ARGB to RGBA (normal PNG format) before saving on
|
||||
@@ -1030,7 +1060,7 @@ int QPNGFormat::decode(QImage& img, QIma
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (setjmp((png_ptr)->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
png_destroy_read_struct(&png_ptr, &info_ptr, 0);
|
||||
image = 0;
|
||||
return -1;
|
||||
@@ -1057,7 +1087,7 @@ int QPNGFormat::decode(QImage& img, QIma
|
||||
|
||||
if ( !png_ptr ) return 0;
|
||||
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
png_destroy_read_struct(&png_ptr, &info_ptr, 0);
|
||||
image = 0;
|
||||
state = MovieStart;
|
||||
@@ -1117,7 +1147,7 @@ void QPNGFormat::end(png_structp png, pn
|
||||
consumer->frameDone(QPoint(offx,offy),r);
|
||||
consumer->end();
|
||||
state = FrameStart;
|
||||
- unused_data = (int)png->buffer_size; // Since libpng doesn't tell us
|
||||
+ unused_data = png_process_data_pause(png, 0);
|
||||
}
|
||||
|
||||
#ifdef PNG_USER_CHUNKS_SUPPORTED
|
|
@ -1,3 +1,4 @@
|
|||
# $Id: PKGBUILD 148935 2012-02-05 11:56:42Z ibiru $
|
||||
# Maintainer: Rémy Oudompheng <remy@archlinux.org>
|
||||
# Contributor: francois <francois.archlinux.org>
|
||||
|
||||
|
@ -10,7 +11,7 @@ plugrel=1
|
|||
pkgname=texlive-bin
|
||||
pkgver=2011.3
|
||||
_luatex_ver=0.70.1
|
||||
pkgrel=1
|
||||
pkgrel=4
|
||||
pkgdesc="TeX Live binaries"
|
||||
license=('GPL')
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -52,12 +53,12 @@ md5sums=('220a4f4cc0d915bf8fcbcb553dcee1ae'
|
|||
'e7f0197559ef865d8c01683dab3b8526')
|
||||
|
||||
build() {
|
||||
if [ "${CARCH}" = "armv7h" ]; then
|
||||
if [ "${CARCH}" = "x86_64" ]; then
|
||||
export CFLAGS="${CFLAGS} -fPIC"
|
||||
export CXXFLAGS="${CXXFLAGS} -fPIC"
|
||||
fi
|
||||
|
||||
cd $srcdir
|
||||
cd "$srcdir"
|
||||
# Building LuaTeX
|
||||
# cd luatex-beta-${_luatex_ver}
|
||||
cd luatex
|
||||
|
@ -110,7 +111,9 @@ build() {
|
|||
test ! -d Work && mkdir Work
|
||||
cd Work
|
||||
echo "--> Initial configuration..."
|
||||
# we use temporary prefix to avoid messing the existing $pkgdir/usr/share/texmf tree
|
||||
# we use temporary prefix to avoid messing the existing
|
||||
# $pkgdir/usr/share/texmf tree
|
||||
# system zlib is disabled due to issues with zlib 1.2.6 (FS#28221)
|
||||
../configure --prefix=/usr -C \
|
||||
--sysconfdir=/etc \
|
||||
--datarootdir=/usr/share \
|
||||
|
@ -124,15 +127,15 @@ build() {
|
|||
--disable-t1utils \
|
||||
--disable-bibtexu \
|
||||
--disable-xz \
|
||||
--with-system-zlib \
|
||||
--with-system-zziplib \
|
||||
--with-system-pnglib \
|
||||
--without-system-zlib \
|
||||
--without-system-zziplib \
|
||||
--without-system-pnglib \
|
||||
--with-system-ncurses \
|
||||
--with-system-t1lib \
|
||||
--with-system-gd \
|
||||
--with-system-poppler \
|
||||
--with-system-xpdf \
|
||||
--with-system-freetype2 \
|
||||
--without-system-gd \
|
||||
--without-system-poppler \
|
||||
--without-system-xpdf \
|
||||
--without-system-freetype2 \
|
||||
--without-system-graphite \
|
||||
--with-freetype2-libdir=/usr/lib \
|
||||
--with-freetype2-include=/usr/include/freetype2 \
|
||||
|
@ -149,63 +152,63 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir
|
||||
cd "$srcdir"
|
||||
#############################################################
|
||||
### install texmf tree
|
||||
echo "-------------------------------------------------------"
|
||||
echo "--> installing the texmf tree"
|
||||
echo "-------------------------------------------------------"
|
||||
install -m755 -d $pkgdir/usr/share
|
||||
cp -r texmf $pkgdir/usr/share/
|
||||
install -d -m755 $pkgdir/etc/texmf/web2c
|
||||
install -d -m755 $pkgdir/etc/texmf/chktex
|
||||
install -d -m755 $pkgdir/etc/texmf/dvips/config
|
||||
install -d -m755 $pkgdir/etc/texmf/dvipdfm/config
|
||||
install -d -m755 $pkgdir/etc/texmf/dvipdfmx
|
||||
install -d -m755 $pkgdir/etc/texmf/tex/generic/config
|
||||
install -d -m755 $pkgdir/etc/texmf/ttf2pk
|
||||
install -d -m755 $pkgdir/etc/texmf/xdvi
|
||||
install -d -m755 $pkgdir/etc/fonts/conf.avail
|
||||
install -m644 $srcdir/09-texlive-fonts.conf $pkgdir/etc/fonts/conf.avail/
|
||||
install -m755 -d "$pkgdir"/usr/share
|
||||
cp -r texmf "$pkgdir"/usr/share/
|
||||
install -d -m755 "$pkgdir"/etc/texmf/web2c
|
||||
install -d -m755 "$pkgdir"/etc/texmf/chktex
|
||||
install -d -m755 "$pkgdir"/etc/texmf/dvips/config
|
||||
install -d -m755 "$pkgdir"/etc/texmf/dvipdfm/config
|
||||
install -d -m755 "$pkgdir"/etc/texmf/dvipdfmx
|
||||
install -d -m755 "$pkgdir"/etc/texmf/tex/generic/config
|
||||
install -d -m755 "$pkgdir"/etc/texmf/ttf2pk
|
||||
install -d -m755 "$pkgdir"/etc/texmf/xdvi
|
||||
install -d -m755 "$pkgdir"/etc/fonts/conf.avail
|
||||
install -m644 "$srcdir"/09-texlive-fonts.conf "$pkgdir"/etc/fonts/conf.avail/
|
||||
# move man files to /usr/share/man
|
||||
for i in 1 5; do
|
||||
install -d -m755 $pkgdir/usr/share/man/man$i
|
||||
mv $pkgdir/usr/share/texmf/doc/man/man$i/*.$i $pkgdir/usr/share/man/man$i/
|
||||
install -d -m755 "$pkgdir"/usr/share/man/man$i
|
||||
mv "$pkgdir"/usr/share/texmf/doc/man/man$i/*.$i "$pkgdir"/usr/share/man/man$i/
|
||||
done
|
||||
# move info files to /usr/share/info
|
||||
install -d -m755 $pkgdir/usr/share/info
|
||||
mv $pkgdir/usr/share/texmf/doc/info/*.info $pkgdir/usr/share/info/
|
||||
rm -rf $pkgdir/usr/share/texmf/doc/{man,info}
|
||||
install -d -m755 "$pkgdir"/usr/share/info
|
||||
mv "$pkgdir"/usr/share/texmf/doc/info/*.info "$pkgdir"/usr/share/info/
|
||||
rm -rf "$pkgdir"/usr/share/texmf/doc/{man,info}
|
||||
# copy config files to $TEXMFCONFIG tree
|
||||
cp -a $pkgdir/usr/share/texmf/chktex/chktexrc \
|
||||
$pkgdir/etc/texmf/chktex/
|
||||
cp -a $pkgdir/usr/share/texmf/web2c/mktex.cnf \
|
||||
$pkgdir/etc/texmf/web2c/
|
||||
cp -a $pkgdir/usr/share/texmf/web2c/updmap.cfg \
|
||||
$pkgdir/etc/texmf/web2c/
|
||||
cp -a $pkgdir/usr/share/texmf/web2c/fmtutil.cnf \
|
||||
$pkgdir/etc/texmf/web2c/
|
||||
cp -a $pkgdir/usr/share/texmf/dvips/config/config.ps \
|
||||
$pkgdir/etc/texmf/dvips/config/
|
||||
cp -a $pkgdir/usr/share/texmf/dvipdfm/config/config \
|
||||
$pkgdir/etc/texmf/dvipdfm/config/
|
||||
cp -a $pkgdir/usr/share/texmf/dvipdfmx/dvipdfmx.cfg \
|
||||
$pkgdir/etc/texmf/dvipdfmx/
|
||||
cp -a $pkgdir/usr/share/texmf/tex/generic/config/pdftexconfig.tex \
|
||||
$pkgdir/etc/texmf/tex/generic/config/
|
||||
cp -a $pkgdir/usr/share/texmf/tex/generic/config/language.dat \
|
||||
$pkgdir/etc/texmf/tex/generic/config/
|
||||
cp -a $pkgdir/usr/share/texmf/tex/generic/config/language.def \
|
||||
$pkgdir/etc/texmf/tex/generic/config/
|
||||
cp -a $pkgdir/usr/share/texmf/ttf2pk/ttf2pk.cfg \
|
||||
$pkgdir/etc/texmf/ttf2pk/
|
||||
cp -a $pkgdir/usr/share/texmf/xdvi/XDvi \
|
||||
$pkgdir/etc/texmf/xdvi/
|
||||
cp -a "$pkgdir"/usr/share/texmf/chktex/chktexrc \
|
||||
"$pkgdir"/etc/texmf/chktex/
|
||||
cp -a "$pkgdir"/usr/share/texmf/web2c/mktex.cnf \
|
||||
"$pkgdir"/etc/texmf/web2c/
|
||||
cp -a "$pkgdir"/usr/share/texmf/web2c/updmap.cfg \
|
||||
"$pkgdir"/etc/texmf/web2c/
|
||||
cp -a "$pkgdir"/usr/share/texmf/web2c/fmtutil.cnf \
|
||||
"$pkgdir"/etc/texmf/web2c/
|
||||
cp -a "$pkgdir"/usr/share/texmf/dvips/config/config.ps \
|
||||
"$pkgdir"/etc/texmf/dvips/config/
|
||||
cp -a "$pkgdir"/usr/share/texmf/dvipdfm/config/config \
|
||||
"$pkgdir"/etc/texmf/dvipdfm/config/
|
||||
cp -a "$pkgdir"/usr/share/texmf/dvipdfmx/dvipdfmx.cfg \
|
||||
"$pkgdir"/etc/texmf/dvipdfmx/
|
||||
cp -a "$pkgdir"/usr/share/texmf/tex/generic/config/pdftexconfig.tex \
|
||||
"$pkgdir"/etc/texmf/tex/generic/config/
|
||||
cp -a "$pkgdir"/usr/share/texmf/tex/generic/config/language.dat \
|
||||
"$pkgdir"/etc/texmf/tex/generic/config/
|
||||
cp -a "$pkgdir"/usr/share/texmf/tex/generic/config/language.def \
|
||||
"$pkgdir"/etc/texmf/tex/generic/config/
|
||||
cp -a "$pkgdir"/usr/share/texmf/ttf2pk/ttf2pk.cfg \
|
||||
"$pkgdir"/etc/texmf/ttf2pk/
|
||||
cp -a "$pkgdir"/usr/share/texmf/xdvi/XDvi \
|
||||
"$pkgdir"/etc/texmf/xdvi/
|
||||
# remove TL specific warnings in the language.{dat,def} files:
|
||||
sed -i -e '/DO NOT EDIT/,+3 d' $pkgdir/etc/texmf/tex/generic/config/language.*
|
||||
sed -i -e '/DO NOT EDIT/,+3 d' "$pkgdir"/etc/texmf/tex/generic/config/language.*
|
||||
# clean updmap.cfg
|
||||
sed -i '/^\(Map\|MixedMap\)/d' $pkgdir/etc/texmf/web2c/updmap.cfg
|
||||
sed -i '/^#! \(Map\|MixedMap\)/d' $pkgdir/etc/texmf/web2c/updmap.cfg
|
||||
sed -i '/^\(Map\|MixedMap\)/d' "$pkgdir"/etc/texmf/web2c/updmap.cfg
|
||||
sed -i '/^#! \(Map\|MixedMap\)/d' "$pkgdir"/etc/texmf/web2c/updmap.cfg
|
||||
|
||||
#############################################################
|
||||
### install
|
||||
|
@ -215,34 +218,34 @@ package() {
|
|||
echo "--> Proceeding with make install ..."
|
||||
echo "-------------------------------------------------------"
|
||||
cd Work
|
||||
make DESTDIR=${pkgdir} texmf=$pkgdir/usr/share/texmf install
|
||||
rm -rf ${pkgdir}/usr/{texmf,share/texmf-dist}
|
||||
make DESTDIR="${pkgdir}" texmf="$pkgdir"/usr/share/texmf install
|
||||
rm -rf "${pkgdir}"/usr/{texmf,share/texmf-dist}
|
||||
|
||||
# replace upstream texmf.cnf with ours
|
||||
rm -f $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
install -m644 $srcdir/texmf.cnf $pkgdir/etc/texmf/web2c/texmf.cnf
|
||||
rm -f "$pkgdir"/usr/share/texmf/web2c/texmf.cnf
|
||||
install -m644 "$srcdir"/texmf.cnf "$pkgdir"/etc/texmf/web2c/texmf.cnf
|
||||
# since the location of texmf.cnf is hard-wired to be under /usr/share/texmf/web2c
|
||||
# we make a symlink from /etc/texmf/web2c/texmf.cnf to the latter
|
||||
ln -sf /etc/texmf/web2c/texmf.cnf $pkgdir/usr/share/texmf/web2c/texmf.cnf
|
||||
ln -sf /etc/texmf/web2c/texmf.cnf "$pkgdir"/usr/share/texmf/web2c/texmf.cnf
|
||||
# fix location of TEXMFCACHE for luatools
|
||||
sed -i 's#texlive2010#texlive#' $pkgdir/usr/share/texmf/web2c/texmfcnf.lua
|
||||
sed -i 's#texlive2010#texlive#' "$pkgdir"/usr/share/texmf/web2c/texmfcnf.lua
|
||||
## remove aleph from fmtutil.cnf
|
||||
sed -i -e '/aleph/d' $pkgdir/usr/share/texmf/web2c/fmtutil.cnf
|
||||
sed -i -e '/aleph/d' "$pkgdir"/usr/share/texmf/web2c/fmtutil.cnf
|
||||
|
||||
## install luatex binary
|
||||
#install -m755 $srcdir/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex $pkgdir/usr/bin/
|
||||
install -m755 $srcdir/luatex/build/texk/web2c/luatex $pkgdir/usr/bin/
|
||||
cd $pkgdir/usr/bin
|
||||
#install -m755 "$srcdir"/luatex-beta-${_luatex_ver}/build/texk/web2c/luatex "$pkgdir"/usr/bin/
|
||||
install -m755 "$srcdir"/luatex/build/texk/web2c/luatex "$pkgdir"/usr/bin/
|
||||
cd "$pkgdir"/usr/bin
|
||||
/bin/ln -s luatex texlua
|
||||
/bin/ln -s luatex texluac
|
||||
|
||||
## install Perl libraries
|
||||
mkdir -p $pkgdir/usr/share/tlpkg/TeXLive
|
||||
install -m644 ${srcdir}/source/utils/biber/TeXLive/*.pm $pkgdir/usr/share/tlpkg/TeXLive
|
||||
mkdir -p "$pkgdir"/usr/share/tlpkg/TeXLive
|
||||
install -m644 "${srcdir}"/source/utils/biber/TeXLive/*.pm "$pkgdir"/usr/share/tlpkg/TeXLive
|
||||
|
||||
# create symlinks for formats
|
||||
echo "--> Create symlinks for TeX formats ..."
|
||||
PATH="$PATH:${pkgdir}/usr/bin" texlinks -f $pkgdir/usr/share/texmf/web2c/fmtutil.cnf $pkgdir/usr/bin/
|
||||
PATH="$PATH:${pkgdir}/usr/bin" texlinks -f "$pkgdir"/usr/share/texmf/web2c/fmtutil.cnf "$pkgdir"/usr/bin/
|
||||
#############################################################
|
||||
# remove dangling symlinks
|
||||
_bibtexextra_scripts="
|
||||
|
@ -339,7 +342,7 @@ vpe"
|
|||
${_pstricks_scripts} \
|
||||
${_science_scripts} \
|
||||
tlmgr; do
|
||||
rm -f $pkgdir/usr/bin/$s
|
||||
rm -f "$pkgdir"/usr/bin/$s
|
||||
done
|
||||
###################################################################
|
||||
}
|
||||
|
|
|
@ -1,3 +1,6 @@
|
|||
infodir=usr/share/info
|
||||
filelist=(dvipng.info dvips.info eplain.info epspdf.info fontname.info kpathsea.info latex2e-es.info latex2e.info latex2man.info mf2pt1.info tds.info texdraw.info web2c.info)
|
||||
|
||||
post_install() {
|
||||
echo ">>> texlive: updating the filename database..."
|
||||
usr/bin/mktexlsr
|
||||
|
@ -5,6 +8,11 @@ post_install() {
|
|||
usr/bin/fmtutil-sys --all 1>/dev/null
|
||||
echo " done."
|
||||
echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
|
||||
|
||||
[[ -x usr/bin/install-info ]] || return 0
|
||||
for file in "${filelist[@]}"; do
|
||||
install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
|
@ -14,5 +22,16 @@ post_upgrade() {
|
|||
usr/bin/fmtutil-sys --all 1>/dev/null
|
||||
echo " done."
|
||||
echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
|
||||
|
||||
[[ -x usr/bin/install-info ]] || return 0
|
||||
for file in "${filelist[@]}"; do
|
||||
install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[[ -x usr/bin/install-info ]] || return 0
|
||||
for file in "${filelist[@]}"; do
|
||||
install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue