extra/libglvnd fix

This commit is contained in:
Kevin Mihelich 2016-11-04 19:09:53 +00:00
parent daafb61a23
commit 590d1b7a18
2 changed files with 29 additions and 2 deletions

View file

@ -0,0 +1,24 @@
From 454fad2893873ef36591c27b6b50a2fc3e92d6b1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 4 Nov 2016 12:32:06 -0600
Subject: [PATCH] remove unused variable
---
src/GLdispatch/vnd-glapi/entry_armv7_tsd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
index faec5bf..2bce0c2 100644
--- a/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
+++ b/src/GLdispatch/vnd-glapi/entry_armv7_tsd.c
@@ -166,7 +166,6 @@ const int entry_stub_size = ARMV7_ENTRY_SIZE;
static const int TEMPLATE_OFFSET_CURRENT_TABLE = ARMV7_BYTECODE_SIZE - 3*4;
static const int TEMPLATE_OFFSET_CURRENT_TABLE_GET = ARMV7_BYTECODE_SIZE - 2*4;
static const int TEMPLATE_OFFSET_SLOT = ARMV7_BYTECODE_SIZE - 4;
-static const int TEMPLATE_OFFSETS_SIZE = 3*4;
void
entry_init_public(void)
--
2.10.0

View file

@ -18,17 +18,20 @@ makedepends=('libx11' 'glproto' 'git' 'python')
source=("git+https://github.com/NVIDIA/libglvnd.git#commit=$_commit"
LICENSE
https://patch-diff.githubusercontent.com/raw/NVIDIA/libglvnd/pull/110.patch
https://patch-diff.githubusercontent.com/raw/NVIDIA/libglvnd/pull/97.patch)
https://patch-diff.githubusercontent.com/raw/NVIDIA/libglvnd/pull/97.patch
0001-remove-unused-variable.patch)
sha1sums=('SKIP'
'c88e07f333fcf8dcdbef370b85372b4d88ad8a66'
'048e89dbdd0a6ca33441a6273208e4126d9828fc'
'48fac1b1248f1a6766ebae66432269c5147b5815')
'48fac1b1248f1a6766ebae66432269c5147b5815'
'39eb9a4d3cb9484e9fa27c234c783e83c2569103')
prepare() {
cd $pkgname
# FS#51527
patch -p1 -i ../97.patch
patch -p1 -i ../110.patch
patch -p1 -i ../0001-remove-unused-variable.patch
}
build() {