core/linux-aarch64 to 5.4.2-1

This commit is contained in:
Kevin Mihelich 2019-12-06 02:16:49 +00:00
parent 9d2e27e745
commit 5921eac0f2
6 changed files with 63 additions and 22 deletions

View file

@ -1,7 +1,7 @@
From 88b3bce10e3ad299d46e85ae646cc0c6d55d6629 Mon Sep 17 00:00:00 2001
From 1a96b25c17a89d6b6efc79f16e9aad41e75c6991 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 1/5] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 355be77f4241..c94a7193e0b9 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.22.0
2.23.0

View file

@ -1,7 +1,7 @@
From cf2a5efc2420ca3bd2037e25b781dad40609cfdd Mon Sep 17 00:00:00 2001
From 110a25d5e289e6254270df2b2fe17d9765f53265 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 7 Aug 2017 19:34:57 -0600
Subject: [PATCH 2/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Subject: [PATCH 2/5] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
---
@ -22,5 +22,5 @@ index c706db0ee9ec..24adeca99711 100644
&pwm2 {
--
2.22.0
2.23.0

View file

@ -1,7 +1,7 @@
From 602af2521e6c517b1b1447588cd2f93effb5ab3a Mon Sep 17 00:00:00 2001
From 843ecfaf6d1e5ef8759ae4ed272b5c747a843696 Mon Sep 17 00:00:00 2001
From: William Wu <william.wu@rock-chips.com>
Date: Mon, 4 Dec 2017 10:40:39 +0100
Subject: [PATCH 3/4] arm64: dts: rockchip: add usb3 controller node for RK3328
Subject: [PATCH 3/5] arm64: dts: rockchip: add usb3 controller node for RK3328
SoCs
RK3328 has one USB 3.0 OTG controller which uses DWC_USB3
@ -16,10 +16,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 27 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
index e9fefd8a7e02..7cfde858a794 100644
index 31cc1541f1f5..0feef5ed71b4 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
@@ -921,6 +921,33 @@
@@ -936,6 +936,33 @@
status = "disabled";
};
@ -54,5 +54,5 @@ index e9fefd8a7e02..7cfde858a794 100644
compatible = "arm,gic-400";
#interrupt-cells = <3>;
--
2.22.0
2.23.0

View file

@ -1,7 +1,7 @@
From a396e39e5a8fdf20c1b901c8c0a239f33086e829 Mon Sep 17 00:00:00 2001
From 00bfb3099639e5fde1aba006356af25b1a172eba Mon Sep 17 00:00:00 2001
From: Heiko Stuebner <heiko@sntech.de>
Date: Mon, 4 Dec 2017 10:40:41 +0100
Subject: [PATCH 4/4] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Subject: [PATCH 4/5] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
Enable the nodes to make the usb3 port usable on that board.
@ -11,10 +11,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
1 file changed, 9 insertions(+)
diff --git a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
index 7cfd5ca6cc85..2e8b99bb57b2 100644
index 62936b432f9a..c684ca7b7e2d 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
@@ -398,6 +398,15 @@
@@ -391,6 +391,15 @@
status = "okay";
};
@ -31,5 +31,5 @@ index 7cfd5ca6cc85..2e8b99bb57b2 100644
status = "okay";
};
--
2.22.0
2.23.0

View file

@ -0,0 +1,38 @@
From 9d393938a33f304ae2b40a1c4669db48928648cf Mon Sep 17 00:00:00 2001
From: Stefan Wahren <wahrenst@gmx.net>
Date: Sat, 30 Nov 2019 13:31:13 +0100
Subject: [PATCH 5/5] ARM: dts: bcm283x: Fix critical trip point
During definition of the CPU thermal zone of BCM283x SoC family there was
a misunderstanding of the meaning "criticial trip point" and the thermal
throttling range of the VideoCore firmware. The latter one takes effect
when the core temperature is between 80 and 85 degree celsius. So the
current critical trip point doesn't make sense, because the
thermal shutdown appears before the firmware has a chance to throttle the
ARM core(s).
Fix these unwanted shutdowns by increasing the critical trip point
to a value which shouldn't be reached with working thermal throttling.
Fixes: 0fe4d2181cc4 ("ARM: dts: bcm283x: Add CPU thermal zone with 1 trip point")
Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
---
arch/arm/boot/dts/bcm283x.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/bcm283x.dtsi b/arch/arm/boot/dts/bcm283x.dtsi
index 2d191fcbc2cc..90125ce19a1b 100644
--- a/arch/arm/boot/dts/bcm283x.dtsi
+++ b/arch/arm/boot/dts/bcm283x.dtsi
@@ -40,7 +40,7 @@
trips {
cpu-crit {
- temperature = <80000>;
+ temperature = <90000>;
hysteresis = <0>;
type = "critical";
};
--
2.23.0

View file

@ -7,7 +7,7 @@ pkgbase=linux-aarch64
_srcname=linux-5.4
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=5.4.1
pkgver=5.4.2
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@ -20,6 +20,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
'0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch'
'0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch'
'0005-ARM-dts-bcm283x-Fix-critical-trip-point.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -28,11 +29,12 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'60-linux.hook'
'90-linux.hook')
md5sums=('ce9b2d974d27408a61c53a30d3f98fb9'
'0f859f2223def2b6e5dbf627515f708f'
'78f0a8c92f49c45d10f7a2b9455551b6'
'86eab100b2b6b4abff411055949329bd'
'843e7d5c5bc47f2899632d6610b4047b'
'138648f7eecf6db5754e25a29b1b175d'
'debad4bcc336d83f6bff88aed8384038'
'f1656e2052c9a25f977b1051136ea85f'
'98bd5a4f6f203d8da94439faf9084dd5'
'4bee45bc09780f8f2b07239ab6594f30'
'0957a4a901282f33c05e1f68390f9ada'
'147b56da6735706dcab3b1bc58b9176e'
'66ffc0986a627575baea16ae9c9649ef'
'7f1a96e24f5150f790df94398e9525a3'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -52,6 +54,7 @@ prepare() {
git apply ../0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
git apply ../0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch
git apply ../0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch
git apply ../0005-ARM-dts-bcm283x-Fix-critical-trip-point.patch
cat "${srcdir}/config" > ./.config