mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/openimageio to 2.3.13.0-1
This commit is contained in:
parent
c329107a4d
commit
593551e853
2 changed files with 19 additions and 52 deletions
|
@ -1,25 +0,0 @@
|
|||
From aff1753c7632464312843617b1b0d98112aff04d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 2 Oct 2020 11:10:28 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
src/include/OpenImageIO/simd.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/include/OpenImageIO/simd.h b/src/include/OpenImageIO/simd.h
|
||||
index 0b2c1193..5498af00 100644
|
||||
--- a/src/include/OpenImageIO/simd.h
|
||||
+++ b/src/include/OpenImageIO/simd.h
|
||||
@@ -193,7 +193,7 @@
|
||||
|
||||
// FIXME Future: support ARM Neon
|
||||
// Uncomment this when somebody with Neon can verify it works
|
||||
-#if defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
+#if 0 && defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
# define OIIO_SIMD 4
|
||||
# define OIIO_SIMD_NEON 1
|
||||
# define OIIO_SIMD_MAX_SIZE_BYTES 16
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1,13 +1,12 @@
|
|||
# Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
|
||||
# Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
|
||||
# Contributor: SpepS <dreamspepser at yahoo dot it>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to disable neon
|
||||
# - disable lto via -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
|
||||
|
||||
pkgname=openimageio
|
||||
pkgver=2.2.18.0
|
||||
pkgrel=4
|
||||
pkgver=2.3.13.0
|
||||
pkgrel=1
|
||||
pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
|
||||
arch=(x86_64)
|
||||
url="http://www.openimageio.org/"
|
||||
|
@ -18,37 +17,30 @@ depends=('openexr' 'boost-libs' 'openjpeg2' 'glew' 'libtiff' 'opencolorio' 'libp
|
|||
makedepends=('cmake' 'qt5-base' 'python' 'boost' 'mesa' 'fontconfig' 'libxrender' 'ninja' 'robin-map')
|
||||
optdepends=('qt5-base: iv image viewer'
|
||||
'python: bindings support')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-$pkgver.tar.gz"
|
||||
'0001-disable-neon.patch')
|
||||
sha512sums=('22a61e8b1ca098c2293e972372d02f0ac8ce54b46eb957b1ffcacb9e0ca4ff13f560d67804e0db0a898d8bec2fdb73f3cdcd1ee1867f92f97f84c1c111e535be'
|
||||
'ea88d253d9f9a9302ffe113c6d8f86ff990ada1c304c890d6aecdb4ad3370c9fd12887bb421aaaeff658af4840caefa9f243d3f552cbfc533403b81c2a56d156')
|
||||
|
||||
prepare() {
|
||||
cd oiio-Release-$pkgver
|
||||
patch -p1 -i ../0001-disable-neon.patch
|
||||
}
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/refs/tags/v$pkgver.tar.gz")
|
||||
sha512sums=('fbefa341a11fd502ec9313ca48a0fe433c5822699e4934f6a14089f670314cbe1c9c0b9a491b1d1927bda0223e38a62192c6ddeec6c4c5e6215a8b3fb6900dd8')
|
||||
|
||||
build() {
|
||||
cd oiio-Release-$pkgver
|
||||
cd oiio-$pkgver
|
||||
|
||||
cmake \
|
||||
-Bbuild \
|
||||
-GNinja \
|
||||
-DUSE_PYTHON=ON \
|
||||
-DPYTHON_VERSION=3.10 \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DOIIO_BUILD_TESTS=ON \
|
||||
-DOIIO_BUILD_TOOLS=ON \
|
||||
-DBUILD_MISSING_FMT=OFF \
|
||||
-DUSE_EXTERNAL_PUGIXML=ON \
|
||||
-DSTOP_ON_WARNING=OFF \
|
||||
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
|
||||
-Bbuild \
|
||||
-GNinja \
|
||||
-DUSE_PYTHON=ON \
|
||||
-DPYTHON_VERSION=3.10 \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DOIIO_BUILD_TESTS=ON \
|
||||
-DOIIO_BUILD_TOOLS=ON \
|
||||
-DBUILD_MISSING_FMT=OFF \
|
||||
-DUSE_EXTERNAL_PUGIXML=ON \
|
||||
-DSTOP_ON_WARNING=OFF \
|
||||
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
|
||||
ninja -C build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd oiio-Release-$pkgver
|
||||
cd oiio-$pkgver
|
||||
|
||||
DESTDIR="$pkgdir" ninja -C build install
|
||||
|
||||
|
|
Loading…
Reference in a new issue