mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/ruby2.3
This commit is contained in:
parent
aa14f1dc25
commit
5948dd8236
2 changed files with 96 additions and 0 deletions
|
@ -0,0 +1,24 @@
|
||||||
|
diff --git a/internal.h b/internal.h
|
||||||
|
index 40916a5..785be49 100644
|
||||||
|
--- a/internal.h
|
||||||
|
+++ b/internal.h
|
||||||
|
@@ -250,16 +250,8 @@ struct rb_subclass_entry {
|
||||||
|
rb_subclass_entry_t *next;
|
||||||
|
};
|
||||||
|
|
||||||
|
-#if defined(HAVE_LONG_LONG)
|
||||||
|
-typedef unsigned LONG_LONG rb_serial_t;
|
||||||
|
-#define SERIALT2NUM ULL2NUM
|
||||||
|
-#elif defined(HAVE_UINT64_T)
|
||||||
|
-typedef uint64_t rb_serial_t;
|
||||||
|
-#define SERIALT2NUM SIZET2NUM
|
||||||
|
-#else
|
||||||
|
typedef unsigned long rb_serial_t;
|
||||||
|
#define SERIALT2NUM ULONG2NUM
|
||||||
|
-#endif
|
||||||
|
|
||||||
|
struct rb_classext_struct {
|
||||||
|
struct st_table *iv_index_tbl;
|
||||||
|
--
|
||||||
|
1.9.0
|
||||||
|
|
72
community/ruby2.3/PKGBUILD
Normal file
72
community/ruby2.3/PKGBUILD
Normal file
|
@ -0,0 +1,72 @@
|
||||||
|
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
||||||
|
# Contributor: Sergey Shatunov <me@prok.pw>
|
||||||
|
# Contributor: Jonne Haß <me@jhass.eu>
|
||||||
|
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
|
||||||
|
# Contributor: Allan McRae <allan@archlinux.org>
|
||||||
|
# Contributor: John Proctor <jproctor@prium.net>
|
||||||
|
# Contributor: Jeramy Rutley <jrutley@gmail.com>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to fix running ruby on v5 (#705)
|
||||||
|
|
||||||
|
_rubyver=2.3
|
||||||
|
pkgname=ruby2.3
|
||||||
|
pkgver=${_rubyver}.3
|
||||||
|
pkgdesc='An object-oriented language for quick and easy programming'
|
||||||
|
pkgrel=1
|
||||||
|
arch=(i686 x86_64)
|
||||||
|
url='http://www.ruby-lang.org/en/'
|
||||||
|
license=(BSD custom)
|
||||||
|
depends=(gdbm openssl libffi libyaml gmp zlib)
|
||||||
|
optdepends=('tk: for Ruby/TK')
|
||||||
|
makedepends=(gdbm openssl libffi doxygen graphviz libyaml ttf-dejavu tk)
|
||||||
|
options=(!emptydirs)
|
||||||
|
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||||
|
0002-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||||
|
sha256sums=('1a4fa8c2885734ba37b97ffdb4a19b8fba0e8982606db02d936e65bac07419dc'
|
||||||
|
'78c0e1db467bcd69b4b74d114f229f62da65646583f5dfd11bb9558bc3b734db')
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd ruby-${pkgver}
|
||||||
|
|
||||||
|
# fixes https://bugs.ruby-lang.org/issues/9507
|
||||||
|
[[ $CARCH == 'arm' ]] && patch -Np1 -i ../0002-Use-only-unsigned-long-for-rb_serial_t.patch
|
||||||
|
|
||||||
|
PKG_CONFIG=/usr/bin/pkg-config ./configure \
|
||||||
|
--prefix=/opt/ruby${_rubyver} \
|
||||||
|
--program-suffix=-${_rubyver} \
|
||||||
|
--sysconfdir=/etc \
|
||||||
|
--localstatedir=/var \
|
||||||
|
--sharedstatedir=/var/lib \
|
||||||
|
--libexecdir=/usr/lib/ruby \
|
||||||
|
--enable-shared \
|
||||||
|
--disable-rpath \
|
||||||
|
--with-dbm-type=gdbm_compat
|
||||||
|
|
||||||
|
make ruby
|
||||||
|
}
|
||||||
|
|
||||||
|
check() {
|
||||||
|
cd ruby-${pkgver}
|
||||||
|
|
||||||
|
make test
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd ruby-${pkgver}
|
||||||
|
|
||||||
|
make DESTDIR="${pkgdir}" install-nodoc
|
||||||
|
|
||||||
|
install -dm755 $pkgdir/usr/bin
|
||||||
|
install -dm755 $pkgdir/usr/lib
|
||||||
|
|
||||||
|
for i in erb irb rdoc ri ruby testrb rake gem; do
|
||||||
|
ln -s /opt/$pkgname/bin/$i-${_rubyver} $pkgdir/usr/bin/$i-${_rubyver}
|
||||||
|
ln -s /opt/$pkgname/bin/$i-${_rubyver} $pkgdir/opt/$pkgname/bin/$i
|
||||||
|
done
|
||||||
|
|
||||||
|
ln -s /opt/$pkgname/lib/libruby.so.${_rubyver} $pkgdir/usr/lib/libruby.so.${_rubyver}
|
||||||
|
|
||||||
|
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
|
||||||
|
install -D -m644 BSDL "${pkgdir}/usr/share/licenses/$pkgname/BSDL"
|
||||||
|
}
|
Loading…
Reference in a new issue