mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/meson to 1.0.0-1
This commit is contained in:
parent
f33226b18b
commit
59862501bb
2 changed files with 84 additions and 30 deletions
|
@ -22,7 +22,7 @@ index 193ad184b637..e94ba68ac30f 100644
|
||||||
|
|
||||||
dep = dependency('ZLIB', version : '>=1.2', method : 'cmake')
|
dep = dependency('ZLIB', version : '>=1.2', method : 'cmake')
|
||||||
diff --git a/unittests/linuxliketests.py b/unittests/linuxliketests.py
|
diff --git a/unittests/linuxliketests.py b/unittests/linuxliketests.py
|
||||||
index 25b392f28e47..db8119f63719 100644
|
index 50c6b62b02dd..20eb73550e9f 100644
|
||||||
--- a/unittests/linuxliketests.py
|
--- a/unittests/linuxliketests.py
|
||||||
+++ b/unittests/linuxliketests.py
|
+++ b/unittests/linuxliketests.py
|
||||||
@@ -359,6 +359,7 @@ class LinuxlikeTests(BasePlatformTests):
|
@@ -359,6 +359,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||||
|
|
|
@ -4,58 +4,112 @@
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - disable lto in arch-meson
|
# - disable lto in arch-meson
|
||||||
|
# - add makedepend on python-setuptools
|
||||||
|
|
||||||
pkgname=meson
|
pkgname=meson
|
||||||
pkgver=0.64.1
|
pkgver=1.0.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='High productivity build system'
|
pkgdesc="High productivity build system"
|
||||||
url='https://mesonbuild.com/'
|
url="https://mesonbuild.com/"
|
||||||
arch=('any')
|
arch=(any)
|
||||||
license=('Apache')
|
license=(Apache)
|
||||||
depends=('python-setuptools' 'ninja')
|
depends=(ninja)
|
||||||
checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' 'git' 'cython'
|
makedepends=(
|
||||||
'gtkmm3' 'gtest' 'gmock' 'protobuf' 'wxgtk3' 'python-gobject' 'gobject-introspection'
|
python-build
|
||||||
'itstool' 'gtk3' 'java-environment=8' 'gtk-doc' 'llvm' 'clang' 'sdl2' 'graphviz'
|
python-installer
|
||||||
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
|
python-wheel
|
||||||
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
|
python-setuptools
|
||||||
'python-pytest-xdist' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
|
)
|
||||||
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
|
checkdepends=(
|
||||||
0001-Skip-broken-tests.patch
|
boost
|
||||||
arch-meson)
|
clang
|
||||||
sha512sums=('4896f5a09f89cadce028080f70e5ca005fd3bb2141a730a0ad71ded63d1bde6d1254957fe079f5e4c6e3b9420a9fcc4525b01e689979f0bab6d09d6483ca42ec'
|
cmake
|
||||||
|
cuda
|
||||||
|
cython
|
||||||
|
doxygen
|
||||||
|
gcc-fortran
|
||||||
|
gcc-objc
|
||||||
|
git
|
||||||
|
gmock
|
||||||
|
gnustep-base
|
||||||
|
gobject-introspection
|
||||||
|
graphviz
|
||||||
|
gtest
|
||||||
|
gtk-doc
|
||||||
|
gtk-sharp-2
|
||||||
|
gtk3
|
||||||
|
gtkmm3
|
||||||
|
hotdoc
|
||||||
|
itstool
|
||||||
|
java-environment=8
|
||||||
|
ldc
|
||||||
|
libelf
|
||||||
|
libwmf
|
||||||
|
llvm
|
||||||
|
mercurial
|
||||||
|
mono
|
||||||
|
nasm
|
||||||
|
netcdf-fortran
|
||||||
|
openmpi
|
||||||
|
openssh
|
||||||
|
protobuf
|
||||||
|
python-gobject
|
||||||
|
python-pytest-xdist
|
||||||
|
qt5-base
|
||||||
|
qt5-tools
|
||||||
|
rust
|
||||||
|
rust-bindgen
|
||||||
|
sdl2
|
||||||
|
vala
|
||||||
|
valgrind
|
||||||
|
vulkan-validation-layers
|
||||||
|
wxgtk3
|
||||||
|
)
|
||||||
|
source=(
|
||||||
|
https://github.com/mesonbuild/meson/releases/download/$pkgver/meson-$pkgver.tar.gz{,.asc}
|
||||||
|
meson-reference-$pkgver.3::https://github.com/mesonbuild/meson/releases/download/$pkgver/meson-reference.3
|
||||||
|
meson-reference-$pkgver.json::https://github.com/mesonbuild/meson/releases/download/$pkgver/reference_manual.json
|
||||||
|
0001-Skip-broken-tests.patch
|
||||||
|
arch-meson
|
||||||
|
)
|
||||||
|
sha512sums=('9b1195cfe856c1aa51bc79f6eb4d0f94925bb02d0a9fbd68a6a6ced6e5c252b09b22d9aac812640687e49b8d64a313ce48d0a69a3bf83ea8ffb8c9dab559fc23'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'51b5d0b684a03ab884c6d94925bae7edc8544168100497251c36e85502428a0fe89e5512e067b24d983695ab3b468a8a504dfbe5d66c1c17579039bf329d3857'
|
'e756e3249e34d119b81403d1c36abbc63ee77db019b16742ebcc89689c177868e3684ae682a058c4bd7c6207d88694445f9e2f2c778f1365fe505e64186394ea'
|
||||||
|
'16099033f4eda0acd3cb2f5785717b493e1b64c50a66012161a10cbcc22e941a38b04124bc2d9622221850226e5407d4e050074d0237a0012dba869bd66af00d'
|
||||||
|
'30558210317307e720fd4d5d360c15882c5c756aad7b26036bc5875a0599312a711df174a87f29d528181ec88e9d48b2ee82456cf23109907c7ba4b4dcc5c238'
|
||||||
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
|
||||||
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd $pkgname-$pkgver
|
||||||
patch -Np1 -i ../0001-Skip-broken-tests.patch
|
patch -Np1 -i ../0001-Skip-broken-tests.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd $pkgname-$pkgver
|
||||||
python setup.py build
|
python -m build --wheel --no-isolation
|
||||||
}
|
}
|
||||||
|
|
||||||
check() (
|
check() (
|
||||||
cd ${pkgname}-${pkgver}
|
cd $pkgname-$pkgver
|
||||||
export LC_CTYPE=en_US.UTF-8 CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS=
|
export LC_CTYPE=en_US.UTF-8 CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS=
|
||||||
./run_tests.py --failfast
|
./run_tests.py --failfast
|
||||||
)
|
)
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd ${pkgname}-${pkgver}
|
cd $pkgname-$pkgver
|
||||||
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
|
python -m installer --destdir="$pkgdir" dist/*.whl
|
||||||
|
|
||||||
install -d "${pkgdir}/usr/share/vim/vimfiles"
|
install -d "$pkgdir/usr/share/vim/vimfiles"
|
||||||
cp -rt "${pkgdir}/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*/
|
cp -rt "$pkgdir/usr/share/vim/vimfiles" data/syntax-highlighting/vim/*/
|
||||||
|
|
||||||
install -Dt "${pkgdir}/usr/share/bash-completion/completions" -m644 data/shell-completions/bash/*
|
install -Dm644 data/shell-completions/bash/* -t "$pkgdir/usr/share/bash-completion/completions"
|
||||||
install -Dt "${pkgdir}/usr/share/zsh/site-functions" -m644 data/shell-completions/zsh/*
|
install -Dm644 data/shell-completions/zsh/* -t "$pkgdir/usr/share/zsh/site-functions"
|
||||||
|
|
||||||
# Arch packaging helper
|
install -Dm644 ../meson-reference-$pkgver.3 "$pkgdir/usr/share/man/man3/meson-reference.3"
|
||||||
install -D ../arch-meson -t "${pkgdir}/usr/bin"
|
install -Dm644 ../meson-reference-$pkgver.json "$pkgdir/usr/share/doc/$pkgname/reference_manual.json"
|
||||||
|
|
||||||
|
install -D ../arch-meson -t "$pkgdir/usr/bin"
|
||||||
}
|
}
|
||||||
|
|
||||||
# vim:set sw=2 sts=-1 et:
|
# vim:set sw=2 sts=-1 et:
|
||||||
|
|
Loading…
Reference in a new issue