added community/guvcview

This commit is contained in:
Kevin Mihelich 2021-11-02 20:57:05 +00:00
parent 465317707b
commit 59ca719c37
2 changed files with 160 additions and 0 deletions

View file

@ -0,0 +1,71 @@
From ee2a783223fc9be7135505535f67ade84d984940 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
Date: Fri, 28 Dec 2018 21:35:06 +0100
Subject: [PATCH] Update AppStream metadata to a newer version
---
data/Makefile.am | 2 +-
data/guvcview.appdata.xml.in.in | 29 ++++++++++++++++++++---------
2 files changed, 21 insertions(+), 10 deletions(-)
diff --git a/data/Makefile.am b/data/Makefile.am
index 22055f0..ad14d10 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -28,7 +28,7 @@ desktop_DATA = $(DESKTOP_FILES)
APPDATA_IN_FILES= guvcview.appdata.xml.in
APPDATA_FILES= $(APPDATA_IN_FILES:.xml.in=.xml)
-appdatadir = $(datadir)/appdata
+appdatadir = $(datadir)/metainfo
appdata_DATA = $(APPDATA_FILES)
endif
diff --git a/data/guvcview.appdata.xml.in.in b/data/guvcview.appdata.xml.in.in
index 61ba8c3..de934f7 100644
--- a/data/guvcview.appdata.xml.in.in
+++ b/data/guvcview.appdata.xml.in.in
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!-- Copyright 2014 Paulo Assis <pj.assis@gmail.com> -->
-<application>
- <id type="desktop">guvcview.desktop</id>
+<component type="desktop-application">
+ <id>net.sourceforge.guvcview</id>
+ <launchable type="desktop-id">guvcview.desktop</launchable>
<metadata_license>CC0-1.0</metadata_license>
<project_license>GPL-2.0+</project_license>
<name>Simple UVC Viewer</name>
@@ -16,12 +17,22 @@
that is compatible with any other v4l2 app.</_p>
</description>
<screenshots>
- <screenshot>https://sourceforge.net/p/guvcview/screenshot/guvcview_image_tab.png</screenshot>
- <screenshot>https://sourceforge.net/p/guvcview/screenshot/guvcview_h264_tab.png</screenshot>
- <screenshot>https://sourceforge.net/p/guvcview/screenshot/guvcview_video_tab.png</screenshot>
- <screenshot>https://sourceforge.net/p/guvcview/screenshot/guvcview_audio_tab.png</screenshot>
- <screenshot>https://a.fsdn.com/con/app/proj/guvcview/screenshots/guvcview_video_preview.png</screenshot>
+ <screenshot>
+ <image>https://sourceforge.net/p/guvcview/screenshot/guvcview_image_tab.png</image>
+ </screenshot>
+ <screenshot>
+ <image>https://sourceforge.net/p/guvcview/screenshot/guvcview_h264_tab.png</image>
+ </screenshot>
+ <screenshot>
+ <image>https://sourceforge.net/p/guvcview/screenshot/guvcview_video_tab.png</image>
+ </screenshot>
+ <screenshot>
+ <image>https://sourceforge.net/p/guvcview/screenshot/guvcview_audio_tab.png</image>
+ </screenshot>
+ <screenshot>
+ <image>https://a.fsdn.com/con/app/proj/guvcview/screenshots/guvcview_video_preview.png</image>
+ </screenshot>
</screenshots>
<url type="homepage">http://guvcview.sourceforge.net/</url>
- <updatecontact>assisp@gmail.com</updatecontact>
-</application>
+ <update_contact>assisp@gmail.com</update_contact>
+</component>
--
2.20.1

View file

@ -0,0 +1,89 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - disable distcc - configure checks for clang first and finds distcc's symlink but no clang
pkgbase=guvcview
pkgname=(guvcview guvcview-common guvcview-qt)
pkgver=2.0.7
pkgrel=1
pkgdesc='Simple interface for capturing and viewing video from v4l2 devices'
arch=('x86_64')
url='http://guvcview.sourceforge.net/'
license=('GPL3')
depends=('ffmpeg' 'gsl' 'gtk3' 'qt5-base' 'portaudio')
makedepends=('intltool')
options=('!emptydirs' '!distcc')
source=("https://downloads.sourceforge.net/$pkgbase/$pkgbase-src-$pkgver-2.tar.bz2"
'0001-Update-AppStream-metadata-to-a-newer-version.patch')
sha256sums=('f0d1d7814597d42fddf1655f3654f74efd9f27e35bbe39ee4f0d42683de85c98'
'd9c65a9bf53eb28c48f9a9126035f5ebe520923124eae507d1cb2994e2a0d08f')
noextract=($pkgbase-src-$pkgver-2.tar.bz2) # missing root dir
prepare() {
mkdir $pkgbase
tar xjf $pkgbase-src-$pkgver-2.tar.bz2 -C $pkgbase
cd $pkgbase
# Update AppStream metadata to a newer version
patch -Np1 -i ../0001-Update-AppStream-metadata-to-a-newer-version.patch
autoreconf -fi
cd ..
cp -a $pkgbase{,-qt}
}
build() {
# GTK+ version
cd $pkgbase
./configure --prefix=/usr --disable-debian-menu
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
# Qt version
cd ../$pkgbase-qt
./configure --prefix=/usr --disable-debian-menu --disable-gtk3 --enable-qt5
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package_guvcview-common() {
pkgdesc="Common files for guvcview"
depends=('ffmpeg' 'gsl' 'libusb' 'portaudio')
cd $pkgbase
make DESTDIR="$pkgdir" install
make -C guvcview DESTDIR="$pkgdir" uninstall
make -C data DESTDIR="$pkgdir" uninstall-man1 uninstall-appdataDATA uninstall-desktopDATA
install -Dm644 data/icons/guvcview.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/guvcview.png
}
package_guvcview() {
pkgdesc="Simple GTK+ interface for capturing and viewing video from v4l2 devices"
depends=('guvcview-common' 'gtk3')
cd $pkgbase
make -C guvcview DESTDIR="$pkgdir" install
make -C data DESTDIR="$pkgdir" install-man1 install-appdataDATA install-desktopDATA
sed -i 's/^Icon=.*/Icon=guvcview/' "$pkgdir"/usr/share/applications/guvcview.desktop
}
package_guvcview-qt() {
pkgdesc="Simple Qt interface for capturing and viewing video from v4l2 devices"
depends=('guvcview-common' 'qt5-base')
cd $pkgbase-qt
make -C guvcview DESTDIR="$pkgdir" install
make -C data DESTDIR="$pkgdir" install-man1 install-appdataDATA install-desktopDATA
mv "$pkgdir"/usr/bin/guvcview{,-qt}
mv "$pkgdir"/usr/share/man/man1/guvcview{,-qt}.1
mv "$pkgdir"/usr/share/applications/guvcview{,-qt}.desktop
sed -i 's/Exec=guvcview/Exec=guvcview-qt/
s/^Icon=.*/Icon=guvcview/' "$pkgdir"/usr/share/applications/guvcview-qt.desktop
mv "$pkgdir"/usr/share/metainfo/guvcview{,-qt}.appdata.xml
sed -i 's/net.sourceforge.guvcview/net.sourceforge.guvcview-qt/
s/guvcview.desktop/guvcview-qt.desktop/' "$pkgdir"/usr/share/metainfo/guvcview-qt.appdata.xml
}